PDA

View Full Version : No! Major glitch means I can't complete Hangsha Seaport!



Jamza
24th Dec 2011, 13:14
Hi guys, I've got a really annoying problem in Hengsha Seaport. This is my second time through the game, and this time I'm exploring every corner. I've sunk 25+ hours into this playthrough, but now it looks like I'm permenantly stuck at Hengsha Seaport.

I've collected Tong's bomb since I got the transmission from him, and I can see it in my inventory. All guards and robots have been killed and I've gained access to Wang's office to set the bomb and continue the game. But I can't put the bomb down and get to the cutscene!

I can see the red outline of where the bomb is meant to be placed but when I centre my cursor on it and press the square button (PS3 version), nothing happens! I stand right there with it telling me 0 metres to objective, and nothing seems to happen!

I tried saving the game and reloading, but that didn't work. I also tried exiting the level, returning to Tong's hideout and then coming all of the way back, but it still won't let me set the bomb.

No one has any ideas do they? I googled the problem and it seems no one else has had this. Its so annoying!

Thanks,

Jerion
24th Dec 2011, 20:30
It should bring up a "Are you sure you want to do this now? There's no going back! Y/N" type dialogue, rather than jump straight to the cutscene. Same kind of prompt you would get before leaving an area via Malik's VTOL, for example. Is this happening?

Jamza
26th Dec 2011, 16:49
Thanks for replying. No dialogue comes up unfortunately, I just reach the table and that's it. My cursor tells me its zero metres to the objective, but still nothing happens. It's a pretty strange glitch, I can't think why it wouldn't appear.

Darthassin
27th Dec 2011, 07:37
maybe you did something strange before trying for the first time

Jamza
27th Dec 2011, 13:37
Well, I took out all guards and disabled all security systems. I also arranged a fight between the turret and the robot. For some reason, I then threw the turret downstairs to see what would happen. After all that I just went to the objective and it wouldn't let me complete it. I can't think of any game-breaking behaviour though.

Goodfeller
29th Dec 2011, 08:40
Isn't one supposed to press E to place the bomb ?

Jibbajabba
29th Dec 2011, 09:16
Isn't one supposed to press E to place the bomb ?

He said he got the PS3 version - no E-Button there.