PDA

View Full Version : Batman Arkham Asylum installation error



dharmil007
21st Sep 2011, 14:51
When i m trying to install Batman : Arkham Asylum it gives the following error :


The version of this file is not compatible with version of Windows you're running. Check your computer's system information to see whether you need an x86 (32 bit) or x64 (64 bit) version of the program, and then contact the software publisher.

i M using Windows 7 64-BiT ultimate.

i Have previously installed many games all have worked flawlessly, but i dont know for some reason this is not working.

pls. guyzz help how do i run this game ??