PDA

View Full Version : Temporary fix for Stuttering Issue by disabling PAGE FILE/VIRTUAL MEMORY



triggerhappy686
28th Aug 2011, 12:33
**DISABLE YOUR PAGE FILE**

The page file is an area of the hard disk that is used as if it were RAM. By disabling this it ensures you are using main memory instead of the hard disk. Obvioulsy RAM has a MUCH higher read and write speed than your hard drive, I think this is why people with Solid State Drives are getting better performance too.

The Page File is also called 'Virtual Memory'.

I have JUST found this 'fix' so I am still testing, but ive got work in like 2 hours time so I can't give it all the time just now I would like to :(

I REALLY hope this works for you guys, it gave me a MASSIVE performance boost, now I can have all settings at full including AA, which I had to turn off completly before.

*HOW TO DISABLE YOUR PAGE FILE*

*right click on My Computer and go to Properties.

*from the panel on the left select 'Advanced System Properties'

*in the 'Advanced' tab there are 3 boxes, you want the top one 'Performance', click 'Settings'

*there are 3 tabs in here, click 'Advanced' tab

*there are 2 boxes this time, you want the bottom one 'Virtual Memory', click 'Change'

*untick the box that says 'Automatically manage paging file for all drives'

*make sure 'C' drive is highlighted and select 'No Paging File', THEN PRESS 'SET', CLICK 'APPLY' AND OK/APPLY YOUR WAY OUT OF THE MENUS.

*when promped for a restart select 'Restart Now'

If this works for others, Mod's can your sticky it please. Thanks :D

cyborg34572
28th Aug 2011, 12:53
**DISABLE YOUR PAGE FILE**

The page file is an area of the hard disk that is used as if it were RAM. By disabling this it ensures you are using main memory instead of the hard disk. Obvioulsy RAM has a MUCH higher read and write speed than your hard drive, I think this is why people with Solid State Drives are getting better performance too.

The Page File is also called 'Virtual Memory'.

I have JUST found this 'fix' so I am still testing, but ive got work in like 2 hours time so I can't give it all the time just now I would like to :(

I REALLY hope this works for you guys, it gave me a MASSIVE performance boost, now I can have all settings at full including AA, which I had to turn off completly before.

*HOW TO DISABLE YOUR PAGE FILE*

*right click on My Computer and go to Properties.

*from the panel on the left select 'Advanced System Properties'

*in the 'Advanced' tab there are 3 boxes, you want the top one 'Performance', click 'Settings'

*there are 3 tabs in here, click 'Advanced' tab

*there are 2 boxes this time, you want the bottom one 'Virtual Memory', click 'Change'

*untick the box that says 'Automatically manage paging file for all drives'

*make sure 'C' drive is highlighted and select 'No Paging File', THEN PRESS 'SET', CLICK 'APPLY' AND OK/APPLY YOUR WAY OUT OF THE MENUS.

*when promped for a restart select 'Restart Now'

If this works for others, Mod's can your sticky it please. Thanks :D

I must be one of the really unlucky ones, my Virtualmemory/Pagefile has always been off because i never needed the feature as i have 8gigs of available ram. I still expirience stuttering , ive also tried disabling core parking for my processor cores and adding these graphical settings in the registry (as someone suggested), no luck still, sigh..

david75sk
28th Aug 2011, 13:57
I think this will not work for someone with less than 8GB RAM.

atomMan
28th Aug 2011, 14:02
Does not work :hmm:


--
Intel Core 2 Quad Q9500
Gigabyte EP45-UD3P
NVIDIA GTX 560 Ti / 280.26 WHQL
8GB RAM
Tagan PRII 680W
1TB WD black (AHCI mode)
ASUS Xonar DX 7.1
Win 7 x64

Arksun
28th Aug 2011, 14:07
And again, this seems to tie in with the PC version using page file and NOT main memory, with a fixed usage of about 443mb.

Is anyone at Eidos listening?!?, I think we've found your bug people, the game is using the PC like its a console fixed memory.

Start using more main memory and we wont have this problem!!

david75sk
28th Aug 2011, 14:17
The problem is in CPU usage aswell, take look. Screenshot taken right after playing (alt+tab directly from action).

http://img51.imageshack.us/img51/2042/beznzvu1m.jpg

Silanda
28th Aug 2011, 14:30
And again, this seems to tie in with the PC version using page file and NOT main memory, with a fixed usage of about 443mb.

Is anyone at Eidos listening?!?, I think we've found your bug people, the game is using the PC like its a console fixed memory.

Start using more main memory and we wont have this problem!!

AFAIK, and I'm not a programmer so I stand to be corrected, programs cannot choose to use the page file. Programs can only use virtual memory addresses and which addresses are allocated to RAM or the page file is up to Windows itself. To me it just looks like the game is using a limited amount of RAM with a streaming engine that doesn't handle the background streaming at all well.

Also, one thing I find curious is that it's not using a fixed amount of RAM. Both system and VRAM usage seems to vary between systems, although it is always really conservative.

drewho
28th Aug 2011, 14:36
disabled my pagefile, made absolutely no difference :(

Abram730
28th Aug 2011, 15:47
I don't have stuttering with this game.. I do get it a lot with other games.

I'm guessing it's my HD.. It's a very fast drive, but it's a bit sluggish to respond and that I have DDR2 memory. Also the creative drivers are a bit sluggish due to their fragmented construction.

Oddball test rigs should be used..
including ones where the game is right on the edge of power saving modes(computer too fast for game).
including underclocked mem.. sluggish HD's.. super fast one.. ext(expose programing over sites)
Game engines should test a system for such issues and make contextual game specific profiles for the OS to use while the game is run.

Also
They really need to make DDR5 hardwired memory on MOBO's, with DDR3 slots for extra memory. APU's and CPU's are being held back. Ivy Bridge and fusion will never get to the high end without it.

Fluffis
28th Aug 2011, 16:03
One thing to try, stolen from Saint's Row 2: disable page file, clear the Windows prefetch directory. Reboot, start the game, load a game, quit and restart the game. That solved a lot of stuttering on that game. You'll basically teach Windows to load the game without virtual memory.

atomMan
28th Aug 2011, 16:15
Fluffis ...

Shall I drop some bat's blood before or after clearing "pre-load"

Fluffis
28th Aug 2011, 16:22
Fluffis ...

Shall I drop some bat's blood before or after clearing "pre-load"

Say what?

PreFetch... that's it.

Edit: ah, the "myth" thing? Yes it slows all loading times, but just the first time you run them. And of course it's more effective, the more memory your comp has.

INSTG8R
28th Aug 2011, 16:38
Hehe well that wasn't a bad theory but I had already had my Pagefile disabled and had Window force core to RAM. In fact I thought that may have been the actual issue. re-enabling my Page File made no difference either.

i7 2600k@4,6 HT on
8GB Corsair Vengence 1600 CL9
5870 Vapor-X
2x WD Caviar Black in RAID 0(Sata III)
Win 7 64bit

Sad part is there is absolutely NO frame drop at all and is running at a constant 59-60fps with everything maxed out at 1920x1080 it just has this constant stutter while moving thru city hubs.

Fluffis
28th Aug 2011, 16:43
Hehe well that wasn't a bad theory but I had already had my Pagefile disabled and had Window force core to RAM. In fact I thought that may have been the actual issue. re-enabling my Page File made no difference either.

i7 2600k@4,6 HT on
8GB Corsair Vengence 1600 CL9
5870 Vapor-X
2x WD Caviar Black in RAID 0(Sata III)
Win 7 64bit

Sad part is there is absolutely NO frame drop at all and is running at a constant 59-60fps with everything maxed out at 1920x1080 it just has this constant stutter while moving thru city hubs.

Oh well. It's probably not the same problem as in SR2 (crappy optimization, due to a bad port), but it was worth a shot.

atomMan
28th Aug 2011, 17:09
ye... SR2 was a terrible port. This one is just bad.

Gameplay wise, it's better then most things around,
but I honestly think Carmack would make DE:HR run on P4 3.0GHz and 8800GT with 60fps locked.

brucek2
28th Aug 2011, 17:26
Yes, any time the program(s) you are actively using require more RAM than the amount of physical RAM you have, you are going to take a huge performance hit.

Turning off the page file is one of way of finding out for sure if this is "out of memory" condition is happening, because instead of things slowing up you will just get a big old "Out of Memory" error.

Other than as an occasional diagnostic I wouldn't recommend running this way though. The virtual memory can really help when all you really want to do is have a bunch of different programs open, even though you only actively using a few of them at a time. VM is great for this situation, it is faster than you having to open and close stuff yourself, and its also safer in that you're not risking a program getting a hard out of memory error and potentially handling it in a way that causes you to lose work.

If doing this causes your game performance to increase, it means you had too many any active programs (some of them may be in the background that you didn't know about.) When this happens to me its often some Flash program hidden in a browser window that has gone amok. Anyway you probably could've gotten the same boost by rebooting (to clear all programs) and not starting anything other than the game.

This suggestion also seems at odds with the many other reports saying DX:HR consumes only a modest amount of RAM - a lot of reports are putting it under 500 MB.

Puce Moose
28th Aug 2011, 17:28
Is anyone running this game off of a SSD? I wonder if the faster access speeds would make a noticeable difference in regards to the stuttering.

Fursnake
28th Aug 2011, 18:44
I am running the game off an SSD and I get a bit of microstutter, just enough to notice but not enough to really slow down the game or make it unplayable by any means. I can imagine running the game off an SSD has to be faster than running it off non-SSD drives in general.

Disabling the page file did nothing to improve game performance or reduce the stuttering for me.

My setup:
Crosshair IV Forula Mobo
Athlon Phenom II X4 965 proc OC'd to 3.7 GHz
8 Gigs Kingston Hyper X RAM 1600
Corsair Force GT 120 GB SSD
Sapphire 5970
3x Acer 24" monitors @ 6048x1080 - Eyefinity

tet5uo
28th Aug 2011, 19:54
I'm loading off of a six-SSD raid0 array and still get the stutters. Not unplayably so, but they're definitely noticeable.

Fursnake
28th Aug 2011, 20:05
I'm loading off of a six-SSD raid0 array and still get the stutters. Not unplayably so, but they're definitely noticeable.

Wow, six-SSD raid0 array and still getting the stutters. That really puts it into perspective hehe.

brucek2
28th Aug 2011, 20:29
a six-SSD raid0 array
+1 for awesomeness

tet5uo
28th Aug 2011, 21:02
Yeah got a good deal on some refurbished 120gb Corsair Force SSD's and decided to go for a nice big array I could install all my games on.

It's also on a hardware controller, some nice 2gb/sec sequential read speeds :P