PDA

View Full Version : Delayed gunshot sound effects are driving me insane



lukeman3000
28th Aug 2011, 07:45
Not to be rude, but I bought this game tonight on the basis of the many positive reviews that I've read of it, and yet it seems that no one who has reviewed the game has actually played it!

The FIRST thing I noticed when I got a gun in my hands was that there is a VERY noticeable delay between the muzzle flash and the actual gunshot sound effect. How this passed QC is beyond me.

I have realtek onboard audio (ac1200), and while I know that they are not the most desirable, it has never given me problems with any other game. This includes starcraft 2, crysis, crysis 2, the witcher 2, half life 2.. the list goes on and on (lots of 2s in there lol).

I have updated my audio driver and the problem still exists.

In its current state, I cannot stand to play the game with this sort of glaring issue. It totally ruins the immersion and I cannot focus on anything else but the ridiculous delay that I see when I fire a weapon.

Upon close examination, it seems that the muzzle flash happens almost exactly when the mouse button is clicked, but the gunshot is delayed. In other weapons (like the pistol), it seems that both are somewhat delayed. So while they are both somewhat delayed, the still are in-sync. What would be nice is if there was no delay whatsoever, and everything was in-sync. Is that too much to ask for?

I feel like I wasted 50 bucks, because I just can't enjoy the game like this. And I hope I don't get called picky, or obsessive compulsive, because something like this should not even be an issue. I shouldn't have to settle for something like this.

NKD
28th Aug 2011, 07:51
Works fine here, and I haven't really seen others complaining about it, so on the contrary, it sounds like one of those edge case problems that slip into almost every game. You act like it's completely unthinkable that some minor audio glitch made it into a game. You don't play very many games, it seems. Go to the technical forum, post a bug report.

jtr7
28th Aug 2011, 07:54
Yep. It's your own system. It's not universal.

lukeman3000
28th Aug 2011, 07:59
Works fine here, and I haven't really seen others complaining about it, so on the contrary, it sounds like one of those edge case problems that slip into almost every game. You act like it's completely unthinkable that some minor audio glitch made it into a game. You don't play very many games, it seems. Go to the technical forum, post a bug report.

Actually, I play a fair amount of games. Not so many these days now that school is in session.

Here are just a couple examples of others that I've found who are experiencing this issue:

http://www.youtube.com/watch?v=TVFYQL5zC6Q
http://www.youtube.com/watch?v=27qbN1nx2C0&feature=related
http://www.gamefaqs.com/boards/944090-deus-ex-human-revolution/59659361

Note the comments in the youtube videos as well. I will try posting in the technical forum.