PDA

View Full Version : Flickering Graphic Glitch



blissend
28th Aug 2011, 01:21
I don't know exactly how to describe this so I recorded a small demo of the problem. It shows flickering issues on models and warped flickering I guess you could call it on characters. At higher resolutions that I play in and can record in if need be, it can get really bad.

http://www.youtube.com/watch?v=4S3a3caK7SA
http://www.youtube.com/watch?v=4S3a3caK7SA

Does anyone else experience this? I have a Windows 7 64bit system with an AMD 6970 card (can give dxdiag). I've updated my graphics driver the day the game came out because I was experiencing this issue. I've since tried fiddling with most video settings but not all yet. What else should I try?

Specs...
MS Windows 7 64-bit SP1
AMD Phenom II X4 940 (4 cores 3.0Ghz)
8.00 GB Memory
AMD Radeon HD 6970

blissend
28th Aug 2011, 20:52
I found that the issue gets worse with tessellation off oddly. Have yet to find out anything else.

10hellfire01
28th Aug 2011, 23:19
Oh wow...worst I've seen was dots appearing on characters but that blows right there. All I can think about doing would be a reinstall. Can't think of anything else.

blissend
29th Aug 2011, 16:21
Oh wow...worst I've seen was dots appearing on characters but that blows right there. All I can think about doing would be a reinstall. Can't think of anything else.

I just tried yesterday and to no avail 8( Going to try submitting a ticket for further help.

jaywalker2309
29th Aug 2011, 16:44
Hm that looks like your gpu having some issues, possibly memory read/writes.. are you overclocking the card at all?

The 6970 is a great card, and i've not seen that specific issue before, What cat drivers you running?

blissend
29th Aug 2011, 16:57
Hm that looks like your gpu having some issues, possibly memory read/writes.. are you overclocking the card at all?

The 6970 is a great card, and i've not seen that specific issue before, What cat drivers you running?

I shouldn't be overclocking, never done so before but I double checked the Control Center. The AMD overdrive area still gives me a license I have to accept before being allowed to overclock so it shouldn't be overclocked.

I'm running...
Driver Packaging Version 8.881-110728a-122939C-ATI
Catalyst Version 11.8
Provider ATI Technologies Inc.
2D Driver Version 8.01.01.1178
2D Driver File Path /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0002
Direct3D Version 7.14.10.0855
OpenGL Version 6.14.10.11005
AMD VISION Engine Control Center Version 2011.0728.1756.30366
AMD Audio Driver Version 7.12.0.7702

If its possibly the graphics card, then are there any specific kinds of tests I can do? If I need to provide more info let me know.

PatrickSwayze
29th Aug 2011, 18:27
I'm running on a 6950 myself not overclocked. (i5, 8 gigs of ddr3 ram)

Tried multiple drivers including the 11.8 beta, windows updates, checking the files via steam and I can't fix it.

It's really off putting to be fair.

I don't know if I should continue playing or wait for a new set of drivers or another patch.

What's annoying is that besides the flicker, the game runs and looks great!

Azarnvalo
29th Aug 2011, 20:25
I'm having the exact same problem. I find that turning off SSAO helps to minimise the problem, but not entirely.

I am DESPERATE for this to be addressed in a patch.

System:
Windows 7 Ultimate 64 bit
Intel Core 2 CPU 6420 @ 2.13GHZ 2.13GHZ
2GB DDR2 RAM
PSU: Antec 550W
Drivers: 280.26
CUDA Cores: 240
Graphics Clock: 648MHZ
Processor Clock: 1476MHZ
Memory Clock: 1242MHZ
Memory Interface: 512 Bit
Dedicated Video Memory: 1024MB GDDR3

Gelantious
30th Aug 2011, 06:10
Hmm, seen this type of glitches in other games and usually it's been heat issues of the GPU. The fan/heatsink isn't full of dust? Or you have a very closed case with bad ventilation?
Keep an eye on the temp while playing.

PatrickSwayze
30th Aug 2011, 09:32
Okay. So the problem has spread.

Last night I went to play Dawn Of War 2 (was too tired to play and enjoy DXHR after bank holiday messyness) and I was getting the same flickering problem as I was getting in DXHR. I've now tried Dirt 2 and Just Cause 2 and it appears the problems are now occurring in those games too.

So like Gelatinous says it could be a heat problem, but that shouldn't be the case. I have a well fanned up, well ventilated case that I often clean out with compressed air.

Could this be a corruption problem?

I'm going to try nuking drivers out of my system and seeing if I can get any further, but overall this might just be a case of ****ty ATI/AMD cards yet again.

It's just strange it's happened with DXHR and not any of the other more graphically intensive games :hmm:

blissend
31st Aug 2011, 20:18
Hmm, seen this type of glitches in other games and usually it's been heat issues of the GPU. The fan/heatsink isn't full of dust? Or you have a very closed case with bad ventilation?
Keep an eye on the temp while playing.

Well I cleaned out the whole case, no luck. So fearing the worst I decided to test an older AMD GPU card I have. It ran it without issue. I think my card is dying in this case because with the older drivers it used to work fine but not anymore so I'm going to use my warranty on it to have it repaired and hope for the best.

PatrickSwayze
31st Aug 2011, 22:06
It's definitely the card.

The problem for me has intensified, though I can lessen its impact by ramping my fan speed up.

I guess we're just unfortunate it's happened when Deus Ex has been released.

My card is to be picked up tomorrow under warranty. It's going to be a long wait...

ajd155
31st Aug 2011, 23:50
Your graphics card is toast. RMA time.

Maranelcz
3rd Feb 2012, 19:28
Hi,

I have got problem with flickering graphic glitch. You can see it here: http://youtu.be/M2ktMj7q_ZI

My specs are:

Windows 7 Pro 64 bit
CPU: AMD Phenom II 960T
GPU: ATI Gigabyte HD6950, 1GB DDR5
Memory: Corsair Vengeance 4x4GB
PSU: be quiet! 680W
MB: Gigabyte 990FXA-UD3
Drivers: Catalyst 12.1

I have not made any OC or other modification. I play with all ON (High). When I try to switch to DX10, even with all ON (HIGH), the problem with flickering does seem to disappear.

Do you have any idea where to start with solving this issue?

deemonize
7th Feb 2012, 15:59
Hi,

I have got problem with flickering graphic glitch. You can see it here: http://youtu.be/M2ktMj7q_ZI

My specs are:

Windows 7 Pro 64 bit
CPU: AMD Phenom II 960T
GPU: ATI Gigabyte HD6950, 1GB DDR5
Memory: Corsair Vengeance 4x4GB
PSU: be quiet! 680W
MB: Gigabyte 990FXA-UD3
Drivers: Catalyst 12.1

I have not made any OC or other modification. I play with all ON (High). When I try to switch to DX10, even with all ON (HIGH), the problem with flickering does seem to disappear.

Do you have any idea where to start with solving this issue?


Funnily enough,there was a thread on the nvidia forums regarding shadow LOD,flickering textures and shaders and what not....and everyone put the blame on nvidia's drivers.After almost 20 pages in to the thread,the moderators had locked it,whilst stating that it was not a driver issue but a problem with game engines.

Prime examples:-Gta4,unreal engine games,crysis...and the list goes on.

When the people who understand how graphics are rendered in engine's,blatantly point all fingers at the developers (and their engines) then i will take their word for it.Plus hardware and software on todays computers are so damn varied,that i can see how difficult it would be to cater to the "PC gamer" in general.Especialy multiplatform games being ported to the pc.

6 year old hardware is the baseline for most games nowadays...thats where the problems lie.(and most sales for that matter)

Pasting in a couple of Directx 11 effects just doesn't cover up the fact,that the engine is old and crusty.Just like the console hardware it runs on.

The only solution to the problems with this game,is to update it better support current pc hardware.Not very likely.

Maranelcz
7th Feb 2012, 19:55
Thank you for your reply.

Now I see that the problem with flickering graphical glitch can be deeper without any easy tune up to fix it.

EDIT: I can still see the flickering, as I have tried to switch off DirectX 11 support in the game settings. I need to look further up in the same window as it is in my in-game video. Furmark gives me no errors in screen while stress testing GPU. I am going to try some other game with DirectX 11 support to see the behavior.

Maranelcz
9th Feb 2012, 10:17
I have tried some other games: Mafia II demo, Civilization V demo, Battlefield 3 and I do not experience similar flickering graphical glitch.

Problem remains with Catalyst drivers: 12.1 and 11.11.

I have tried some other GPU stress test (MSI Kombustor) and GPU burn-in test gives me no artefacts in shown object.