View Full Version : [PC] Weird graphics issue. Screenshot inside.

27th Aug 2011, 18:29
Okay, so I installed the game from a retail DVD and got everything activated with Steam. Opening cutscene worked fine, but as soon as I actually got control this happened->


Running Windows 7 64 Bit on an Intel Duo P8400 at 2.26/2.27GHz with 2GB RAM and two Radeon HD3870s in XFire.

Controls, sound, menus and everything else all seem to work fine, but the graphics just aren't there. Been looking around the web all afternoon and not found anything else like this. After playing around with Catalyst settings and updating drivers I uninstalled the game and am current reinstalling via Steam download to see if that makes a difference.

27th Aug 2011, 18:31
Looks like something didn't unpackage right or something. Would recommend downloading it.

27th Aug 2011, 18:35
It did take my DVD drive four or five attempts to recognise the disk, so I'm really hoping its just that and that downloading from Steam will solve the problem.. 3870s are still pretty widely used, and I've not seen complaints about them anywhere else..

27th Aug 2011, 23:30
Well, reinstalling did nothing, but I managed to fix it by fiddling with random graphical settings. Turning SSAO and DOF worked this time, with FXAA high and shadows normal, but if I try and turn VSync off, turn anti-aliasing down or change texture filtering at all it just breaks again. This is making absolutely no sense.

28th Aug 2011, 00:05
Turned Catalyst Control Centre off and the problem in the screenshot is gone. Now I just get crashes with the 'system may not have enough resources' message whenever I turn antialiasing or texture filtering down from the settings it gives me by default.

2nd Sep 2011, 03:44
Did you figure this out? I am having the exact same problem and it is very annoying.
My gpu's specs are pretty low end but the game runs fine on low settings. Other new games run fine as well, which leads me to believe that something is wrong with the game but I cant be sure.
Messing around with the video settings sometimes gets it to work but there doesn't seem to be any specific one that makes it work.
If there is any info or help you could give me, please don't hesitate!

space ghost
2nd Sep 2011, 15:55
See this thread...