PDA

View Full Version : Stuttering and my thoughts on the issue



ianbryan744
27th Aug 2011, 15:33
Just as many others have posted, I'm here to report my issue of stuttering. Let me be clear on my PC/knowledge of computers before I discuss the stuttering. I'm a pretty avid PC user, I regularly update drivers, etc. My computer is also quite good: Intel i7 930, 8GB DDR3 RAM, GTX 470, and 10K RPM Western Digital Raptor HDDs x2.

I pre-ordered the game on Steam and pre-loaded it as well, so as soon as it unlocked the night of release, I decrypted the files and began playing. Let me assure you all: I didn't have ANY stuttering AT ALL my first playthrough. I spent a total of around 30 hours over the next two days playing, and never once had any sort of issues with stuttering.

Today I decided to start my Pacifist run, and the game was playing normally until I entered the Detroit city hub. That's when I started noticing brief stuttering with video and audio. Very quick stutters, maybe only a fraction of a second long, but quite noticeable. At first I thought it was some sort of program in the background causing the stuttering, so I alt-tabbed and checked to see if I left some other game open accidentally (I was playing Crysis 2 earlier), but I didn't, so I saved and closed the game. I re-opened the game and loaded my save, and began playing again. For a few moments it was fine, and I thought it must have just been some fluke. However as I kept playing and continued through the Detroit City hub, it began stuttering, as if it was loading the city improperly. I was a bit puzzled, and decided to restart my PC. I did this and loaded the game again after everything booted up properly and tried playing again. Still stuttered.

I'd like to point out that my first playthrough occurred before the patch was released that sped up loading times. I know this is correct, because I remember the loading times being longer than most loading times in any PC game, and since my PC is fairly high-end, it didn't make sense to me. After beating the game I took a break. I didn't play anymore for a few days.

What I think has happened, and this is purely speculation, is whatever patch that was introduced to speed up loading times has negatively impacted the performance in-game somehow. All I know is, these problems didn't occur prior to these patches on my system. My guess is before the patch, you would load 100% of the level, and then play it, and that caused the high loading times. Now with the latest patch, for the sake of this hypothetical guess, let's say that only 50% of the level is loaded, and as you progress, it begins loading the other 50% as you advance. This wouldn't usually be an issue if you were in an actual mission with enemies, however in areas such as the Detroit City Hub, the player moves through this level quite fast, and maybe moving faster than the game can load.

I have no idea if what I've said is accurate in anyway, it's just what I think may be the issue.

tet5uo
27th Aug 2011, 15:44
The patch didn't change anything for me. The stuttering when moving to new areas or looking at one is still the same as it ever was.

Annoying.

XXBladeRunner
27th Aug 2011, 15:53
Just as many others have posted, I'm here to report my issue of stuttering. Let me be clear on my PC/knowledge of computers before I discuss the stuttering. I'm a pretty avid PC user, I regularly update drivers, etc. My computer is also quite good: Intel i7 930, 8GB DDR3 RAM, GTX 470, and 10K RPM Western Digital Raptor HDDs x2.

I pre-ordered the game on Steam and pre-loaded it as well, so as soon as it unlocked the night of release, I decrypted the files and began playing. Let me assure you all: I didn't have ANY stuttering AT ALL my first playthrough. I spent a total of around 30 hours over the next two days playing, and never once had any sort of issues with stuttering.

Today I decided to start my Pacifist run, and the game was playing normally until I entered the Detroit city hub. That's when I started noticing brief stuttering with video and audio. Very quick stutters, maybe only a fraction of a second long, but quite noticeable. At first I thought it was some sort of program in the background causing the stuttering, so I alt-tabbed and checked to see if I left some other game open accidentally (I was playing Crysis 2 earlier), but I didn't, so I saved and closed the game. I re-opened the game and loaded my save, and began playing again. For a few moments it was fine, and I thought it must have just been some fluke. However as I kept playing and continued through the Detroit City hub, it began stuttering, as if it was loading the city improperly. I was a bit puzzled, and decided to restart my PC. I did this and loaded the game again after everything booted up properly and tried playing again. Still stuttered.

I'd like to point out that my first playthrough occurred before the patch was released that sped up loading times. I know this is correct, because I remember the loading times being longer than most loading times in any PC game, and since my PC is fairly high-end, it didn't make sense to me. After beating the game I took a break. I didn't play anymore for a few days.

What I think has happened, and this is purely speculation, is whatever patch that was introduced to speed up loading times has negatively impacted the performance in-game somehow. All I know is, these problems didn't occur prior to these patches on my system. My guess is before the patch, you would load 100% of the level, and then play it, and that caused the high loading times. Now with the latest patch, for the sake of this hypothetical guess, let's say that only 50% of the level is loaded, and as you progress, it begins loading the other 50% as you advance. This wouldn't usually be an issue if you were in an actual mission with enemies, however in areas such as the Detroit City Hub, the player moves through this level quite fast, and maybe moving faster than the game can load.

I have no idea if what I've said is accurate in anyway, it's just what I think may be the issue.

I have to agree with this post. The moment the stuttering began on my system, i put it down to loading issues.
My PC is above and away beyond the specs required for this game. My PC does not even break a sweat running it on max settings. The stuttering seems to happen at keypoints on the maps, again and again the same places. As if certain checkpoints load the game. Ive seen it on to many other games for it to be anything else.

The patch introducing these issues would make alot of sense to why some people are having them and some are not. The reason being alot of people don't always patch there games to latest when it arrives incase of issues, some from retail do not know how, others who use steam like myself, auto patcher does it for you.

It really needs to be addressed now. Ive put the game aside. I can not play it like this.

Heinosity
27th Aug 2011, 16:04
Just as many others have posted, I'm here to report my issue of stuttering. Let me be clear on my PC/knowledge of computers before I discuss the stuttering. I'm a pretty avid PC user, I regularly update drivers, etc. My computer is also quite good: Intel i7 930, 8GB DDR3 RAM, GTX 470, and 10K RPM Western Digital Raptor HDDs x2.

I pre-ordered the game on Steam and pre-loaded it as well, so as soon as it unlocked the night of release, I decrypted the files and began playing. Let me assure you all: I didn't have ANY stuttering AT ALL my first playthrough. I spent a total of around 30 hours over the next two days playing, and never once had any sort of issues with stuttering.

Today I decided to start my Pacifist run, and the game was playing normally until I entered the Detroit city hub. That's when I started noticing brief stuttering with video and audio. Very quick stutters, maybe only a fraction of a second long, but quite noticeable. At first I thought it was some sort of program in the background causing the stuttering, so I alt-tabbed and checked to see if I left some other game open accidentally (I was playing Crysis 2 earlier), but I didn't, so I saved and closed the game. I re-opened the game and loaded my save, and began playing again. For a few moments it was fine, and I thought it must have just been some fluke. However as I kept playing and continued through the Detroit City hub, it began stuttering, as if it was loading the city improperly. I was a bit puzzled, and decided to restart my PC. I did this and loaded the game again after everything booted up properly and tried playing again. Still stuttered.

I'd like to point out that my first playthrough occurred before the patch was released that sped up loading times. I know this is correct, because I remember the loading times being longer than most loading times in any PC game, and since my PC is fairly high-end, it didn't make sense to me. After beating the game I took a break. I didn't play anymore for a few days.

What I think has happened, and this is purely speculation, is whatever patch that was introduced to speed up loading times has negatively impacted the performance in-game somehow. All I know is, these problems didn't occur prior to these patches on my system. My guess is before the patch, you would load 100% of the level, and then play it, and that caused the high loading times. Now with the latest patch, for the sake of this hypothetical guess, let's say that only 50% of the level is loaded, and as you progress, it begins loading the other 50% as you advance. This wouldn't usually be an issue if you were in an actual mission with enemies, however in areas such as the Detroit City Hub, the player moves through this level quite fast, and maybe moving faster than the game can load.

I have no idea if what I've said is accurate in anyway, it's just what I think may be the issue.

When I first fired up the game and played it (release day), I didn't really have a chance to play it very long, but I know I did not have these stuttering issues. I just now started a new game and went through the beginning again, and sure enough, I experienced the same amount of stuttering that I do in my current game where I am running through the streets of Detroit. So, it doesn't matter where I am in the game. Every few steps I take it stutters with the hard drive light going ape****, while in between those stutter moments I am getting a solid 60 FPS locked with vsync on.

I really hope this gets fixed soon...it is such a good game, and I want to play really bad, but I just can't right now because of this. It just ruins the whole experience. :(

Tommando
27th Aug 2011, 16:08
I was definitely having the framerate slowdown issue prior to the patch that reduced loading times. Tuesday I didn't notice it, but then I only played up through the first big mission that day; Wednesday, I left Sarif Industries for the first time and it became very apparent.

jeremygrim
27th Aug 2011, 17:04
Yep, it's worst in detroit for me too, I think that's because it's stuttering when new objects / areas are entering the screen and in isolated places like Sarif industries or the first mission, its apparent when going to new areas but clears up right after that. In detroit, new objects / areas are constantly being introduced so it becomes unplayably stuttery.

ianbryan744
27th Aug 2011, 17:24
Yep, it's worst in detroit for me too, I think that's because it's stuttering when new objects / areas are entering the screen and in isolated places like Sarif industries or the first mission, its apparent when going to new areas but clears up right after that. In detroit, new objects / areas are constantly being introduced so it becomes unplayably stuttery.

I think this accurately describes the problem we all seem to have. If the load time patch somehow affected this, that might be the issue right there. Honestly I didn't mind the load times before they were fixed, they were unusually long, but not long enough to trade it for stuttering.