PDA

View Full Version : DirectX 11 refresh rate stuck at 59Hz!



Phnxsmv
26th Aug 2011, 12:28
I cannot change the refresh rate for directx 11. There is no other selection available. I'm running Windows 7.

Xsquader
26th Aug 2011, 12:38
I had the same problem. Its not a big deal unless A. you don't like your monitor going whacky while alt-tabbing or b. you are trying to stream the game. My solution was not to change the refresh rate to 60 hz (I couldn't either) but to change my desktop refresh rate to 59 hz by right clicking my desktop selecting screen resolution going to advanced options and setting the refresh rate to 59 rather than 60. Hope this helps :)

Phnxsmv
26th Aug 2011, 12:47
I had the same problem. Its not a big deal unless A. you don't like your monitor going whacky while alt-tabbing or b. you are trying to stream the game. My solution was not to change the refresh rate to 60 hz (I couldn't either) but to change my desktop refresh rate to 59 hz by right clicking my desktop selecting screen resolution going to advanced options and setting the refresh rate to 59 rather than 60. Hope this helps :)

Well, it is a known (and still unfixed) Win 7-problem that you cannot set your desktop refresh rate to 60Hz (stuck at 59Hz). I have solved it by setting a user-defined resolution and refresh rate in the nvidia control center. So, my desktop is at 60Hz but the game won't let me play at that rate. I guess the problem is that the directx 11 function under Win 7 does not let the game run on 60Hz. So the developers have to create a workaround, I guess.
The real problem is that I do not like my computer playing me for a fool by doing what he wants, so to speak. :D

Xsquader
26th Aug 2011, 13:24
Well, it is a known (and still unfixed) Win 7-problem that you cannot set your desktop refresh rate to 60Hz (stuck at 59Hz). I have solved it by setting a user-defined resolution and refresh rate in the nvidia control center. So, my desktop is at 60Hz but the game won't let me play at that rate. I guess the problem is that the directx 11 function under Win 7 does not let the game run on 60Hz. So the developers have to create a workaround, I guess.
The real problem is that I do not like my computer playing me for a fool by doing what he wants, so to speak. :D

Never heard of that one. I usually run windows 7 64 bit and it allows me 60 hz and 59 hz. However I did notice something weird. When I was trying to switch my desktop from 60 hz to 59 hz in CCC it kept resetting itself back to 60. I could only set my refresh rate to 59 through windows not my CCC. Although as long as the refresh rates of your desktop and the game match there should be no issues. 59 hz and 59hz shouldn't make a difference. But if you want 60hz some people say they have it but I don't nor could I figure out how. I even tried adjusting it in the registry and it would always reset itself when launching the game.

Xsquader
26th Aug 2011, 16:12
I fixed this problem by going back to Windows 7. (Was using Windows 8)

Phnxsmv
26th Aug 2011, 16:53
I fixed this problem by going back to Windows 7. (Was using Windows 8)

I don't understand.