PDA

View Full Version : directx 11 issues



Gorty
26th Aug 2011, 07:50
Hey

First off al, thx for the game. But i am having 1 big issue: activating directx 11

Before people start to shout out 'update drivers' and 'can you even support it', my both answers on this is: YES
i have a ati radeon 4870x2, windows 7 64 bit with service pack 1 and... directx 11 support
My drivers are updated to the latest versions and every other game i have i can run in directx 11 without problems.

I checked the compatibility of Deus Ex aswell Steam and both are running in windows 7 and as administrator.

Now whats my prob: I never get the option to check on directx 11 throught the setup aswell ingame. Ingame the option directx11 is just red marked.

any suggestions/explanations are welcome.

greets
Gorty

jaywalker2309
26th Aug 2011, 08:05
Hate to say but the Radeon 4870 is a 10.1 card, NOT a full DX11 card. it released right at the beginning of DX11 coming out, but didnt support every feature to be able to get called an official DX11 card. DXHR requires a full DX11 compliant card

http://en.wikipedia.org/wiki/Radeon_R700

Gorty
26th Aug 2011, 08:18
Guess DE is the first game then where i feel my pc is getting out dated.

Thx for the fast reply.

greets
Gorty

jaywalker2309
26th Aug 2011, 08:36
Know what you mean.. I've still got a pc with an nVidia 8800 GTX.. its probably one of longest lasting cards around :) but its old..

nukedukem
26th Aug 2011, 11:29
Don't worry, you arent missing much. Lots of people like myself cant play in DX 11 because the game constantly freezes and crashes in it, forcing us to turn off the option even when we have it!

widget21
26th Aug 2011, 17:44
Hey all, to pick up where it was left off... :mad2:

Card is an AMD Radeon HD 6970. latest Cata 11.6, checked 11 minutes ago.

My Direct X 11 is also un-tickable in setup, greyed out in options. :confused:

I see some ppl are recommending leaving it off, but it would be nice to atleast have the option.

Any ideas? :scratch:


Cheers.
Widget21

Blastermaximus
30th Aug 2011, 20:04
I have a Radeon 5870 and I was able to get DirectX 11 to run but I also have a visual problem that is a double image / shadowing / ghosting that makes playing a disaster. When I turn off DX 11 the graphics clear up.

jimo
31st Aug 2011, 08:36
@widget21 What OS are you on? DirectX 11 is only supported on Vista and 7

@Blastermaximus If you're comfortable with using regedit, check that StereoMode is set to 0 in HKEY_CURRENT_USER / Software / Eidos / Deus Ex: HR / Graphics. This seems to fix the double image problem for other people.

Blastermaximus
1st Sep 2011, 00:14
@widget21 What OS are you on? DirectX 11 is only supported on Vista and 7

@Blastermaximus If you're comfortable with using regedit, check that StereoMode is set to 0 in HKEY_CURRENT_USER / Software / Eidos / Deus Ex: HR / Graphics. This seems to fix the double image problem for other people.

i TRIED THE REGISTRY FIX BUT FOUND THAT STEREOMODE WAS ALREADY SET TO 0, WHEN I TRIED dx11 AGAIN I found that double image was still there, so I am back to no DX 11 with a Radeon 5870 card ;(, would appreciate any more ideas as i am very surprised I would have any unique stuff (Win 7, modern graphics card, etc. Thanks Stephen