PDA

View Full Version : Using HD3D Compatible Card, Compatible Monitor, and Latest Drivers... 3D Greyed Out



akihabara
26th Aug 2011, 05:52
I've got a SAPPHIRE Radeon HD 5870(an AMD HD3D Compatible graphics card), a Samsung S27A950D display(an AMD HD3D Compatible 3D display), and I'm running the latest Catalyst drivers(11.8).

However, when I launch the Deus Ex Setup Tool, "Stereoscopic 3D" is greyed out. In game, the menu option is red and unselectable.

AMD's site has literally zero information on this, and there's nothing I can find here either. Is there some step I'm missing here?

skyguy
26th Aug 2011, 06:09
Switch between the DisplayPort and HDMI ports before launching setup and see if it helps. VGA will disable HD3D. Displayport will run at 1080p 60Hz and HMDI will max out at 1080p 24Hz or choose 720p 60Hz.

HD3D requires DX11 to be enabled.

akihabara
26th Aug 2011, 06:32
I'm using the DVI-D cable that came with the monitor. Is 3D not supported over this at all? I've tried both DVI ports on my card, no change in behavior.

skyguy
26th Aug 2011, 06:38
DVI does not support HD3D.

AMD HD3D quad buffer stereo 3d is designed to work with the DisplayPort connection (best) or the HDMI connection.

ms307
26th Aug 2011, 19:56
I am having the same issue. I have the same monitor, the Samsung S27A950D, and a Radeon 5970. I've tried using a dual link DVI cable as well as a displayport cable. Neither allows me to select stereoscopic 3d in the setup window or in the game.

jhunsi
28th Aug 2011, 00:41
Same here with my HD5970.
I have two DVI connection and a Mini DisplayPort. (DP+) connection.
Tried all, but none would allow me the use of S3D.

.......and yet all the Nvidia users think they've left out of the S3D option.

would Eidos explain why?

micla
28th Aug 2011, 02:53
Same issue for me here, also on hd5970 and syncmaster t27a950 ( see a topic i started ) I also use a 1.4 hdmi cable with a Dp-adapter. Still no luck in getting 3d options enabled. i'm happy ( in a way ) that i'm not the only one. maybe it will be resolved in later patches. ( i hope so :rolleyes: )

akihabara
28th Aug 2011, 04:33
Update: Displayport cable came in from Amazon today and... absolutely no change in behavior.

Glad(kind of) to see I'm not the only one with the issue.

Maybe post specific manufacturer of the cards affected so far in case it's meaningful?

SAPPHIRE Vapor-X 100281VX-2SR Radeon HD 5870 1GB

micla
28th Aug 2011, 15:47
Good idea, maybe we get something out if it.

Mine is a Sapphire HD5970 OC edition, my specific monitor type is LT27A950EX/EN

I've already sent a message to Samsung Netherlands and AMD Netherlands with the question to please look in to it. I also have pointed out that my monitor is on the combatability list and that there are others with same isseus.

If enough people with simalar problems will do also, mayby we get a fix for it. So cry out at devs and manufactures and let them know !!!

WE WANT 3D !!!!!!:lmao:

ms307
28th Aug 2011, 17:09
I have a standard reference design 5970 from HIS. I'm wondering if AMD still has not provided quad buffering support for these monitors. Support was mentioned in the 11.8 driver preview, but it's not listed in the release notes for the official 11.8 driver release.

micla
28th Aug 2011, 19:15
I managed to get it to work now with the catalyst 10.11 drivers by disabling the ai setting. ( In my case with the 5970 it disables my 2nd gpu.) In the gamemenu as wel in the game itself i can now use the stereoscopic options. However the stereoscopic effect is really awfull, like in crysis 2. It looks no way neer the quality of avatar. Everything is just in de background with a minimum of depth, ( yes the depth slider is up all the way ) only the hud stuff is placed more in front of the screen.

should it be this way? because if this must be amd's answer to 3d vision they have a lot of development to do.

Back to the Tridef software and another playtrough of Avatar. Damn, i was so hoping this game would be freaking owsome in real 3d, but apparantly it's not. I Guess i'll have to wait till i have a videocard wich is fast enough to run it wit DDD. Anyone know of a Tridef profile yet ??

p.s. The game is running excellent on this driver though, completly flawless at 60 fps vSync on just 1 GPU. no more hicckups, with and without 3d..

akihabara
30th Aug 2011, 05:26
Hi Micla,

so you had to roll back all the way to catalyst 10.11 drivers to get this to work? this isn't an acceptable work around for me because DXHR is not the only game that I play, and I don't want to sacrifice performance in other games just to do something I should be able to out of the box.

Can we get some feedback from Eidos on this?

micla
30th Aug 2011, 13:34
Yeah, all the way back to to 10.11 . That's the latest catalyst where im able to turn of my 2nd gpu through the ai setting. In ALL later versions this option is not there anymore. For me it's also the only way to work with the DDD Tridef software, they also do not support crossfire. I've maild amd several times about this issue, and that i want a modified driver from them that lets me work with those ai settings again, but i never had a answer back.

But in your post you are saying that your on a 5870, witch is a single gpu card. So this isseu should not apply you, and stereoscopic settings should just be available. Unless you have two of them in crossfire. But then you should be able to simply turn crossfire off in the CCC

For me this was my last time buying a dual gpu card. It's crazy that people who bought the most expensive card on the market ( for me it was the HD5970, now it's the HD6990 ) can not use that card where it's needed the most: in 3d gaming, if its not due to lack of support for crossfire, it is to unbelievable stupit unthought driver changes witch make it impossible to overcome the crossfire problem in the fist place:mad2:

peteben
30th Aug 2011, 17:10
This might help somebody. By reading some AMD SDK documentation, I figured out that the only thing that was preventing me from running with native HD3D was my projector. It was not recognized as a 3D device. I created a new EDID override with a .inf monitor file, enabling the projector as a frame sequential device, and now it works.
So you might want to verify what kind of EDID info your monitor is returning to the driver. If it is not reporting as 3d capable, HD3D will not work. So, you either need to hack the .inf file or get the right one for your monitor.

My setup:
Win 7x64
Sapphire 6950
BenQ MW512 connected through VGA at 120hz.

Pete

akihabara
1st Sep 2011, 23:32
Bump.

I'm using hardware all explicitly stated to work with 3D in this game and I can't even enable it.