PDA

View Full Version : SYSTEM REBOOT DURING VIDEOS - Resolved



XenocideQ
25th Aug 2011, 14:34
[RESOLVED]
"Great news everyone" -Farnsworth

It appears that Deus Ex and Steam don't play nicely together. At least not on my system. I was able to fix, or at least work around the problem I was having by setting the processor affinity of Steam and Deux Ex so they run on separate cores.

Steam on Core 7
Deus Ex on Core 0-6

Which cores they run on probably doesn't matter so long as they don't over lap.

IMPORTANT:
I was unable to launch Deus Ex with steams affinity set to Core 7. So keep steam running on all cores, launch Deus Ex, than alt+tab out of the game as soon as you're able. The game doesn't appear to crash once you've alt+tabbed, so you can take your time after that.


Best luck to everyone, I wouldn't hesitate to try this to fix other bugs, I have no idea why this works, but it does.

[ORIGINAL POST]
Hey,

I guess I could have just made a post in that ginormous CRASH/FREEZE thread but the majority of those people seem to be experiencing a distinctly different issue (but some are having the same issue as myself). So I thought I'd start a new thread in hopes we can figure what's going on (or maybe spur Eidos into addressing this issue as well).

The Issue:
My system will do a complete reboot during videos. There are no blips, audio loops, or screen freeze. I'm watching a video and then BAM! screen goes black, I hear my computer POST and I realize I am no longer in Kansas.

The reboot doesn't always occur at the same time. It has happened during the Logos at the start, and it has happened during the intro cut-scene. Again, there does not appear to be an exact moment when it occurs in any given cut-scene.

I haven't done a ton to try to resolve this but I have tried a handful of things that people have suggested (though these have been suggestions to fix other problems).

Things I have tried:
-Dx11 On
-Dx11 Off
-Maxed Graphical Settings
-Default Graphical Settings
-New Windows User
-Updated all drivers

I read in the crash forum that some people have had success (again for other issues) with setting the CPU affinity for Steam / Deus Ex to a single core. I haven't tried this yet, but it is the first thing I will try when I can (I can't try it now because... uhuh... I'm skydiving... yea, skydiving). I noticed that in the other thread most of, if not all, the people experiencing this issue were running i7s so, I dunno CPU affinity sounds promising.

My System:
Graphics: ASUS ENGTX580 DCII <3
Processor: Core i7 920
Motherboard: EVGA 58x 3xSLI
RAM: 6GB of... OCZ something something


Lets get this sorted, this game loots so freak-en cool. And really playing it through without cut-scenes would... no, just no...

XenocideQ
25th Aug 2011, 23:50
Bump for work around.