View Full Version : Game Not Starting in 64-Bit Win7

25th Aug 2011, 01:37
EDIT: Problem solved! Thanks a lot to Arkose (http://forums.steampowered.com/forums/showpost.php?p=24613065&postcount=4).

Bear with me. I intend to give as thorough and detailed description of the issues as I can. I do so because through my searches in the technical support forums (both Valve and Eidos), I have seen not seen as yet any issues similar to mine, nor has the little bit of personal support I've received so far been of much use (seen below). So I hope this will be able to help some users.

First off, my system configuration is this:
OS: Windows 7 Ultimate 64-bit Version
Processor: Intel Core2Quad Q9300, 2.50GHz
Video: Nvidia GeForce 9800 GT
RAM: 4.0 GB

I pre-ordered Human Revolution 5-7-11. Prior to launch, on 8-21, I reinstalled my entire Windows operating system, followed by the necessary hardware drivers, then Steam. Windows is fully updated, however SP1 is still not installing properly. I've found this is a Microsoft problem that is yet to be fixed.

So right now I am starting with a clean install of Windows and Steam.

I had the game pre-installed via Steam on 8-22. The following day, on 8-23, I had to reinstall the full game because of an unknown update issue. After finally completing that installation, I tried to run the application through Steam.

During the Steam prompt that says "Installing: Microsoft VC Redist Package (step 1 of 2)" I received the following two errors:

The program or feature "\??\c:\program files (x86)\steam\steamapps\common\deus ex - human revolution\redist\vcredist\vcredist_x86.exe" cannot start or run due to incompatibity with 64-bit version of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

The program or feature "\??\c:\program files (x86)\steam\steamapps\common\deus ex - human revolution\redist\dx90c\DXSETUP.exe" cannot start or run due to incompatibity with 64-bit version of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

After this happened, it was off to the forums to find help. Both tech support forums only had some generic issues, so I tried anything remotely applicable to my problem. I then sent an email to Eidos tech support. This morning I got this reply:

"Unfortunately, the game is locked through Steam until its official release date which is 1201 AM GMT on the morning of Friday 26th August.

Please try again after this time."

Clearly this is incorrect. This is the EU release date, not US. Good job Eidos. So I am skipping that and moving on.

[U]Attempted Fixes:
Searching technical support forums from both Steam and Eidos. I found no entries duplicating my exact issue.
Attempted running the game under a new user.
Searched for these files: "C:\Windows\SysWOW64\atiadlxy.dll" and "C:\Windows\SysWOW64\atiadlxx.dll". They are not on my system. I DO have the files "atidxx64.dll" on my system, but since these are not the exact same as the ones posted, I avoid deleting these to avoid damaging my system.
Manual installation of vcredist_x64.exe directly from the Microsoft website.
Manual installation of the latest Direct X drivers from the Microsoft website.

At this point I feel pretty confident that I've taken every action I could to fix the problem, and it still hasn't worked. I have found some users are having similar (but not the same) issues who are also on 64-bit systems. I found a single post that has a similar issue here: http://forums.eidosgames.com/showpost.php?p=1656618&postcount=10

The only other solution I can personally come up with is to reinstall Windows 7 in 32-bit mode instead (I have OEM disks with both versions) -an option I'd try to avoid. If anyone could give me any further clues that would be great.

P.S. If anyone could point me to an Eidos tech support feedback page, that would also help.

25th Aug 2011, 07:42
Okay first thing that shouts out `possible area of problem` with some of your issues is the SP1 not installing `correctly`.. this suggests your Windows is in a bit of a flux.. i had issues with SP1 on my 64bit Windows, and i had to get a `fixit` thing from MS to correct the problem, then suddenly i had updates available to me (post SP1) and things all have been fine.

Windows will do a lot to stop things working if it thinks theres a problem in ITS backyard..

I run Windows 7 64bit with SP1 all working, and i've been involved in the development of the game so every version has been installed/tested on my machine during the development cycle..

Have you tried running steam as admin?.. also have you checked event viewer to see what error its logging?