View Full Version : ATI dll problem unsolved

24th Aug 2011, 08:39
I've got an ATI dll issue. I've tried everything listed in the technical issue sticky, and I still can't seem to get it to work. I've updated to latest drivers. I've also tried renaming the ATI dll's (effectively removing them from the folder sysWOW64). I've copy and pasted my error popup details below, hopefully someone can make some sense of it. I had a copy of the Beta/Leaked build back when it came out, and it ran fine. I pre-purchased this copy on Steam and had it pre-loaded. I thought that might have been an issue, so I deleted all local files and redownloaded, but to no avail. I have verified the integrity of the game cache, which then prompted Steam to download an update, but no dice. While I have resorted to buying a second copy of DX:HR for the Xbox 360, I'd really like to get this working on the PC so that I can play this wherever on my laptop.

Problem signature:
Problem Event Name: BEX
Application Name: dxhr.exe
Application Version: 1.1.620.0
Application Timestamp: 4e53c8bd
Fault Module Name: atiadlxy.dll_unloaded
Fault Module Version:
Fault Module Timestamp: 4a78f625
Exception Offset: 00b655b0
Exception Code: c0000005
Exception Data: 00000008
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

24th Aug 2011, 08:44
What graphics card do you have?

24th Aug 2011, 09:05
I have an ATI Mobility Radeon 4650.

24th Aug 2011, 09:10
If you have an ATI card, you shouldnt be touching those files as they are relevant to your hardware.. Try reinstalling the latest drivers.. reboot and try again?

24th Aug 2011, 09:12
Oh, okay, let me give that a shot.

24th Aug 2011, 09:53
Sorry, that didn't work. I reinstalled drivers, and undid the "backup" dll change, and still no progress. I'm getting the same error.

24th Aug 2011, 10:06
What driver version have you installed Cat 11.8?

24th Aug 2011, 13:06
I'm getting the same error. I'm using a AMD M880G with ATI Mobility Radeon HD 4200 on Windows 7.
Windows says my driver version (8.634.0.0) is up-to-date.

24th Aug 2011, 13:42
My drivers are as up-to-date as humanly possible. I have a Sony laptop and they've made it impossible to update drivers unless it's through them. Sony doesn't like releasing updates for the video cards they've put into their machines, so my drivers are updated to 8.635.0.0 and they can't be updated any further. I've tried using the 11.8 update but the program will actually finish with a message that tells me that I can't update my drivers.

24th Aug 2011, 13:47
:( thats a bit of a problem as 2009 drivers are really outdated and will definitely mean issues will happen as you can see

http://support.amd.com/us/gpudownload/windows/Pages/auto_detect.aspx <- does this tool from amd not allow you to get supported drivers?

24th Aug 2011, 13:51
That tool downloads 11.8 and then attempts to install it. Unfortunately, that results in the aforementioned screen informing me that my drivers cannot be updated. Out of curiosity, would there be a reason why the leaked build worked fine, but the full game doesn't? (Note: I don't support piracy, and if anything, it made me want the game more, and I also ended up buying 2 copies.)

24th Aug 2011, 14:41
I have a very similar issue, although my driver is at version 8.872.0.0.

Faulting application name: dxhr.exe, version: 1.1.620.0, time stamp: 0x4e53c8bd
Faulting module name: aticfx32.dll, version:, time stamp: 0x4e1679a8
Exception code: 0xc0000005
Fault offset: 0x0005118e
Faulting process id: 0x1748
Faulting application start time: 0x01cc626b6274d1dd
Faulting application path: c:\program files (x86)\steam\steamapps\common\deus ex - human revolution\dxhr.exe
Faulting module path: C:\Windows\system32\aticfx32.dll
Report Id: a4e0db02-ce5e-11e0-ae97-e0cb4eb7300b

However, I've found some less than ideal ways to get the game to run. I have two monitors, one a 19" and the other a 24". I generally default to the larger of the two, but if I select the 19" in Deus Ex setup, it will run and work correctly. Also, if I unplug the smaller monitor I become able to play on my main monitor.

24th Aug 2011, 14:44
have you tried;

This is from the technical summary: "Users experiencing a crash on launch relating to a ATI dll file.. for nVidia users this seems related to a file in the system32 or syswow (syswow64) folder under the Windows folder (depending if 32bit or 64bit). For a temporary workaround, Locate the atiadlxy.dll and atiadlxx.dll file in the folder and rename to atiadlxy.bak / atiadlxx.bak. This should allow users to start the game"

Changing these helped. I know that for me, the atiadlxy file was in syswow64 while atiadlxx was in system 32. change .dll to .bak and itll work

24th Aug 2011, 14:53
As mentioned before, I've already tried that, and jaycw2309 has also pointed out that that particular solution is only recommended for those without ATI cards.

24th Aug 2011, 14:55
Yeah I wasnt sure if that solution was posted after you made your original. Sorry man that blows. I still have no solution either

25th Aug 2011, 00:19
So, jaycw2309, I'm assuming that there's nothing that I can really do at this point? Maybe just sit tight and see if you guys can fix it somehow? Or maybe buy a new laptop?

25th Aug 2011, 00:21

Try that. Apply it to the extracted, latest, drivers and it will install on your hardware. It might solve the issues, or introduce several new ones :p It should work fine, though. Also, ALWAYS use this tool before updating drivers - http://phyxion.net/item/driver-sweeper.html

25th Aug 2011, 02:30
Hey Freeloo, I just tried your solution and I think the most recent ATI driver packages are now protected against mobility modder or something. The modification time is 0 seconds and nothing seems to be changed. Did you use a specific ATI driver package? I've tried all the 11.* packages and 10.8 - 10.12 packages.