PDA

View Full Version : Failed to initialize Direct3D with current settings



Forager
23rd Aug 2011, 15:34
When first opened the game through Steam I chose "Setup Deus Ex: Human Revolution" to insure resolution and graphics were set to my preferred settings. I changed none of them and clicked 'ok.' (only mentioned this in case it makes a difference)

Now when I run the "Play Deus Ex: Human Revolution" I receive the following error:


--------------------------------------------------
Deus Ex: Human Revolution Error
--------------------------------------------------

Failed to initialize Direct3D with current settings


--------------------------------------------------



Thanks for any help!

Full System Specs if they are relevant:
Operating System:
Windows 2.6.1.7601 (Service Pack 1) (Windows 7 64bit)
CPU Type:
Intel® Core™2 CPU X6800 @ 2.93GHz
CPU Speed:
2.95 GHz
System Memory:
8 GB
Video Card Model:
ATI Radeon HD 5700 Series
Video Card Memory:
1.04 GB
Video Card Driver:
atiumdag.dll
Desktop Resolution:
1920x1080
Hard Disk Size:
298.09 GB
Hard Disk Free Space:
209.48 GB (70%)
Download Speed:
466.51 kB/s (3.8 mbps)

jaywalker2309
23rd Aug 2011, 15:38
When first opened the game through Steam I chose "Setup Deus Ex: Human Revolution" to insure resolution and graphics were set to my preferred settings. I changed none of them and clicked 'ok.' (only mentioned this in case it makes a difference)

Now when I run the "Play Deus Ex: Human Revolution" I receive the following error:


--------------------------------------------------
Deus Ex: Human Revolution Error
--------------------------------------------------

Failed to initialize Direct3D with current settings


--------------------------------------------------

Have you tried update drivers, 11.8 is current/latest i think..

also then try maybe reducing the settings down?

Forager
23rd Aug 2011, 16:10
The problem is fixed!

I checked drivers using the "ATI Radeon Catalyst Control Center" That led me to their site where I could download newer drivers. Download, update, and fixed.


Thank you so much for the help, I'll post again here if any further errors occur that may relate to this issue.

jaywalker2309
23rd Aug 2011, 16:15
Phew.. again *ticks another box*

cLemenZa
27th Aug 2011, 17:47
I have the same problem, all drivers up to date and i've tried lowering the settings and still can't play the game. Could there be anything else Jaycw??

jaywalker2309
27th Aug 2011, 18:52
I have the same problem, all drivers up to date and i've tried lowering the settings and still can't play the game. Could there be anything else Jaycw??

What are your specs? graphics card etc?

cLemenZa
27th Aug 2011, 21:58
Operating system:
Windows 7 64 bit
CPU Type:
Intel® Core™i7 CPU 860 @ 2.80Ghz 2.80Ghz
System Memory:
6 GB
Video Card Model:
ATI Radeon HD 5770
Video Card Memory:
1 GB
Video Card Driver:
atiumdag.dll
Desktop Resolution:
1920x1080
Hard Disk Size:
458GB
Hard Disk Free Space:
310GB (67%)
Download Speed:
4304 Kbps

fatcat1111
28th Aug 2011, 06:09
Hello,

I just installed Deus Ex : HR over Steam. Trying to start it, I am first presented with graphics options. Changing nothing, I click Ok and get the following error:

---------------------------
Deus Ex: Human Revolution Error
---------------------------
Failed to initialize Direct3D with current settings
---------------------------
OK
---------------------------


I've since tried changing the settings (e.g. resolution, anti aliasing, etc.), to no avail, and the error message is rather useless, so I'm coming to Eidos for help.

Here is my system info, from dxdiag.exe:


Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
Language: English (Regional Setting: English)
System Manufacturer: LENOVO
System Model: 1952AP2
BIOS: Phoenix FirstBIOS(tm) Notebook Pro Version 2.0 for ThinkPad
Processor: Genuine Intel(R) CPU T2400 @ 1.83GHz (2 CPUs), ~1.8GHz
Memory: 3072MB RAM
Available OS Memory: 3062MB RAM
Page File: 1309MB used, 4814MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

---------------
Display Devices
---------------
Card name: Mobile Intel(R) 945 Express Chipset Family
Manufacturer: Intel Corporation
Chip type: Intel(R) GMA 950
DAC type: Internal
Device Key: Enum\PCI\VEN_8086&DEV_27A2&SUBSYS_201A17AA&REV_03
Display Memory: 256 MB
Dedicated Memory: 0 MB
Shared Memory: 256 MB
Current Mode: 1024 x 768 (32 bit) (60Hz)
Monitor Name: ThinkPad Display 1024x768
Monitor Model: unknown
Monitor Id: LEN4040
Native Mode: 1024 x 768(p) (60.004Hz)
Output Type: Internal
Driver Name: igdumd32.dll
Driver File Version: 8.15.0010.1867 (English)
Driver Version: 8.15.10.1867
DDI Version: 9Ex
Driver Model: WDDM 1.0
Driver Attributes: Final Retail
Driver Date/Size: 8/6/2009 17:02:54, 3829760 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B78E66-64E2-11CF-5173-1000A3C2C535}
Vendor ID: 0x8086
Device ID: 0x27A2
SubSys ID: 0x201A17AA
Revision ID: 0x0003
Driver Strong Name: oem10.inf:Intel.Mfg:i945GM0:8.15.10.1867:pci\ven_8086&dev_27a2&subsys_201a17aa
Rank Of Driver: 00F40001
Video Accel: ModeMPEG2_A ModeMPEG2_C
--snipping out deinterlace caps section as it's huge--
D3D9 Overlay: Supported
DXVA-HD: Not Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled


Please advise.

Fasterkatt
28th Aug 2011, 06:24
The issue probably stems from the integrated graphics from intel on your laptop. After looking up the specific chipset, yes it does support up to Direct3D 9.1 however I believe it is probably just too underpowered to support the game 100%. With it being a laptop there most likely isn't another upgrade path besides purchasing a new laptop, or if you have a desktop system with better hardware you could try running the game on that.

Edit: A quick edit, just did a quick wikipedia search on your chipset, link:http://en.wikipedia.org/wiki/Intel_GMA#GMA_950

A direct quote: "The GMA 950 is Intel's second-generation graphics core, which was also referred by Intel as 'Gen 3.5 Integrated Graphics Engine' in datasheets. It is used in the Intel 940GML, 945G, 945GU and 945GT system chipsets. The amount of video-decoding hardware has increased; VLD, iDCT, and dual video overlay windows are supposed to be handled in hardware.[2] However in a feature comparison document[3] it is noted, that VLD and iDCT are not supported until GMA 3100 (on G33 chipsets only). The maximum core clock is up to 400 MHz (on Intel 945G, 945GC, 945GZ, 945GSE), boosting pixel fill-rate to a theoretical 1600 megapixels/s.

The GMA 950 shares the same architectural weakness as the GMA 900: no hardware geometry processing. Neither basic hardware transform and lighting,[4] nor more advanced vertex shaders are handled in the GMA hardware, these are only accessible via Software Rendering. The 950 does support Hardware Pixel Shader 2.0 and Software Pixel Shader 3.0 (Not Emulated) but is not capable of running modern games."

fatcat1111
28th Aug 2011, 16:32
Well, shoot. I thought this old dog was *just under* the system requirements (e.g., it has 2x procs at 1.83 GHz, rather than 2x at 2.0 GHz), allowing me to play with reduced settings. Guess not.

Fasterkatt, thanks for your help with this. I appreciate it.

jaywalker2309
28th Aug 2011, 16:46
:( yeh your intel chipset is just feature lite am afraid :(

Do you have another pc you can play your steam account on?

zhdankie
29th Aug 2011, 13:58
Same error here!

My laptop: 2,3 Hz / 4 Gb RAM / _ATI Radeon Mobility 5650 HD 2 Gb_ / Win 7 64-bit.

Any suggestions?

jezccc
31st Aug 2011, 20:18
I'm suffering exactly the same issue.
System: Intel Core i5 460 (2.53MHZ)
4GB RAM
ATI RADEON MOBILITY HD 5650
Resolution 1600 x 900

tried updating directx and the graphics card drivers, still no joy

oh yeah.... I'm running windows 7 - 64 bit

jaywalker2309
31st Aug 2011, 21:57
Operating system:
Windows 7 64 bit
CPU Type:
Intel® Core™i7 CPU 860 @ 2.80Ghz 2.80Ghz
System Memory:
6 GB
Video Card Model:
ATI Radeon HD 5770
Video Card Memory:
1 GB
Video Card Driver:
atiumdag.dll
Desktop Resolution:
1920x1080
Hard Disk Size:
458GB
Hard Disk Free Space:
310GB (67%)
Download Speed:
4304 Kbps


I'm suffering exactly the same issue.
System: Intel Core i5 460 (2.53MHZ)
4GB RAM
ATI RADEON MOBILITY HD 5650
Resolution 1600 x 900

tried updating directx and the graphics card drivers, still no joy

oh yeah.... I'm running windows 7 - 64 bit

What driver versions you running?

jezccc
1st Sep 2011, 13:26
The latest update was version 11.8 of the drivers, downloaded from AMD/ATI website last night.

Mic_Re
4th Sep 2011, 12:22
Hi Folks,


Same here! Running an AMD 4870 X2 graphicscard (dualGPU)

1)
Installed the latest drivers from the AMD website (11.8 for 64bit Sys)! no changes!

2)
I installed the latest directX from the microsoft site and after a reboot run the webInstaller, just to check, and it said: latest version is installed - no further changes necessary.
no changes in Deus EX... though!

3) I installed the latest gaming profiles from the AMD website.... no changes!

4)
DxDiag comes up completely clean! no issues!





Its all annoying since that crap message doesn't say a bit in regard of WHAT THE F*** IS NOT FUNCTIONING!
(I believe that 'smart' programmer was trained by Microsoft!?)

Cheers Mic

My System:
MoBo: MSI Eclipse SLI, X58 (triple PC3-10667U DDR3) (7520-010R)

CPU: Intel(R) Core(TM) i7 920 @ 2.67GHz (8 CPUs), ~2.7GHz

Graphic Card: ATI Radeon HD 4870 X2
Dedicated Memory: 2028 MB
Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver File Version: 8.17.0010.1091 (English)
Driver Version: 8.881.0.0
DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
DirectX Version 11

Power: Xilence XP800
Ram: 6144MB GDDR3
Win7 64 (home)
Display 2x LG Flatron 22" @ 1680x1050

AMD video profile: 11.8 CAP2 Release 8/21/2011

Mic_Re
9th Sep 2011, 18:17
Hello ..... ello......llo......lo.......o

anyone there?..... ere..... ere..... e..... ?



No? Ok .... maybe I should open a thread of my own with the same header....
Thanks for all the help!
Great job!
I feel like I purchased a really good game, with a top support!

Mic_Re
9th Sep 2011, 18:31
Hey guys... don't feel alone and abandoned ... you are!
And you are not the only one who waits for an answer in vain... :mad2:


But hey, even when you cant play that game .... you can watch on Youtube how it should look like, and what fun it is to play!



Did that help you?

YES [ ]
NO [ ]
fu** off a**hole [ ]
fu** EIDOS [ ]
fu** ATI Radeon [ ]



*g* sorry for trolling, I'm just frustrated!




My System:
MoBo: MSI Eclipse SLI, X58 (triple PC3-10667U DDR3) (7520-010R)

CPU: Intel(R) Core(TM) i7 920 @ 2.67GHz (8 CPUs), ~2.7GHz

Graphic Card: ATI Radeon HD 4870 X2
Dedicated Memory: 2028 MB
Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,at icfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64 .dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a. cap,atitmm64.dll
Driver File Version: 8.17.0010.1091 (English)
Driver Version: 8.881.0.0
DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
DirectX Version 11

Power: Xilence XP800
Ram: 6144MB GDDR3
Win7 64 (home)
Display 2x LG Flatron 22" @ 1680x1050

AMD video profile: 11.8 CAP2 Release 8/21/2011



.

Mic_Re
9th Sep 2011, 19:20
Hi folks,

since there was no real solution of that mentioned above issue, in the other 3 threads with that very same header I open it a 4rth time!

Sorry for that, but its frustrating to simply get no answer and no solution!

here is what I did so far:

I bought Deus Ex
I tried to install Steam ... and failed ... since there where at least 3 different error messages!
2 days of search on the net until I found: For the installation you HAVE to switch off your anti virus program, since the Steam updater acts like most viruses. Very clever people programmed it and got a lot of money for that crap, for sure! Does anyone wants to make a guess WHO is paying that money???

2 more days off waiting until that crappy program downloaded the installation files for Deus Ex, since the steam server presented that files with a mere 20kbit/sec :thumb:
I tried to start Deus Ex.... and the graphic config dialog started.... I started it with default settings and got the Message:


Failed to initialize Direct3D with current settings


Cool ... its a game running under the graphic logo of ATI Radeon and I run a ATI double GPU card....

I searched the net for any solution but all I found was the standard solution: "please install the latest drivers"

I installed the latest drivers from the ATI website....
I installed the latest DirectX
I Installed the latest CAP profile from the ATI website...

Failed to initialize Direct3D with current settings

I deinstalled all ATI software
I deinstalled the drivers
I deinstalled Deus Ex
I deinstalled Steam

I ran a driver cleaner
I ran CCleaner

I re-installed directX
I re-installed the LATEST ATI drivers
I re-installed steam
I re-installed Deus Ex and W A I T E D A N O T H E R f***** 2 days through the f**** slo-mo download!

I started Deus Ex ... and ...

Failed to initialize Direct3D with current settings

:mad2:

Just in case anyone wants to advise: " Did you reboot the PC..." SCRATCH THAT! DON't even THINK IT!



Has anyone a usefull idea, aside from kicking the PC... pray to the gods of gamers... dream of strangling the programmer .... and insulting the support team in a life chat???


Are there any windows services that are not essetial for the normal run of windows and all other games, but are essential for initialize the graphic engine of Deus Ex?
Anything else?
Any idea is appreciated!
A lot of Radeon users are waiting for a solution and some answers, and I am so bold to guess, that the amount of future sales on RADEON cards are dropping slow but steady right NOW!


Cheers Mic



My System:
MoBo: MSI Eclipse SLI, X58 (triple PC3-10667U DDR3) (7520-010R)

CPU: Intel(R) Core(TM) i7 920 @ 2.67GHz (8 CPUs), ~2.7GHz

Graphic Card: ATI Radeon HD 4870 X2
Dedicated Memory: 2028 MB
Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,at icfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64 .dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a. cap,atitmm64.dll
Driver File Version: 8.17.0010.1091 (English)
Driver Version: 8.881.0.0
DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
DirectX Version 11

Power: Xilence XP800
Ram: 6144MB GDDR3
Win7 64 (home)
Display 2x LG Flatron 22" @ 1680x1050

AMD video profile: 11.8 CAP2 Release 8/21/2011

Lastchild
12th Sep 2011, 21:02
I have been having the same problem for days and it's been driving me crazy! So I tried to think of the last thing I installed on my computer and found the problem, at least for me anyway.

Have you recently installed "Dead Island"?

I found that after I had installed dead island it had somehow been left running in the background and would not allow Deus Ex to start. I just had to go into the task manager (Cnrl + Alt + Del) and look for dead island in the processes tab and end it.

Deus Ex starting right up!!

jezccc
13th Sep 2011, 13:51
We need support

jaywalker2309
13th Sep 2011, 13:53
So you both get `direct3d initialise` error?

Are you able to run the setup program? or does that give same error?

Can i politely remind you that `official` support is via the http://support.eu.square-enix.com/main.php?id=2134&la=2 website. The forums are for communal help, yes you may find a solution here, but saying you not getting support if you haven't actually gone to the support site is a bit unfair :)

Mic_Re
13th Sep 2011, 19:19
Hi Jaycw,

Under these conditions, yea ...you'r right... its a bit unfair.
I did not contacted the official support yet, I thought they would take a look here now and than.
Thanks for pointing that out and thanks for the link too. And finally, thank you for your time.
And to make it not to easy for you: I got the impression this thread was closed as "resolved" so I started up anew one here:
http://forums.eidosgames.com/showthread.php?p=1682897#post1682897

Maybe you guys can merge them in a way?




To answer your question:
Yes, the small graphic configuration program that gets started from the Steam client when you chose "Play Deus Ex", comes up and works fine. But regardless of what settings I choose... High res or low res... the result is the same.

So far, I switched off any programm running in the background, piece by piece (not any windows services yet) to see if one of them might interfere with DE and its 'graphic initialisation' but to no noticeable avail.


The only prog a can't switch off is my virus scanner - I run the Bitdefender - but I added DE and steam to its whitelist and switched it to 'gamer mode'. In that mode it is not hassling with any running program.exe or parts of that anymore. The "life protection" is temporarely switched to "tolerant" and its not directly monitoring any running programs.


I even searched the windows log files, if there might have been any 'event' that might either be related to the start of DE or any graphical issue, driver or hardware, but there is nothing. There is not even any registered event with the same timestamp.

very odd and very annoying

cheers
Mic

Mic_Re
13th Sep 2011, 19:29
Hi Lastchild,

thanks for your thoughts.

No, I have not installed 'Dead Island'. And I checked if any programm running in the background would interfere with DE or the steam client. I switched off anything - programm by programm - but nothing changed.

And, there is nothing in the logfiles of windows, that I could 'correlate' to the start up of either steam client and/ or DE, or any graphic related issue.

Regards
Mic

jaywalker2309
13th Sep 2011, 19:47
sounds silly have you tried to hit `reset to default`?

NixxesSoftware
13th Sep 2011, 20:15
This is known to happen for some users when selecting specific anti-aliasing modes in DX9. Try disabling it or setting it to FXAA High. Perhaps that works for you.

Mic_Re
13th Sep 2011, 20:38
Yes, I tried both of that too!
"default settings" and every possible AA settings .... including FXAA High ... that's default anyway.


Result: KLICK (https://lh4.googleusercontent.com/-vhFQDkqrEU8/Tm--TJQ8hJI/AAAAAAAAAQY/bYn3CRRxz94/DeusEx_error_3.jpg)

Mic_Re
15th Sep 2011, 00:38
I don't get it! I deinstalled the CatalystControlCentre from the ATI Driver package and installed the latest 64bit version of ATI Tray Tools instead. During the installation process I choose "install low Level Drivers", what ever that meant, and enabled all additional functions for the different version series of Radeon cards!

Reboot... Driver Config for AA etc. "application controlled" and AI off!!

And Deus Ex started!!

I don't know what happend and what exactly was changed, since the actual display driver has not been changed .... I just changed the control terminal ... I will see if I can play tomorrow, and keep you informed!

Cheers Mic

Mic_Re
15th Sep 2011, 00:46
Hi Jaycw,

I don't get it! I don't know exactly what I did, but it seams I did right!

I deinstalled the CatalystControlCentre from the ATI Driver package and installed the latest 64bit version of ATI Tray Tools instead.
During the installation process I choose "install low Level drivers", what ever that meant, and enabled all additional functions for the different version series of Radeon cards!

Reboot...
Driver Config left as it is... default.... and just set the AA etc. to "application controlled" and switched AI off!!


And Deus Ex started!!


I don't know what happend and what exactly was changed, since the actual installed AMD display driver has not been changed .... I just changed the control terminal ... and choose the same settings as before!

I will see if I can play tomorrow, and keep you informed!

Cheers Mic

mattg
17th Sep 2011, 18:03
Hi everyone.

I can also confirm that Mic_re is correct.

I have a sony vaio with a ati radeon HD5650.

With sony you have to log into sony support and download the latest ati catalyst program I had the original program from new. Then voila!

I had tried initially from the AMD webiste but no joy. So for me it took me about 1 hour to fix I did nothing else except this.
I had a feeling this could be my main issue. As recently I have been having trouble with civ5 not loading up in directx 11.

Thanks so much for saving me the hassle Mic!

Hope this saves other people some time too.

Thanks again

Matt

Hope it helps other people.

jaywalker2309
17th Sep 2011, 18:09
Glad that worked for you guys.. :)

Mic_Re
17th Sep 2011, 22:00
Hi folks,

just to conclude my issue here:
somehow the installation of ATI Tray Tool for the fine tuning of Radeon drivers seamed to do the trick (for me).
Deus Ex is running smooth and without any fuss, at the highes settings. Ok... My card is not a DirectX 11 so I have to be content with DirectX 9 / 10 but thats ok!

The only thing that is still botherin my is, that I don't know what exactly happened and what was changed by installing the ATI Tray Tools. Since I already had it installed when I installed DE the first time and it wouldn't run. Very strange...

Hope someone can figure out the real thing and comes up with a fix, maybe with the next driver version.

Cheers
Mic

Mic_Re
17th Sep 2011, 22:08
Hi Everyone,

ATI Tray tools did the trick... I dont know how and why but it did. Deus Ex is running at the highest settings available for me. I played through the first 3 missions and so far no problems at all.

Case closed... at least for my.
Thanks for the help and the brains.

Cheers
Mic

Mic_Re
17th Sep 2011, 22:18
Hi,

After a complete deinstallation of steam and Deus Ex, and all Radeon Drivers and ATI / AMD driver tools and programs I re-installed all that stuff and nothing had changed.

BUT somebody told me to install the ATI tray tools instead of the Catalyst Control Center to be able to fine tune the driver. So I installed ATI TT ... and got asked if I want to install Low Level Drivers too... I did and I enabled every possible special feature for all different Radeon Series 2xxx, 3xxx, 4xxx etc.

After that Deus Ex started!

I don't understand what happened and what got changed ... but the ATI tray tools seam to have fixed my problem with the driver, what ever it was.

Regards
Mic

kwintinpark
5th Oct 2011, 20:44
Hi there,

One of my friend had the same problem, he fixed it by running the game as administrator (right-click on the shortcut and "execute as administrator") then toogling off the case "Use Directx 11" in the graphic configuration screen.
And strangely it worked for him!

Hope this could be useful

Daa
13th Oct 2011, 22:44
i'm having the same problem. 'failed to initialize Direct3d with current settings'
so if everybody having the same problem and nobody has solved it yet. maybe the game's broken.

Bshop
27th Dec 2011, 21:00
Hi guys, this one worked for me.

-Uncheck the option for Directx11 [leave everything else as defaults]
-Accept the message that says the Game needs to restart...or something like that.
-Click Cancel to close that window.
-Restart Game... this time game will works without trying to use Dx11.

Merti47
30th Dec 2011, 22:30
It's so stupid just someone like me could do it!
If you have an issue with Direct3D it could be just Steam playing stupid all you have to do is start the game in windowed mode. The game will go smoothly and in the in game options just change it again to full screen mode and you won't see this error ever again! - worked fine by me although i have Nvidia GeForce 9600M GT ;)

Markusss
27th Jan 2012, 12:59
Goodday everyone,

I have the same problem:
Failed to initialize Direct3D with current settings.

I'm using Virtu technology on z68 so my xfx 6990 isn't always on.
I have add deus ex on Virtu and in the bios I used I-mode instead of D-mode to save watt.

When I use D-mode the game started. But with I-mode it doesn't.

I have the latest software on my 6990 and virtu.

Kind regards,

Specs:
Windows 7 Servicepack 1 64bit
8gb DDR G-Skill
xfx6990 4GB
I7 2600K
Z68 gd80

jonescat
6th Feb 2012, 11:29
Hi all, bumped into this thread via Google, having had the same issue (I've got a Radeon HD 5800 card). Updated drivers, relaunched - same problem. Ran the Deus Ex setup programme via Steam, and tried switching on and off various things. What worked in the end? Set everything to original defaults, and then turned OFF the 'use Direct X 11' tab. Bizarrely, it now launches...

jamfan
26th Feb 2012, 22:24
Hello I am having this same problem. I was initially able to get into the game using my onboard Intel graphics, but unable to get in with the GTX560. Tried all the stuff recommended so far (set to default, change settings, have the latest drivers, etc..)

CPU: i7 2600 SandyBridge
GT560 (using Lucid Virtu) - 295.73 NVidia Driver

:mad2:

jamfan
27th Feb 2012, 13:42
Goodday everyone,

I have the same problem:
Failed to initialize Direct3D with current settings.

I'm using Virtu technology on z68 so my xfx 6990 isn't always on.
I have add deus ex on Virtu and in the bios I used I-mode instead of D-mode to save watt.

When I use D-mode the game started. But with I-mode it doesn't.

I have the latest software on my 6990 and virtu.

Kind regards,

Specs:
Windows 7 Servicepack 1 64bit
8gb DDR G-Skill
xfx6990 4GB
I7 2600K
Z68 gd80


I think I've figured out a workaround using the combination of suggestions from everyone else. I think the problem, at least in our case, has to do with Deus Ex trying to access our video cards before they are turned on by Lucid Virtu. And maybe this is a Steam issue more than an Eidos issue - I'm not sure.

Anyway the workaround... when you first try to start up, you get the Direct3D error. Click OK. You get the setup screen. Uncheck "Use DirectX 11" and "Fullscreen". You get a message stating you have to restart. Click OK. You get the same Direct3D Error. Click OK. Then at the setup screen click Cancel. Try to restart the game again, and Deus Ex launches in a window. You see the Lucid Virtu logo. Once in the game you can turn DirectX 11, Fullscreen, and any other features you want back on.

Unforunately it looks like you have to do this everytime.

shadow123
1st Apr 2012, 05:55
When first opened the game through Steam I chose "Setup Deus Ex: Human Revolution" to insure resolution and graphics were set to my preferred settings. I changed none of them and clicked 'ok.' (only mentioned this in case it makes a difference)

Now when I run the "Play Deus Ex: Human Revolution" I receive the following error:


--------------------------------------------------
Deus Ex: Human Revolution Error
--------------------------------------------------

Failed to initialize Direct3D with current settings


--------------------------------------------------



Thanks for any help!

Full System Specs if they are relevant:
Operating System:
Windows 2.6.1.7601 (Service Pack 1) (Windows 7 64bit)
CPU Type:
Intel® Core™2 CPU X6800 @ 2.93GHz
CPU Speed:
2.95 GHz
System Memory:
8 GB
Video Card Model:
ATI Radeon HD 5700 Series
Video Card Memory:
1.04 GB
Video Card Driver:
atiumdag.dll
Desktop Resolution:
1920x1080
Hard Disk Size:
298.09 GB
Hard Disk Free Space:
209.48 GB (70%)
Download Speed:
466.51 kB/s (3.8 mbps)
The only solution to this problem is to disable directx11 while launching the game....first disable the directx11 and then click ok and restart the game...finally this works for me...however still if you want to play with directx11 then updating the drivers can solve this problem...and im 100% sure...
my graphics card is ati 5650 and windows 7 bit....so for this the update found here..
http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx
download catalyst control suit...it include all the drivers...

ethanice
6th Jun 2012, 04:09
Have you tried update drivers, 11.8 is current/latest i think..

also then try maybe reducing the settings down?

hey i also have this problem and my things up to date i have a radeon 9250

NixxesSoftware
6th Jun 2012, 08:47
We're sorry to say the Radeon 9250 is below minimum spec. It is a 2004 card, and a low-end one back then. It does not have full support for DirectX 9.

one2twelve
15th Aug 2012, 02:36
Hey everyone, I understand that this thread/problem is somewhat old, but I may have a solution that wasn't listed in the pages above.

I tried every single suggestion in this thread and nothing worked, and right when I was about to give up I decided to check my hardware devices and noticed that my On-Board video drivers were still installed.

Asrock Extreme4
i5-3570k
Gigabyte HD 7970 3gb

I didn't think leaving the on-board drivers installed would be an issue (it hasn't in any other game) but I decided to uninstall them anyways; just to see. After rebooting I got an error about the Video Controller needing updated. I went back to device manager and just right-clicked and disabled.

So if everything else in this thread isn't working, drop by your Device Manager and check and make sure you have ONLY the drivers you need. Uninstall (or disable?) any on-board/chip video controllers and leave JUST your video card driver.

susheel soni
28th Aug 2012, 12:25
failed to initialize direct3D with current settings

diego gr
5th Feb 2013, 22:30
I don't play Deus Ex, but was having problem to run Interstate 76 on Windows 7, using a ATI Radeon HD4650.
I got the message "Failed to initialize 3D hardware acceleration".
I had to install my old video drivers, copy the file "ATIUMDAG.DLL" to any folder, and reinstalling the video drivers, but NOT THE LAST ONES (some from 2009).
After drivers are updated, you restart in SAFE MODE and paste the old ATIUMDAG.DLL in SYSTEM32 folder.
Restart Windows and every D3D game and 3DFX/Glide game should work. (NFS2SE, Moto Racer, Carmageddon, Interstate 76, Thief: Dark Project.....)
But now I noticed Windows Media Player is not playing any video in any format, only audio.
So it's definitely an AMD ATI driver problem.
And one more time with Microsoft Windows it happens: "Let the customers solve the problem, they always do. We can keep only receiving easy money" LOL

evilgogeta4
21st Feb 2013, 06:08
failed to initialize direct3D with current settings...Please help

Having problem with Game Deus Ex Human Revolution...


I am using intel Q965/Q963 chipset family
1GB RAM DDR
Windows 8

ruby fan
14th Sep 2013, 20:27
I have the same problem, all drivers up to date and i've tried lowering the settings and still can't play the game. Could there be anything else Jaycw??

I've had the same problem. I'm running windows 7 64 bit. After I clicked on shortcut to my game, a window opens, in which I can click "play" but when I clicked it, a message appeared: "failed to initialize Direct3D with curent settings."

I found a solution here: http://pcgamingwiki.com/wiki/Tomb_Raider_%282013%29#Force_DirectX_9_renderer_on_DirectX_11_systems

In case the link is broken, or wathever, here is the description from that page:

1) Launch the Registry Editor (open the Start screen/Start menu, click on Run and type regedit into the window that apperas and hit Enter).
2) (on the left) Navigate to HKEY_CURRENT_USER\Software\Crystal Dynamics\Tomb Raider\Graphics
3) Modify RenderAPI value (on the rigth) to 9.

Note: Revert to 0 for DX11, anything else will result in DX11 renderer with some DX11 features disabled.


So, it simes that the problem was that win 7 supports DirectX 11, but the game wanted to run on DirectX 9. After 3 days of googling the solution, I've found a bunch of forums that helped some poeple, but not me. After I did this 3 steps and like it is written in Note above, everything that has a "DX11" in the name, I've put to 0. Then I run the game and it worked!

I should probably say this too: people usualy say, it's not wise to change stuff in the registry, so if you are going to do this, you are doing this on your own risk. (I did not have any problems with the game or windows so far).