PDA

View Full Version : Low fps problem



Azureth
23rd Aug 2011, 14:47
Specs:

GTX 460 SE
e8400 3.2ghz
4gb ram
windows 7

I can't even play it on the lowest settings @ 1920x1080 with absolutely nothing turned on. This baffles me as I can play The Witcher 2 at max settings minus aa, af, bloom, etc.

My roommate can play it just fine with a pentium 4, 2gb ram and an 8800GTS 512 on minimum settings...

I've downloaded the latest drivers and everything...really ruining my experience with this great game.

jaywalker2309
23rd Aug 2011, 14:56
Have you tried running at a lower resolution?

Azureth
23rd Aug 2011, 14:58
1440x900 is still really low fps.

scar1983
1st Sep 2011, 20:17
I'm having the same issue too.

550 ti
4GB RAM
i5 2.8
Windows 7

Qazwix
4th Sep 2011, 18:16
Same thing here. EVGA GTX 460. Everything is turned as low as it can go with only an average of 10fps. I can other games just fine on max settings. With Deus Ex, it doesn't really matter what settings i use (lowest or even highest settings) I still get an average of 10fps. Drivers are updated too. I also noticed it's only using one core on a i7-2600k. 16gb ram and a raid 0 WD blacks. I just don't understand why we're having these issues.

ajd155
5th Sep 2011, 00:15
Try putting the settings all the way up. Maybe with such low settings it's trying to put it on your CPU but with higher settings the GPU will kick in. It's not unheard of.

Otherwise, I'm betting your anti-virus is doing a realtime scan and it's capping your fps. What anti-virus are you guys using?

benjamind
5th Sep 2011, 08:51
Try updating your audio drivers, I had similar issues. Unrealistically poor performance no matter what settings I changed. I uninstalled the realtek drivers for my soundcard and let windows install what it found itself. I now have great performance, as good as can be expected anyway.