PDA

View Full Version : STUTTERING & LAG / FRAME RATE Drop - Video & Audio - All Discussion



Pages : [1] 2 3 4 5

Mondos
23rd Aug 2011, 13:34
I have been experiencing major audio stutter in the first 45min that I have played. It seems to increase when the action picks up and is present throughout. It's extremely distracting, anyone else have this problem?

Specs:
G930 Headset
Windows 7 64bit
i5 2500K @ 4.2Ghz
GTX 570
8Gb Corsair Vengeance
Gigabyte GA-Z68X-UD3H-B3


________________________________________________



MODERATOR EDITS


Official Updates/Announcements:

March 1, 2012


Talked to the guys and gals in the lab and here's their response...

"This sounds like the firmware update is needed to fix drm issues. Asus also has an update available but was lost on this link at some point, we are waiting for this to be added back also."

http://support.amd.com/us/kbarticles/Pages/STEAMGamesonAMDFXplatforms.aspx

"It's important to note this is not DXHR specific, it's affected any game using certain drm methods."


__




Poll and Discussion Thread on general forum:

http://forums.eidosgames.com/showthread.php?t=121283

__


Some possible solutions:


This might fix it. It fixed my studdering in Age of Empires 3 and The Witcher.

For nvidia users, download the nvidia inspector program if you haven't already.

There should be a profole for Deus Ex: Human Revolution.

Set Triple Buffering to On
Set V-Sync to On
And here's what might do it:
Set the frame rate limiter to 60fps.

This removed my stutter/frame skipping in the first two games I mentioned and might also work for this game.

For anyone that doesn't have a fix, try this out and see if it works.






Game Laggy / Lagging or Low Performance
As with most game fixes, some that you may have used before may in fact help fix the problem you’re experiencing with Deus Ex: Human Revolution. If you have any sort of lag of stuttering, then try these solutions.

– If you have NVIDIA 3D Vision installed, then remove the driver as it commonly causes lag and performance drops!
– Using NVIDIA Control Panel for NVIDIA graphics card or ATI Catalyst Center for ATI video cards, you can dramatically increase or even fix some problems you’re experiencing. Firstly, try experimenting with VSYNC — turn V-SYNC ON if it is disabled and then try running the game. If you already have it forced on, then also try disabling it. Depending on the issue, having it enabled instead of disabled or vice-versa may be a better idea than the other. It can help bypass a frames per second / FPS limit or cap and sometimes even helps if you are experiencing blur. VSYNC can effect the refresh rate.
– Another option is to enable Triple Buffering through your GFX Card Control Panel. A program like D3DOverrider can help you enable VSYNC and Triple Buffering for NVIDIA cards.
– Lower the graphics settings, resolution, antialiasing (AA), and other effects
– Upgrade your video card drivers (they generally offer bug fixes and performance increases)

So for the exact steps to enable VSYNC, Anti-Aliasing, and Anisotropic Filtering for NVIDIA cards try:
1) Load the NVIDIA Control Panel (can be accessed in system tray generally or Control Panel)
2) Click “Performance & Quality Settings” -> “Add Profile” -> enter Deus Ex: Human Revolution
3) Click “Browse” -> select the Deus Ex exe -> check the checkbox that’s next to it in the associated application list
4) Under “Application” be sure to select the entry you just added and uncheck “Application-controlled”

For ATI video cards, just Load ATI Catalyst Control Panel and expand the 3D menu. Easy!
http://geekmontage.com/texts/game-fixes-deus-ex-human-revolution-crashing-freezing-no-audio-lagging-black-screen/



Now I'm not sure what he meant. He says 16-bit 48000Hz, but the screenshot has 24-bit 192000 highlighted.

OK never mind, I think I'm still stuttering... but I swear I wasn't before. I don't have 3D Vision installed! And changing the audio doesn't do anything.

EDIT

Disabling SSAO seems to have helped a lot!


I started playing the HR today, and the stuttering was impacting my ability to enjoy the game. It turns out that the stuttering was caused by vsync and triple buffering. Without vsync, the screen tears like crazy, and forcing it from the ATI Control Panel didn't work for me.

I ended up using the Direct3DOverrider that comes with RuvaTuner. There's an option in the program to force vsync and triple buffering (make sure you disable it in game first). It's not compatible with every game, but it's perfect for games like Dead Space 2 with broken vsync.

The game runs as smooth as butter now. I recommend anyone still having the stuttering issue to go and download RivaTuner.
You have to use D3DOverrider. Don't force VSYNC in the control panel.
http://www.guru3d.com/index.php?page=rivatuner


In case it helps, member miseryguts recently posted this on the main DXHR forum:

Don't know if this is going to help you but i had exactly the same issues until changed the renderer to DX11 (it defaulted to DX9 for some reason) i now have no lag or stuttering whatsoever.


Only fix that worked for me was MSI Afterburner and its frame rate limiter, set to 60fps. Now the game is smooth.
Nvidia 570, i2500k, Windows 7.

There is also other solution that works for some people and that is running the game in window mode.


I've found the holy grail. My friend directed me to this download: http://www.xtremesystems.org/forums/showthread.php?276698-A-fix-for-Valve-CEG-games-causing-BSOD-on-Bulldozer-issue&p=5005608&viewfull=1#post5005608

ladies and gentlemen, this download completely stopped all the retarded fps lag I was having. After all this time trying to fix it this seems surreal. I have no tried watching a cutscene yet, so I don't know if the audio skipping problem persists, but ffs, at least now it's playable.

All thanks go to roidmonkey on steam for leading me to this most beautiful of downloads.

ps- he used it to fix saints row 3, so try it for every game you have that you lag on!

:)


I think it should be mentioned that more specifically, this is a fix for AMD Bulldozer cpus.
It's unlikely that other AMD chips will benefit from it (or even need it).



Try some of the fixes in this thread over on Steam.
http://forums.steampowered.com/forums/showthread.php?t=2075294


Haven't been on here for a while but I am pleased to say I finally fixed my game and I can now play it relatively stutter free at max DX11 settings. Here's how I sorted it -

- install latest drivers
- use MSI Afterburner framerate limiter and set to 60fps, this has to be running in the background
- click play button on Steam for the game and select "Setup Deus Ex:Human Revolution" option.
- click "set to default" option, then ok
- click play button on Steam for the game and select "Play Deus Ex:Human Revolution"option which takes you into the game.
- Now select all your graphic options that you want (I play max DX11) but make sure to select the vsync and triple buffering option
- Load your save or start a new game wherever you are at

I have to carry out that same process in bold blue writing everytime I play the game to have a stutter free experience (Only tiny little saving stutters are apparent which is perfectly normal with mechanical HDDs). If I don't carry that procedure out it will have GPU usage issues, frameskipping the whole works. I genuinely feel there may be a problem with the startup initialisation of the game and for some people, like myself. it is not hooking correctly.

I'm now able to fully get lost in the Deus Ex world and enjoy the game....it's awesome!!

It also works the same way for the missing link DLC too. Hope that helps someone.




******* A!

I've tried all other fixes in the original post except for the two above yours, none of which worked.

Now after a short test on the highest settings in an area with unquestionable stuttering even on modest settings...

No stuttering!

Here's some more details:

1 ) Download the latest MSI Afterburner BETA from here:
http://event.msi.com/vga/afterburner/download.htm

2) Extract, install.

3) Run Afterburner.

4) Click Settings, then the Monitor tab.

5) In the list "Active hardware monitoring graphs" scroll down to Framerate and click the gray icon to the left of the text. Now some grayed out settings beneath will activate and you should tick the boxes left of "Show in On-Screen Display" and "Show in tray icon". Now press OK.

6) Look in your tray (bottom right of your entire monitor screen, to the left of your Windows clock) and find the MSI On-Screen Display icon. Press it once to open the program up.

7) Click the + and locate dxhr.exe (the .exe file that you use to run the game... not a shortcut to it!).

8) Click the large wrench icon under "General properties."

9) Under "Framerate limiter properties" input 60 to the right of "Framerate limit", then press OK.

10) Minimize the MSI On-Screen Display program and MSI afterburner to the tray...

And enjoy. Please get back here if it works! I registered here just to say it works.

Some more settings that you might want to look at in the MSI On-Screen Display I guess are (under general properties) "Start with Windows", "Show On-Screen Display" (deactivate this to remove the pink text), "On-Screen Display zoom" and "On-screen Display palette" to change the size and colour of the framerate text and colour.

When running the game with the On-Screen Display activated the FPS should be around 60 FPS in-game I think...

However... after some very short testing it seems the game runs fine even with no framerate limit while running MSI Afterburner and the MSI On-Screen Display in the tray... for this I have no f**king explanation lol! Perhaps just adding dxhr.exe to the OSD-program fixes stuff for some reason? I'll have to look more into this because it seems wierd.




__


I would like to assure you all that representatives of Eidos Montreal, Nixxes, as well as Square Enix, are closely monitoring these forums to look for any issues that users are running into and that require attention. Please note however that this is not an official support mechanism, and if you require official support we recommend you contact http://support.eu.square-enix.com/ for Europe or http://support.na.square-enix.com for America.

That said, we would like to give the community on this forum an update on what our near term plans are for further support for Deus Ex: Human Revolution on PC.

As you are probably aware we have already rolled out two patches soon after release to deal with issues we wanted to address as quickly as possible, after we found out that they existed. We are now looking at additional fixes for issues that some players have been experiencing, and on top of that we are also looking at adding some additional features on the PC side that we noticed some players would really like to see.

These additions are more involved as the first patches, and due to this take longer as those initial patches. We need to test them carefully to ensure we do not introduce any new issues.

Unfortunately, at this point we cannot guarantee specific fixes for patches at specific dates. Fixes once released may not always be immediately effective for every single user on every system out there. But rest assured that people at the studio, in cooperation with IHVs, are looking at all issues that come up and are trying to get them resolved for you as soon as possible.

Thank you for your patience.


__



VIDEO HELP

Preventing microstutters and sound lag in Deus Ex: Human Revolution

Some players of Deus Ex: Human Revolution, including myself, have fallen victim to a variety of game issues. Some of the more annoying issues include a tendancy to stutter, albiet only for a brief amount of time.

The other issue is sound lag, where shooting makes the sound play out seconds after the animation itself has completed.

This video shows potential fixes for both problems.

h55nS2gUSVI

jaywalker2309
23rd Aug 2011, 13:37
I have been experiencing major audio stutter in the first 45min that I have played. It seems to increase when the action picks up and is present throughout. It's extremely distracting, anyone else have this problem?

Specs:
G930 Headset
Windows 7 64bit
i5 2500K @ 4.2Ghz
GTX 570
8Gb Corsair Vengeance
Gigabyte GA-Z68X-UD3H-B3

You dont mention your audio chipset? is it realtek? motherboard chipset not a dedicated card etc?

djchozen91
23rd Aug 2011, 14:03
Any time I access a terminal in the game, zoom into iron-sights, or switch into a third-person animation, the camera stutters. It is extremely annoying. I have the latest drivers for my nvidia GTX460. I have tried switching off dx11 mode but that actually resulted in the game not launching at all. I have tried turning each graphics option on and of and nothing changes.

I'm running:

Windows 7 Home Premium
i7 950
4gb DDR3 ram
GTX460

Would appreciate some help if anyone can lend it.

Eidos Support
23rd Aug 2011, 14:23
Are you able to try your onboard sound instead of the headset and see if it makes a difference? You could also make sure you have installed the latest drivers for your headset:

http://www.logitech.com/en-gb/438/7248?softwareid=7303&osid=14&section=downloads

(From UK logitech site, as that is where I am based; change to your local if need be. :) )

Mondos
23rd Aug 2011, 15:27
I'm not sure what i am using since it is a usb headset. Though I don't have a sound card so I guess the usb uses on board sound?

The on-board sound for my motherboard is (Realtek ALC889 codec).

I never actually downloaded the drivers for it, so I'll try that. I'll also try using a set of audio jack earbuds and see if the stuttering goes away. Will update with results!

Mondos
23rd Aug 2011, 15:39
I tested it with the on-board sound and it worked fine. When I was back there plugging in my earbuds I noticed I had my headset plugged into a usb 3.0 slot. From the 20 seconds I tested it now works fine without stutter in the usb 2.0 slot. I hope that was my problem, will update if stutter returns.

Thanks!

stephensj1
23rd Aug 2011, 15:45
My tutorial videos are stuttering. Which codecs are in use? I want to try ffdshow or atleast make sure they are current. I could totally be way off base as to this being the issue, but I want to check this first, thanks.

Edit: It's just the tutorial videos that are stuttering, everything else is processing fine.

jaywalker2309
23rd Aug 2011, 16:08
My tutorial videos are stuttering. Which codecs are in use? I want to try ffdshow or atleast make sure they are current. I could totally be way off base as to this being the issue, but I want to check this first, thanks.

Edit: It's just the tutorial videos that are stuttering, everything else is processing fine.

Once in game everything is handled by the `game` so to speak.. if the cutscenes play okay then theres nothing wrong with the playback so to speak..

jaywalker2309
23rd Aug 2011, 16:09
Glad to hear the problem seems to be resolved :)

stephensj1
23rd Aug 2011, 16:10
Thanks for the quick reply. I'll make due.

BobTheSpy
23rd Aug 2011, 16:50
This is going to sound kind of weird - but I've never had a problem quite like this. Basically, if I'm in an area I've already seen, my FPS will be all find and dandy. But if I turn to look at an area I haven't seen yet, there's an FPS drop. Anyone know what I could do to make this stop happening?

xfullboost
23rd Aug 2011, 17:03
I was literally about to post the exact same question when I saw your thread! I am having the same issue as you. I would suggest posting more information about your setup so others can more easily assist us. Such as steam or retail versions? what operating system and your computer specs.

Problem: Poor game performance when entering new areas in-game. 60fps to 35fps with a noticeable (and irritating) micro stutter. I tried HR on both my SSD and HDD with same performance. I tried two other games to see if my system was doing this to all applications. The Witcher 2 ran fine when running into a new city or town, and Arma 2 ran fine when zooming in with a sniper rifle.

Deus Ex Human Revolution Augmented Edition Steam edition

System
Windows 7 Ultimate 64bit
AMD Phenom II x6 1090T (4ghz 250x16)
Asus Radeon HD 6970 (2 in crossfire)
Asus Crosshair IV Formula
OCZ Vertex 3 MAXIOPS 120gb SSD
Corsair Dominator GT DDR3 8GB
Creative Soundblaster X-Fi MB
Full water cooling, all temps never exceed 45c.

xfullboost
23rd Aug 2011, 19:20
I am getting rather piss poor performance in city hubs. When moving from one end of the city to the other, I experience 4 hiccups (or slow downs or fps drops) I have experienced this before in games. The game is loading new textures, and its doing so badly. My fps is not what is taking the hit, its the data loading in the first place. And let me remind you, I am on a solid-state drive with over 500mb/s read/write rate. What gives?

[FGS]Shadowrunner
23rd Aug 2011, 19:23
I've never had a problem quite like this

Very much so in Deus Ex 1. It's to be expected that when suddenly viewing a large detailed area for the first time, there will be an initial fps drop.

BobTheSpy
23rd Aug 2011, 20:20
My Specs are:
GTX 560 ti
Phenom II X4 955 3.2 Ghz Quad-core processor
4 GB RAM
Windows 7 Ultimate

BobTheSpy
23rd Aug 2011, 23:37
Bump, anyone else have this issue? It seems to really only affect the City Hubs - or is this normal and I should quit *****ing?

ArnoKalavent
24th Aug 2011, 02:00
I'm running my game at max settings and the actual gameplay is just fine. All of the pre-recorded videos stutter making it very difficult to figure out what's going on in them.

ghost654
24th Aug 2011, 03:32
My deus exs frame rate seems pretty good and smooth but occasionally it feels like it skips a frame or lags. At first I thought that my old video card finally hit something it couldn't play well (geforce 8800gt). But I tried on my friends new i5-2500k, geforce 570 computer and it had the same issue. It ran smooth overall except for that occasional lag, so i dont think it is the hardware causing it.

I can really see it happen the most when walking diagonally it seems. and sometimes when just turning while walking straight.

rokstrombo
24th Aug 2011, 06:13
It might be helpful to Eidos Montreal if you were to post your system specifications (including the operating system, audio interface and speaker/headset setup used).

You could try the following workaround to help troubleshoot this problem:

Start > Run.
Type 'dxdiag' and press Enter.
Click on the 'Sound' tab (there may be several if you have multiple audio interfaces installed).
Under 'DirectX Features', note the relative position of the 'Hardware Sound Acceleration Level' slider. Next, move the slider to the leftmost option 'No Acceleration'. Click 'Exit'.
Launch Human Revolution and replay cutscenes. If the stuttering is fixed, exit Human Revolution and try re-opening dxdiag and moving the slider further to the right to see if the stuttering recurs.


Note that changing the Hardware Sound Acceleration Level may introduce problems in other areas, so if successful remember to return the slider to it's original value when you finish playing.

Senpai C
24th Aug 2011, 06:51
I think that might be a direct x issue. I have a problem that sounds just like yours on my ATI Radeon HD 4870. My brother has one that's a bit more powerful but with direct x11 and turning dx11 on fixes it. When it's turned off on his pc it has the same issue that mine does. I've already experimented around with all of the other settings so I'm fairly certain it's a direct x issue.

Johnnytd
24th Aug 2011, 08:02
I am having the exact same problem and it is frustrating that this seems to be an isolated issue. Is anyone else experiencing this and have a fix? It would be greatly appreciated

Tommando
24th Aug 2011, 09:17
I'm also having a problem with framerate drops, on an HD 4870. The framerate tends to be rather choppy when coming out of a loading screen, but I don't mind that too much as it smooths out after 20 seconds or so. Much more bothersome(and something I didn't notice until I got out onto the streets for the first time)is a tendency for the framerate to drop dramatically when turning a corner or otherwise stepping into a new area.

I can understand how generating that new stuff as it comes into view might increase the strain on resources and thus cut into performance, but I don't see why that should be happening here when I've played plenty of other games with much larger and and more active environments without having the framerate ever take a noticeable hit.

I've played around with various settings in-game and in CCC but nothing seems to work. Hopefully a patch or fix will come along to make the framerate more consistent. I wouldn't even mind capping the FPS at 30 if that would guarantee it stayed at 30 constantly and didn't stutter.

Darktronik
24th Aug 2011, 09:30
Ive got the frameskipping too.

bughole5
24th Aug 2011, 10:01
same here, is it intentional?

xfullboost
24th Aug 2011, 10:20
I'm still getting a bad stutter in the city hubs. not to mention really long loading times for the levels themselves. this game feels poorly optimized, or am i the only one? still, there have been much worse games and im not too bothered by it. im still enjoying my time in-game very much so.

theseagle
24th Aug 2011, 10:51
I'm wondering if the camera stutter / frame skip is just an affect of the aggressive simulation of a "head bob" while running. While moving fast diagonally and changing the mouse aim, it is especially noticeable for me.

ajd155
24th Aug 2011, 11:40
Hello thank you for reading this. First I want to say this game looks great, has a great story already and seems like it's going to be a blast. I am not knocking it at all. I am just having a problem which makes me a little dizzy and it's happening a lot so maybe someone knows of a fix. (I don't think this is the same as mouse lag but I really don't know.)

Here is a video example. (http://vimeo.com/28100052) Somehow the video compression lost a few frames of the stutter in the shuffle, so in actuality it's a bit worse than what shows here. There's a cut about 2/3 that shows it really badly on this little glass object on the ground. It actually sort of induces vertigo when I watch it for too long.

Notice when I move in 1 direction it's fine, when moving in 2 it's still ok but not great. When I move in 1 direction and move my mouse (as if circle strafing someone) the screen jiggles back and forth like crazy. It's disorienting. I have tried disabling v sync, directx 11, ambient occlusion, and tessellation but nothing seems to work. It seems like it's hard coded into the game but shouldn't be hard to fix I wouldn't think. Usually I can find an .ini file or something and tweak some values but I can't seem to find them for deus ex. FPS stay constant the whole time at max.

I should mention I'm on dual quad i7s, gtx 570, 16gb ram. logitech keyboard and mouse with acceleration turned off in windows and in setpoint. It almost feels like the movement and the mouse are fighting against eachother for what is getting drawn during a rotation. Hard to explain I guess I hope the video makes it clearer.

Thanks so much for any help you can give here, I'm looking forward to playing this more as soon as I get this one figured out. I'm not really having any other problems, just the stutter. Any light that can be shed would be awesome. Thanks!

thgc
24th Aug 2011, 11:48
Hi, I installed the game yesterday and am also experiences really annoying frame skip / stuttering, especially when turning the camera around / aiming.

My rig:
EVGA 9800GTX+ 512MB
Intel Core 2 Duo E8400 3.0 GHz overclocked to 3.6GHz
4 GB RAM

thgc
24th Aug 2011, 12:01
Same here, please help

thgc
24th Aug 2011, 12:03
I've got it too, please help Eidos, the game is so great!

ArnoKalavent
24th Aug 2011, 12:11
Thanks rokstrombo. Unfortunately I can't seem to disable the Hardware Acceleration through Windows 7. I've googled around and most people seem to be at that consensus. That did however provide me with an easy way to dump my specs in here.

Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 12/16/10 09:57:42 Ver: 08.00.15
Processor: Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz (4 CPUs), ~3.2GHz
Memory: 4096MB RAM

Card name: AMD Radeon HD 6900 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x6719)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_6719&SUBSYS_E186174B&REV_00
Display Memory: 3822 MB
Dedicated Memory: 2034 MB
Shared Memory: 1787 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Dell ST2420L(HDMI)

For sound I'm using my speakers with onboard VIA High Definition Audio.

cyborg34572
24th Aug 2011, 12:49
Anyway to fix this yet?, its getting kinda annoying, to the point where it becomes difficult to actually enjoy the game.
My framerate always stays at 60 and i still get horrible stuttering. Also the the loading times are quite long, would like that fixed too.

Specs
Intel i72600k 4.5Ghz
G.Skill Ripjaws 8GB 2133Mhz
2x Sli DCUIIGTX580
Windows 7 x64

Video Card Drivers - 280.26

Thomac
24th Aug 2011, 13:21
Intel i72600k 4.5GhzIntermittent stuttering is a common side-effect of overclocking, so try bringing the processor down to stock clocks to see if it fixes it.

Lorloth
24th Aug 2011, 13:52
I also have significant stuttering in the introductory cinematic. I haven't really tried playing the game yet, but the gameplay itself seems to be significantly smoother than the intro cinematic.

Is there a workaround to this? I'd expect it might be a while before it's patched, but anyone know of good workarounds or tweaks to reduce/prevent the cinematic stuttering?

Motherboard: Intel D945GNT
Processor: ~3 GB Intel (I forget... whatever Family 15, Model 4, Stepping 3 is supposed to be)
Physical Memory: 2 GB
Operating System: Windows XP Service Pack 3
Video Card: ATI Radeon 3800 Series
Video Card Drivers: 6.14.10.7119
Sound Card: Creative X-Fi Audio Processor

Lorloth
24th Aug 2011, 13:54
Regarding overclocking, my system is not overclocked.

Lorloth
24th Aug 2011, 13:57
Same exact issue here, though I'm running the game at fairly minimal settings. The game itself is smooth, but the cutscenes are terribly stuttering.

Motherboard: Intel D945GNT
Processor: ~3 GB Intel (I forget... whatever Family 15, Model 4, Stepping 3 is supposed to be)
Physical Memory: 2 GB
Operating System: Windows XP Service Pack 3
Video Card: ATI Radeon 3800 Series
Video Card Drivers: 6.14.10.7119
Sound Card: Creative X-Fi Audio Processor

cyborg34572
24th Aug 2011, 14:17
What drivers you guys using?, latest one?

Rabbot
24th Aug 2011, 15:12
I am running a GTX 460/i5 with the latest drivers and have the same issue.

I would recommend trying the following: DX11 on, tessellation disabled, vsync off, FXAA. I have had the best results on cutting down the skipping using these settings, though I am still getting an unacceptable amount of frame skipping.

Jaston
24th Aug 2011, 16:24
My tutorial videos are stuttering. Which codecs are in use? I want to try ffdshow or atleast make sure they are current. I could totally be way off base as to this being the issue, but I want to check this first, thanks.

Edit: It's just the tutorial videos that are stuttering, everything else is processing fine.

I am experiencing the same thing with the tutorials stuttering and everything else being fine. I will make due, as well, but wanted to post in hopes that some resolution is found.

BobTheSpy
24th Aug 2011, 16:37
I'm also having a problem with framerate drops, on an HD 4870. The framerate tends to be rather choppy when coming out of a loading screen, but I don't mind that too much as it smooths out after 20 seconds or so. Much more bothersome(and something I didn't notice until I got out onto the streets for the first time)is a tendency for the framerate to drop dramatically when turning a corner or otherwise stepping into a new area.

I can understand how generating that new stuff as it comes into view might increase the strain on resources and thus cut into performance, but I don't see why that should be happening here when I've played plenty of other games with much larger and and more active environments without having the framerate ever take a noticeable hit.

I've played around with various settings in-game and in CCC but nothing seems to work. Hopefully a patch or fix will come along to make the framerate more consistent. I wouldn't even mind capping the FPS at 30 if that would guarantee it stayed at 30 constantly and didn't stutter.

I have the exact same problem as this guy, word for word. If anyone has any sort of potential solution, that'd be great to hear.

Warl0rd25
24th Aug 2011, 16:47
Yeah I'm having this same issue. It seems to really happen bad when I go up or down stairs, but there are lots of times where I'm just walking around and it will do it too. I'm pretty sure it's a engine problem because I just upgraded my computer and have no problem at all playing lots of powerful games on max settings like Metro 2033, Crysis 2, and Just Cause 2.

Specs:
i7-2600k @ 4.6Ghz
G.Skill 8GB DDR3 @ 1600Mhz
EVGA GTX 580
1000W PSU

talesoflumin
24th Aug 2011, 17:29
I am having the same problem of the camera stuttering when zooming in on a keypad, console or whatever else while playing and I have to say it is quite frustrating. I hope we can at least get some sort of answer regarding all of this from another person or, better yet, the devs themselves!

Will it be patched? Is the issue with the game or our machines? Anything, please!

I have a Nvidia GTX465 with an i7 860. 8 Gigs of ram! (No overclocking on anything)

Also, as a sidenote none of the settings in the game change / fix / improve this at all. Definitely not vsync, that was the first thing I tried!

chatterbot
24th Aug 2011, 17:32
I was getting pretty bad stuttering before, not matter what graphics settings I was using. In the process of finding a solution, I took a look at my RAM usage and noticed that my system was showing only 2GB of RAM being used when I have 4GB installed. Later I realized that the RAM was a loose, so I plugged them in fully. Now I had 4GB available.

This fixed the fame rate/stuttering issue when moving and looking around. So I guess, RAM is the bottleneck.


Windows 7 64
4GB RAM
NVIDIA 460
Intel QX8700

Arthur Hucksake
24th Aug 2011, 17:47
Same problem here, very annoying. Notice more in the streets.

i7 2600K @ 4.5ghz, 8GB ram, 2 x 570 GTX SLI running off a Vertex 2E SSD.

Get over 100fps showing using fraps (120hz monitor) with or without vsync enabled. Usually when turning corners.

I hope Eidos are looking into this.

Lorloth
24th Aug 2011, 17:53
You could try the following workaround to help troubleshoot this problem:

Start > Run.
Type 'dxdiag' and press Enter.
Click on the 'Sound' tab (there may be several if you have multiple audio interfaces installed).
Under 'DirectX Features', note the relative position of the 'Hardware Sound Acceleration Level' slider. Next, move the slider to the leftmost option 'No Acceleration'. Click 'Exit'.
Launch Human Revolution and replay cutscenes. If the stuttering is fixed, exit Human Revolution and try re-opening dxdiag and moving the slider further to the right to see if the stuttering recurs.


Note that changing the Hardware Sound Acceleration Level may introduce problems in other areas, so if successful remember to return the slider to it's original value when you finish playing.

I have tried this fix and it did not alleviate the stuttering during cinematic videos.

evilgrug
24th Aug 2011, 17:54
Is there going to be a fix for the laggy audio? Lipsync and especially gunfire is noticably off on my system.

Looking around at various forums, a lot of complaints seem to be from those using C-Media chipsets (Xonar DG, Auzentech Xplosion, HT Omega Striker) but I've seen a few Xonar DX (Asus chipset) owners complaining and it's not much better when I switch back to my Realtek onboard.

I took some blurry footage of both of them and slowed it down:
http://www.youtube.com/watch?v=T6_HMGo9CDQ

Win7 x64, I've updated to the latest drivers for both devices, tried other output formats, and turned off any DSP effects. No other games seem to suffer from the same problem.

Lorloth
24th Aug 2011, 18:14
Upgraded my ATI Catalyst drivers from 6.14.10.7119 to 6.14.10.7213 and that DID work to significant reduce the severity of stuttering during cinematic cutscenes, but it did not eliminate the problem. Stuttering remains significant.

That's the first thing that's helped, though.

Anyone else have any other fixes/suggestions/workarounds? Until we get a patch, we may be sort of stuck for a while.

Sessoneon
24th Aug 2011, 18:38
I as well along with a lot of other people... http://forums.steampowered.com/forums/showthread.php?t=2075294

Even with the lowest possible settings the game still has a horrible micro-stutter.

Win 7 64
AMD HD 5850 latest drivers
Phenom II X4 965
4GB

MagicalHippy
24th Aug 2011, 19:06
Have the same issues purchased on steam verified files installed new drivers for vid card and on board audio chip (Realtek ALC888 8+2 Channel HD Audio) now I am uninstalling and restarting computer then reinstalling to see if that works so far nothing seems to fix it. The audio only lags during cut screens and very badly during the walk with the girl after 1st cut screen every time the door closes behind you sound will jitter and also when second char the girl talks. I have the setting set to lowest and disabled DX11 still has issues. I also disable surround sound and tried headphones still has issues.
System Manufacturer: BIOSTAR Group
System Model: TA790GX 128M
BIOS: Default System BIOS
Processor: AMD Phenom(tm) II X4 940 Processor (4 CPUs), ~3.0GHz
Memory: 8192MB RAM
Card name: NVIDIA GeForce GTX 465

Arthur Hucksake
24th Aug 2011, 19:44
Same problem here. Not cool. Only noticed it in the city hubs, turning corners on the streets. Doesn't matter how low I turn everything, it's still present. I have a high end system too, needs patching or a solution.

Lorloth
24th Aug 2011, 21:42
I remember having exactly the same issue with the first Mass Effect (stuttering in cinematics) on release and I find myself desperately trying to remember how someone eventually figured out a way to eliminate it and coming up short.

Anyone remember that issue and how it was resolved?

sygyzy
24th Aug 2011, 21:49
I am having zero issues with the videos, no issues with tutorials, no stutering and no lag but overall when I mouse-look it just feels sluggish. There aren't times when it freezes or stutters, but instead it feels like the whole experience isn't fluid. Imagine you were giving your nephew a piggy back ride. Sure it doesn't break your back or stop you from walking around or doing chores but everything is weighted down, right?

With that said, what are the graphical items I should turn down or disable, in order from least likely to affect image quality to most likely.

Windows 7
Steam
i5-2500 @ 4 Ghz
8GB RAM
Radeon 5770

ajd155
24th Aug 2011, 22:03
I find it a trifle annoying that my thread was moved into this one and then simply ignored by moderators. All we have in terms of an idea is that if the cutscenes don't lag then we really don't have a problem... though I get sick as a dog watching things rotate which is a BIG problem. Some sort of "we're looking into it" or something along those lines would help...

I can't help but feel like my thread was thrust in here to shove it in a corner and forget about it. Any type of reply would have helped assuage the dissonance but instead I just get "moved". I can't even get much of a reply now because it's in a sea of other ignored problems.

ArnoKalavent
24th Aug 2011, 22:29
I agree ajd, now all the video stuff is being lumped together. I've now managed to completely uninstall and reinstall the newest AMD drivers and my videos are still stuttering. This is beginning to get very frustrating. Where are all the Eidos moderators?

baxterpunch
25th Aug 2011, 01:20
Is it me or are there two different issues being discussed here? Some stuttering/frame skipping in game, some in cinematics?

I am having a horrible issue with frames skipping, dropping and stuttering in game. Cinematics are fine. Played around with settings, still nothing.

AMD 965 quad core Black Edition
8 gb of RAM
Nvidia 460 GTX SE 1GB
Latest video drivers.

Absolutely ruining a great game.

xfullboost
25th Aug 2011, 01:28
Apparently the community has nicknamed this problem "stutterring" and either people have it or they dont. maybe its a type of hardware configuration that is bottle necking this game. i am confident nexxis can patch this quick.

baxterpunch
25th Aug 2011, 01:55
Checked out the steam forums and this configuration has helped A LOT (still getting stuttering, but this makes it playable)

DX 11 on
FXAA High
Texture Filtering: High
Shadows: Normal
SSAO: Off
DOF: Normal
Enable Triple Buffering
Disable VSYNC
Enable Post Processing
Disable Tessellation
FOV: 85

My Specs:
AMD 965 quad core Black Edition
8 gb of RAM
Nvidia 460 GTX SE 1GB
Latest video drivers

Hope This helps.

thgc
25th Aug 2011, 02:01
Hi guys,
just tried setting back my CPU to NOT being overclocked, since I had it slightly overclocked... Now the turning/aiming stutter is practically gone. Some hickups after quickloading, but afterwards everything seems to be running smooth now.
Hope this helps someone.
Cheers,
thgc

cyborg34572
25th Aug 2011, 02:11
Hi guys,
just tried setting back my CPU to NOT being overclocked, since I had it slightly overclocked... Now the turning/aiming stutter is practically gone. Some hickups after quickloading, but afterwards everything seems to be running smooth now.
Hope this helps someone.
Cheers,
thgc

What processor do you have?

thgc
25th Aug 2011, 02:39
What processor do you have?

Intel Core 2 Duo E8400 3GHz . It was @3.6GHZ before I reset it.

xfullboost
25th Aug 2011, 02:54
Checked out the steam forums and this configuration has helped A LOT (still getting stuttering, but this makes it playable)

DX 11 on
FXAA High
Texture Filtering: High
Shadows: Normal
SSAO: Off
DOF: Normal
Enable Triple Buffering
Disable VSYNC
Enable Post Processing
Disable Tessellation
FOV: 85

My Specs:
AMD 965 quad core Black Edition
8 gb of RAM
Nvidia 460 GTX SE 1GB
Latest video drivers

Hope This helps.

what about ansiotropy?

PaterDeus
25th Aug 2011, 03:22
Same problem here, very annoying. Notice more in the streets.

i7 2600K @ 4.5ghz, 8GB ram, 2 x 570 GTX SLI running off a Vertex 2E SSD.

Get over 100fps showing using fraps (120hz monitor) with or without vsync enabled. Usually when turning corners.

I hope Eidos are looking into this.

Are you running directx 9 or 11?

JaredC
25th Aug 2011, 04:55
Processor AMD Phenom(tm) II X4 955 Processor, 3200 Mhz, 4 Core(s), 4 Logical Processor(s)
Version 6.1.7601 Service Pack 1 Build 7601
Installed Physical Memory (RAM) 4.00 GB
Name ATI Radeon HD 5800 Series
Driver Version 8.881.0.0
(xfx 5850 1gb black edition)
OCZ Vertex II 120gb SSD

I've changed all sorts of settings and checked and rechecked my system. I have a decent background in tech support for games and haven't been able to find a fix. Crazy (nearly unplayable) stuttering in hub areas, slight stuttering in more enclosed areas. I also have a slight delay in in-game sounds.

Looking for a fix so that I can get my fix of Deus Ex!

trick1992
25th Aug 2011, 05:07
I too have the stuttering issue. My framerate is great (about 90ish indoors, 50ish outdoors) but it stutters abit when I'm outdoors.

CPU: i5-2400 (sandybridge)
GPU: Sapphire 5850 Xtreme Edition
Ram: 8GB

Bantis
25th Aug 2011, 05:42
UPDATE WITH WHAT HELPED ME: An update to my original post below. I've got the game running fairly smooth now. I just ran the first mission and it was smooth with a nice constant frame rate. I didn't mark the numbers but I'd say it averaged around 40 fps. My main change was that I turned off DirectX 11. I took a few screenshots with it on and off and I honestly didn't see a whole lot of difference. From that stand point its ok but it bums me out as I specifically bought the 460 below for this game because my previous one didn't support DX11. So not thrilled about that....

The other change I made that made a difference was that I changed texture filtering from 16x to 8x. I wouldn't have thought this would make that much of a difference but it did for me. This smoothed the stutter out for me a good bit. This makes me think the stutter is not so much caused by level objects loading on the fly as you walk around but textures being loaded as you walk around. If this is the cause I don't really understand why it's a problem with this game and not more graphically intense games. But I'm not a programmer so...

My other settings for the game are:

Res: 1680 x 1050 60hz
Aspect Ratio: Auto
AA: FXAA High
Shadows: Normal
SSAO: High
DOF: Normal
Triple Buffering: On
VSync: On
Post-Processing: On

You can see my system specs below. I hope this helps someone.

-----------------------------------------------------------------

Having similar problems. It's like the game or something in my system is holding something else back. I have:

GeForce GTX 460
SoundBlaster xTremeGamer
4GB Ram
Windows 7 (fully up to date including DirectX 11)
WD 1TB hardrive
Intel Core Duo E6750 2.66GHz

I have the latest drivers for everything.

My frame rate hovers around 35 but then can go down to the low 20s when viewing some areas and thats when I get the 'stutter'. In a fire fight its alot more noticeable and sometimes the gun sound seems to be a bit slower to sound than when I pull the trigger. (on Windows 7 I don't have the dxdiag hardware acceleration slider). It's playable for sure but it just seems like it should be higher and smoother because I am also getting the turn/load stutter. It's not terrible but it's enough that the game just feels a step or two behind what I'm doing with the controls. The game just feels off.

The main reason I'm posting and what I don't understand though is that none of the graphics settings change the frame rate at all. That is why I feel like something is being held back. If I turn everything on (though nothing above normal) the frame rate is almost exactly the same as when I turn everything off including turning AA to its lowest setting. Setting AA to MLAA doesn't affect anything either. Toggling vsync can have maybe a 2-3 fps second difference but it depends on the area. This I don't understand.

How can turning everything off not affect the game performance?

I hope ppl keep posting some maybe something suggestion will improve things.

AdamJensensAugmentedArm
25th Aug 2011, 05:47
So, this is quite annoying. I can basically max out all of the settings and run this game beautifully until I move my mouse. If I walk around just using wasd I have no problems. The second I move my mouse to look around, I am thrown into a whirlwind of stuttering madness and horrible times. Hopefully someone out there has overcome this same obstacle and gone on to prosper.

Oh, and just to be sure, I have the same issue if I turn all of the settings down to their lowest. Like I said, no problems until I use the mouse.

<<< System Summary >>>

Mainboard : Dell 0Y536R Chipset : Intel PM45 Processor : Intel Mobile Core 2 Duo P8700 @ 2533MHz Physical Memory : 4096MB (2 x 2048 DDR3-SDRAM ) Video Card : ATI Mobility Radeon HD 4670 Hard Disk : Western Digital WD3200BJKT-75F4T0 ATA Device (320GB) DVD-Rom Drive : HL-DT-ST DVDRWBD CA10N Monitor Type : G370R€B156RW1 - 15 inches Network Card : Intel Wireless WiFi Link 5100 Network Card : Broadcom NetLink BCM5784M Gigabit Ethernet PCIe Operating System : Windows 7 Home Premium Home Edition Media Center 6.01.7600 (64-bit) DirectX : Version 11.00 Windows Performance Index : 5.9 on 7.9

Thanks, friends!

smackywolf
25th Aug 2011, 08:49
So very, very sad.

I am also experiencing the stutter. Also, intermittent issues with videos not playing back and crashing the game. I am yet to get the game stable enough to be able to play. Not just loading new areas, loading everything. Turning too quickly gives me a brief stutter, so much so that the game is not playable.

I have confirmed i have the newest Nvidia drivers, reset all the nv settings to the default, confirmed all drivers are up to date, updated BIOS, removed Nvidia 3D vision, messed with every level of settings in the game, enabled/disabled DX11, turned VSYNC on and off, changed the thread priority for the DXHR executable, prayed to the gods to make this game work so I can finally play it :(

No dice at all.

I do not have issues with stuff like Crysis, Fear 3, etc etc.

My specs are as follows:

Mainboard : ASUS P5G41C-M
Processor : Intel Core 2 Quad Q6600 @ 2.4ghz
Physical Memory : 4GB DDR3 1333
Video Card : Gigabyte Nvidia GTX460 1gb
Windows 7 Ultimate x64
Monitor running at 1920x1080
5.9 Windows Experience index

Erika Furudo
25th Aug 2011, 08:50
The game seems to have loading time issues, mouse acceleration issues and FPS issues for me as well.

It's mostly playable, but after long period of gaming with the issues stated above, I get this feeling I just want to turn the game off and not play it for the day..

My rig:
CPU: i7-2600K @ 3.4GHz
RAM: DDR3 8GB
GPU: Nvidia GeForce GTX 560 Ti
PSU: 750 watts
Monitor: ACER 24'' 1920x1080

loinbread
25th Aug 2011, 11:00
I also experience the "stuttering" issue. It'd probably be more accurate to call it "shuddering", I suppose, because the framerate itself doesn't drop, the displaying of the frame itself is what's stuttering.

ArnoKalavent
25th Aug 2011, 12:19
I've done everything now from reinstalling the game to reinstalling my drivers and I'm still getting a stutter only when the FMVs play. Oddly enough the game itself plays extremely smooth.

funkRush
25th Aug 2011, 13:08
Can this thread get a sticky, please?

huginn
25th Aug 2011, 14:11
Ditto. Stuttering happens in big hub areas, and a little stuttering happens in smaller areas now and then. It happens mostly when turning and looking around when graphics are being rendered. Then after a few seconds once everything has loaded and properly rendered, it'll stop. Very annoying I can't imagine getting into a firefight like this. Changing resolution doesn't help. Hope a patch comes soon!

I'm on a Raedon 4850 series, 4gb of ram.

timothydog76
25th Aug 2011, 14:20
Add me to the list of people with the stuttering issue. My PC gaming rig is new and I'm getting very solid frames with all options at max but I started noticing some random dropped frames while moving around last night. A good way to see them is to stare down at the floor while you move. I've tried lowering some of the video settings and get the same results.

My Machine: i5-2500k @ 4.0Ghz - 8GB DDR3 - 80GB Intel SSD 320 - Nvidia GTX 560 ti

cyborg34572
25th Aug 2011, 14:22
Well ive done everything, lower settings , changing drivers, putting clocks to default (processor/memory/Gpu) and nothing changed my stuttering. My framerate is always at 60fps even when the stuttering occurs, its very frustrating. Im trying to enjoy the game but this stuttering even in takedowns is really annoying, everything looks/feels choppy i cant immerse myself. I did not build a powerful rig to get this kind of performance, patch this please.

- Intel i72600k @ 4.5Ghz - 8GB DDR 2133Mhz -1TB WD Black - 2x Sli Asus DCUIIGTX580 (latest drivers)

lexcyn
25th Aug 2011, 16:00
Add me to the list of stuttering when moving the mouse around. Otherwise my frame rates are locked via VSYNC but if I turn it off, I get over 100FPS, so I know it's not my video card.

Specs: Intel i5 760 (quad), 8GB DDR3, Intel SSD, Nvidia GeForce GTX 570 (280.19 drivers, the newest WHQL give me horrible lag everywhere), using on-board Realtek audio, Windows 7 Pro x64

adconne
25th Aug 2011, 17:01
add me to the long list of people with the video stuttering, issue. it's quite obvious the game is accessing the HD way too much and is not very optimized to use enough RAM. there is a similar discussion going on in the steam forums. it would be nice for someone at Eidos to at least acknowledge the problem and that they are working on a solution.

i7-2600K
Nvidia 580 GTX
8 GB RAM
850 W power supply

rock solid stability on my system, no issues with any other games. i feel very misled from all the glowing reviews. for me, this is a game killer.

JaredC
25th Aug 2011, 17:47
It would be awesome if we could hear if the developers have reproduced this issue. I'll wait to play for a better experience if a patch is forthcoming.

BobTheSpy
25th Aug 2011, 18:14
I'm getting some stuttering too, but not as bad as people say. It only really affects me in City Hubs, like Detroit. When I turn around and look at new areas, there's a bit of a stutter. Not enough to ruin the enjoyment of the game, but still annoying.

ericdb
25th Aug 2011, 18:49
I finally get passed the zone alarm issue only to encounter this one.

Tried all settings, high and low. Same phenomenon either way. A stuttering/lagging with mouse movements.

I don't even think there is a need to post my specs since it is clear this isn't a personal computer issue at this point.

>puts Dues Ex on shelf< Awaiting patch. Thank you Edios for a great game, look forward to your improvements soon.

JaredC
25th Aug 2011, 19:21
Strangely, I get the same stutter (though much less of it) on my work computer. I figured that it would be more of a hardware configuration issue but this is pretty different from my home machine. Maybe the issue is wider spread but being largely ignored because the game is still playable.


OS Name Microsoft Windows 7 Enterprise
Processor Intel(R) Core(TM) i7 CPU 960 @ 3.20GHz, 3201 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM) 12.0 GB
Name NVIDIA GeForce GTX 480
Resolution 2560 x 1600 x 59 hertz

ExDeus
25th Aug 2011, 20:01
This might help the lag/stuttering issues

As with most game fixes, some that you may have used before may in fact help fix the problem you’re experiencing with Deus Ex: Human Revolution. If you have any sort of lag of stuttering, then try these solutions.

– If you have NVIDIA 3D Vision installed, then remove the driver as it commonly causes lag and performance drops!
– Using NVIDIA Control Panel for NVIDIA graphics card or ATI Catalyst Center for ATI video cards, you can dramatically increase or even fix some problems you’re experiencing. Firstly, try experimenting with VSYNC — turn V-SYNC ON if it is disabled and then try running the game. If you already have it forced on, then also try disabling it. Depending on the issue, having it enabled instead of disabled or vice-versa may be a better idea than the other. It can help bypass a frames per second / FPS limit or cap and sometimes even helps if you are experiencing blur. VSYNC can effect the refresh rate.
– Another option is to enable Triple Buffering through your GFX Card Control Panel. A program like D3DOverrider can help you enable VSYNC and Triple Buffering for NVIDIA cards.
– Lower the graphics settings, resolution, antialiasing (AA), and other effects
– Upgrade your video card drivers (they generally offer bug fixes and performance increases)


So for the exact steps to enable VSYNC, Anti-Aliasing, and Anisotropic Filtering for NVIDIA cards try:
1) Load the NVIDIA Control Panel (can be accessed in system tray generally or Control Panel)
2) Click “Performance & Quality Settings” -> “Add Profile” -> enter Deus Ex: Human Revolution
3) Click “Browse” -> select the Deus Ex exe -> check the checkbox that’s next to it in the associated application list
4) Under “Application” be sure to select the entry you just added and uncheck “Application-controlled”

For ATI video cards, just Load ATI Catalyst Control Panel and expand the 3D menu. Easy!

more fixes, go here:
http://geekmontage.com/texts/game-fixes-deus-ex-human-revolution-crashing-freezing-no-audio-lagging-black-screen/

Edit:
after uninstalling the 3d drivers, i havent gotten any stuttering/lag
(i also changed the vsync and tripple buffering in nvidia controlpanel)
im on a
i7 950
6gigs rram
gtx 570

libindi
25th Aug 2011, 20:13
This game really need a patch to fix the stutter issue,i have 4GB RAM 1GB VRAM,i never see any game stutters so badly.

libindi
25th Aug 2011, 20:15
http://forums.steampowered.com/forums/showthread.php?t=2075294&page=10 you can see a lot people having the stutter issue here.

ExDeus
25th Aug 2011, 20:23
if u got the nvidia 3d driver installed, and your not using the 3d.. then uninstall them.. worked for me, no stuttering what so ever

read my previous thread for more fixes

libindi
25th Aug 2011, 20:26
I dont have 3d vision installed, and i tried trun on/off vsync and Triple Buffering,the stutter is ridiculous,its like the game only use 10% of all my ram and vram。

bughole5
25th Aug 2011, 20:29
I'm using:

GTX 590
i5 2500k
Corsair TX750 watts
12gb G-SKILL


getting stuttering when turning fast, and when moving into new areas. Also, the load times are fn unbearable.

FalseTautology
25th Aug 2011, 21:25
Same issues as everyone else, stutters when looking around, runs fine when standing still. Gtx 460se, Athlon II x2, 4 gig ram, etc etc. Feels broken and I consider this totally unplayable, but maybe it's me so I'm downloading newest video drivers and windows updates.

jack_black_91
25th Aug 2011, 21:58
I bought Deus Ex 3 on Tues using Steam. I have to say it's a great game, though i'm having a "hiccuping" or studdering problem that is a bit of annoyance. I know my computer is ready for this game, so, here's my specs: Win 7 64bit Home Premium, AMD Phenom II X4 965 (overclocked), 4G Kingston RAM, 2X ATI Sapphire 5770 Radeon Crossfire.

The wired thing is I started the game settings everything on highest and noticed the game "hiccuping". But when turn down the settings, Tessellation, Post-processing, Triple-buffering, Anti-aliasing, Anisotropic filtering, etc, all OFF. The problem continues:/ Logically speaking, shouldn't I notice at least a little boost in performance? I'm thinking It has something to do with game's graphical scripting, because my PC has played way more graphically demanding games with ease running silky smooth, ie: Metro 2033.

Is anyone having the same problem? If so, can you notify me if there is a patch being released soon, that fixes these problems? Or, can I fix this with the resources I have currently with me?

Flakkar
25th Aug 2011, 22:05
Have you installed catalyst 11.8 and 11.8 cap2?

I had pretty severe issues with my 6950s until i installed the CAP.

The CAP brought its own problems though. The steam overlay flickers now, and your hands flicker too but I managed to fix that by ducking into cover and moving around for a bit, and it went away.

jack_black_91
25th Aug 2011, 22:11
Yeah, I did install 11.8 Catalyst. All my drivers are up to date, including Win 7. I'm very anal when it come to making sure I have everything updated:p

PaterDeus
25th Aug 2011, 22:31
I'm using:

GTX 590
i5 2500k
Corsair TX750 watts
12gb G-SKILL


getting stuttering when turning fast, and when moving into new areas. Also, the load times are fn unbearable.


Same issues as everyone else, stutters when looking around, runs fine when standing still. Gtx 460se, Athlon II x2, 4 gig ram, etc etc. Feels broken and I consider this totally unplayable, but maybe it's me so I'm downloading newest video drivers and windows updates.

which version directx are you guys using?

tet5uo
25th Aug 2011, 23:23
Yeah I have the stuttering too when zooming with Ironsights or onto a keypad, as well as when walking into new areas especially in detroit.

My specs:

https://docs.google.com/document/d/1N1lJaY-L94pn4z-bkgsMtVeueRBMtViwU_QxRmdfFl4/edit?hl=en_US

splitsticks
26th Aug 2011, 00:22
I bought Deus Ex 3 on Tues using Steam. I have to say it's a great game, though i'm having a "hiccuping" or studdering problem that is a bit of annoyance. I know my computer is ready for this game, so, here's my specs: Win 7 64bit Home Premium, AMD Phenom II X4 965 (overclocked), 4G Kingston RAM, 2X ATI Sapphire 5770 Radeon Crossfire.

The wired thing is I started the game settings everything on highest and noticed the game "hiccuping". But when turn down the settings, Tessellation, Post-processing, Triple-buffering, Anti-aliasing, Anisotropic filtering, etc, all OFF. The problem continues:/ Logically speaking, shouldn't I notice at least a little boost in performance? I'm thinking It has something to do with game's graphical scripting, because my PC has played way more graphically demanding games with ease running silky smooth, ie: Metro 2033.

Is anyone having the same problem? If so, can you notify me if there is a patch being released soon, that fixes these problems? Or, can I fix this with the resources I have currently with me?

I'm having a similar, if not exact same problem. Running an i7 960, 12gb ddr3 1600 ram, 2x radeon hd6870 (crossfire). What I've found about this stuttering problem is that it primarily occurs indoors. Outside in the hubs I have virtually no issue, but if I step into the apartments (passing no loading screens), then I get major stuttering. I've found that if I disable crossfire this problem goes away completely, so that's what I'm doing. I've also tried lowering my graphics settings into the dirt to see if it fixes it, but the problem still persists. So it seems that the game does not handle crossfire very well.

Bantis
26th Aug 2011, 02:45
The wired thing is I started the game settings everything on highest and noticed the game "hiccuping". But when turn down the settings, Tessellation, Post-processing, Triple-buffering, Anti-aliasing, Anisotropic filtering, etc, all OFF. The problem continues:/ Logically speaking, shouldn't I notice at least a little boost in performance?

Yep. Just adding that is the same experience I am having on my system. Whether I turn everything on or everything off the game performance is almost exactly the same. As I stated in my previous post turning texture filtering down from 16 to 8 and turning off DirectX 11 did improve the stuttering. It's tolerable. But even with that I get the stutter from time to time turning quickly and when I enter new areas.

Also want to add that the new areas are usually not far apart, so it's not like I am crossing a whole map and am loading the entire other side. The stuttering can occur just turning a corner around a building.

It doesn't take much.

ajd155
26th Aug 2011, 04:50
Also want to add that the new areas are usually not far apart, so it's not like I am crossing a whole map and am loading the entire other side. The stuttering can occur just turning a corner around a building.

It doesn't take much.


Exactly my problem here. If you are running one direction and moving the mouse another (like circle strafing) it's huge stutter. I've tried all the settings, defrag, even disabled hypertheading. Nope. It's definitely the engine. Or maybe copy protection, idk.

Bercut
26th Aug 2011, 05:22
I'm getting some stuttering too, but not as bad as people say. It only really affects me in City Hubs, like Detroit. When I turn around and look at new areas, there's a bit of a stutter. Not enough to ruin the enjoyment of the game, but still annoying.
+1 for me. GTX480, i7-930, 6 GB RAM, Win 7 x64. Annoying, but can be played. Still hope to see a fix for it.

jack_black_91
26th Aug 2011, 07:20
Well, this is a temporary resolver but at least it makes the experience tolerable. I set my resolution settings from 1920x1080 to 1360x768, and after the game runs silky smooth. Though it's not on high setting, like I want it to be:c

This is really bad for the PC community, being console versions run and "probably" look better better than this:\

ajd155
26th Aug 2011, 10:15
I've tried everything in this thread but nothing solves the problem. Some things seem to lessen it a bit, but never truly get rid of it. At the lowest game settings the problem is 20x worse. (266 drivers were the best btw.) Latest patch did nothing for the stutter though I gotta give them credit the load times are much faster. (Nice job guys!)

I tried an xbox 360 controller based on a post I read and the game was very smooth and wonderful as it was meant to be. So this is obviously not about computer specs, driver versions, mouse acceleration overrides, ambient occlusion, antialiasing, etc etc. At least for me. Some tweaks helped a bit more than others, but in the end it was all unbearable.

My controller I noticed would fight with the game for attention if I tried to use the mouse. As if both were enabled at once. So on a hunch I unplugged it, though normally I leave it plugged in and just sitting to the side. This actually helped a lot with the super micro stuttering, but added a new level of weird sudden stuttering every few seconds. Figured I'd restart the game, problem is worse. So now I can move around an object without it going *too* crazy back and forth, but it still does micro stutter more than is comfortable. Now there are big stutters often. But when I plug in the controller and use that there are none at all, no big or small stutters. (Other than loading stutters which are different and I understand in any game be it morrowind or deus ex.)

If you have a controller, plug it in and test it. It's smooth. Looks and acts like it should.
Now unplug it and wait for a patch. Stop gimping your graphics and game settings to no avail. It's not you. It's on them at this point.

I really wish they had just delayed it for Christmas. But I am happy for the people that it's running fine for. I cant switch from mouse to controller on a shooter, it just feels wrong. I'll wait to play it, hopefully not forever.

ArnoKalavent
26th Aug 2011, 11:36
I know we seem to be tracking a handful of problems in this thread, but for those of you who have the FMV stuttering I offer a small suggestion. I noticed that my audio driver was at least 2 years old, and tracked down and upgrade. That seems to have cleared up most of the problem on that front. Hope that helps at least some of you.

funkRush
26th Aug 2011, 12:05
Someone wrote something about uninstalling or disabling 3D Vision drivers if you are not using 3D Vision. Maybe it helps here, too.

Spookyy
26th Aug 2011, 13:23
I get the same loading? stutter that make the game freeze for split second.

I get 40% gpu usage, a bit low for a new game =)

Using Phenom II 4x, Geforce 460gtx 1gb, 4gb ram, Windows 7 x64, dedicated gaming drive with loads of space.
Defragged and no crap stuff in the background and updated drivers etc.

libindi
26th Aug 2011, 13:53
Are the developers working on this issue?

funkRush
26th Aug 2011, 14:27
Did someone try my suggestion? Uninstalling the 3D Vision drivers and the Stereo HD drivers from Nvidia. Or simply just installing the graphic card driver and the PhysX driver without any additions offered.

In the 25th August patch post they said they are reading our posts and working on the issues. So I guess this is getting worked on as well.

ExDeus
26th Aug 2011, 15:38
i did try it, it helped a bit, but it came back after awhile...:mad2:

AdamJensensAugmentedArm
26th Aug 2011, 16:21
I tried a 360 controller and had the same results. Movement with the left thumbstick results in smooth gameplay, but the second I begin using the right, the same exact stuttering problem pops up again.

ajd155
26th Aug 2011, 18:16
I tried a 360 controller and had the same results. Movement with the left thumbstick results in smooth gameplay, but the second I begin using the right, the same exact stuttering problem pops up again.

Bummer, it's more pervasive than I thought.

jack_black_91
26th Aug 2011, 19:08
I'm having a similar, if not exact same problem. Running an i7 960, 12gb ddr3 1600 ram, 2x radeon hd6870 (crossfire). What I've found about this stuttering problem is that it primarily occurs indoors. Outside in the hubs I have virtually no issue, but if I step into the apartments (passing no loading screens), then I get major stuttering. I've found that if I disable crossfire this problem goes away completely, so that's what I'm doing. I've also tried lowering my graphics settings into the dirt to see if it fixes it, but the problem still persists. So it seems that the game does not handle crossfire very well.
Yup, that is pretty much what i'm getting. Though for me "studdering" or "hiccuping" occurs in pretty much every facet of the game; outdoors, inside, and even in the vents, where you'd think there would be a lot less to render.

And, you have a better rig than I do, and seems you are getting the same issue as I am. So that says a lot. Coupled with this knowledge, it has to be the games scripting that is causing the problem for so many PC users.

funkRush
26th Aug 2011, 19:53
I'd really like an offical statement on the problem if this is possible in any way.

DesaanUK
26th Aug 2011, 19:54
Stuttering is atrocious, totally unplayable. How can the highest and the lowest settings yield the same performance? Something is horrible wrong here......


So I took a look in the game folder and was surprised at the total lack of game files, there is basically 4 large files all named bigfile.001 to 004 and a few dll's. Surely this can NOT be a good thing when it comes to accessing files required by the game engine. The HDD (SSD or otherwise) must be thrashing like crazy grabbing the resources from such large (and probably compressed) files.

These files NEED to be unpacked as I'm pretty sure they are the source of the problem.

Mystery
26th Aug 2011, 20:12
Stuttering here as well.

I don't have a high-end rig, but it's well above the minimum requirements and performs the game quite well.

Athlon 64 X2 5800+ (2x3.00GHz)
4GB DDR2 800 RAM
ATI Radeon HD4850
Windows XP X86 SP3
Windows is installed on a 10K rpm WD Raptor and DeusEx is on a seperate 7.2k rpm SATA HDD.

These are my regular settings:
1680x1050 (native resolution of my 22" screen)
Edge AA
16xAF
Shadows, SSAO, DOF all on normal
Triple Buffering, VSync, Post-Processing all enabled

I usually get 30fps (vsync on) or 40-50fps (vsync off) with this configuration, but the game stutters heavily under these circumstances:
-loading a game
-entering a new area (loading screen)
-quickly travelling from point A to point B in the game world

While I'm (slowly/normally) moving at a certain location, the game runs perfectly, but when the engine has to stream a part of the game world that's not currently in memory, the fps drop significantly.

This would also explain why the video settings have little impact on the problem.
I tried the following settings:
800x600 and everything on low or off with no AA/AF. While the stuttering didn't last as long (for example after loading a game) it was still the same as before. As jack_black_91 said, it even happens inside a vent, where there shouldn't be any performance issues.

This -has- to be a problem related to the streaming of the game world itself, which works great on consoles but seems to have been poorly ported to the PC.

The problem also only occurs when I'm looking around. If I don't do anything after loading the game, the fps are steady. Moving forward/backward and strafing left/right doesn't have an impact on the fps as well. Neither does looking up/down with the mouse have much of an impact.
But when I turn around to a new area after loading, the fps drop heavily until the game has streamed the content. This also shows, that it's not a controller problem, because the issue would always be there, but it's not. After the game has loaded the current area around me, I can do whatever I want and the fps are smooth.
But when I quickly move towards a new area (or an old area that's not cached anymore), it starts all over again.

The game itself runs smooth even on my old system, but the streaming doesn't seem to be very well optimized for the PC, or for DX9, as some people report less stuttering with DX11.

Arthur Hucksake
26th Aug 2011, 20:15
I'm leaning towards a GPU issue.

My C drive is an SSD with an SSD swap file. 8GB of ram, I have a seperate SSD which has my Steam directory on with the game installed. Disabled Indexing, because they are SSD.

Mystery
26th Aug 2011, 20:39
It can't be a GPU issue. Why?
-people with high end Crossfire or SLI cards encounter the same stuttering
-the stuttering occurs even in locations like inside a ventilation shaft, which shouldn't cause any GPU to drop fps
-if it was a GPU issue, using the lowest possible video settings would resolve the problem or at least reduce it very significantly, which it doesn't

Arthur Hucksake
26th Aug 2011, 20:47
GPU-Z reports only 187MB of Vram is getting used during this game. Might have something to do with it.

DesaanUK
26th Aug 2011, 20:51
Also noticing low CPU and GPU usage on my end = screw you PC users enjoy your ****ty port?

Cloakmachine
26th Aug 2011, 20:56
GPU-Z reports only 187MB of Vram is getting used during this game. Might have something to do with it.


Also noticing low CPU and GPU usage on my end = screw you PC users enjoy your ****ty port?

Sounds pretty serious. I'm on an i5-2500K (3.7Ghz Turboboost), ASUS GTX560Ti DCU II Top, 8GB DDR3 1600MHz RAM. Using Realtek HD Audio Manager. Motherboard is an Intel, can't remember the exact one from the top of my head.

The problem occurs for me when I'm turning around most of the time. Turning in general seems to be the problem and it's always happening when on the move. Makes the game quite tedious to play, considering that my computer isn't exactly low tier either. Not to mention, I'm only on 1680x1050.

DesaanUK
26th Aug 2011, 21:07
Anyone else noticed DE:HR using obscenely low system resources?

Current V-Ram usage (CPU-Z): 187mb (lol)
Current System Memory usage (Windows Task Manager): 587mb

Meanwhile my CPU usage is spiking all over the place, anything from 30-90% (AMD Quadcore BE) WTF? So totally random.....

Is it trying to run this game via CPU/GPU processing power alone?

Lamargo
26th Aug 2011, 21:27
Having a quick read over what people are saying here about this, and kudos to the community for keeping this rational, but I get the feeling this is more processor related than graphics. I can't quite place it, but I am sure I have encountered something like this before with other games... Anyone looked in to updating their BIOS? This is usually the place for improvements on CPU handling. Note: I am not saying CPU's are maxed out, seems obvious most aren't, but that doesn't stop the info flowing in strange ways if there are certain system bottlenecks somewhere.

Arthur Hucksake
26th Aug 2011, 21:43
Having a quick read over what people are saying here about this, and kudos to the community for keeping this rational, but I get the feeling this is more processor related than graphics. I can't quite place it, but I am sure I have encountered something like this before with other games... Anyone looked in to updating their BIOS? This is usually the place for improvements on CPU handling. Note: I am not saying CPU's are maxed out, seems obvious most aren't, but that doesn't stop the info flowing in strange ways if there are certain system bottlenecks somewhere.

Wish it were that simple. Worth risking a 6 month stable system because of one badly coded game? Not sure it is.

cupojava
26th Aug 2011, 21:44
So I took a look in the game folder and was surprised at the total lack of game files, there is basically 4 large files all named bigfile.001 to 004 and a few dll's. Surely this can NOT be a good thing when it comes to accessing files required by the game engine. The HDD (SSD or otherwise) must be thrashing like crazy grabbing the resources from such large (and probably compressed) files.

These files NEED to be unpacked as I'm pretty sure they are the source of the problem.

The large archives are used to reduce seeks.


The file systems used on consoles are rather simple, which has some implications. For example, simply opening and closing files takes a lot more time than you first might realize. When there are too many files in a folder, we need extra seeks to read file table data. There are hard limits on the number of files in a folder and the length of filenames. We want to allow artists and level designers to organize their data in a logical way, and we want to be able to quickly find data during development. However, even changing the folder being read from will cause an implicit seek. Checking if a file exists or a file's size may also cause an implicit seek.

Our solution to the overhead of handling files is to have a simple, platform independent game file system. All files are combined into several large archive files, and these files are kept open at all time. When the archive files are created, we hash filenames and store the hash. The archive file's table of contents is always kept in memory and contains the hashed filenames, the archive file handle, offsets of the files in the archive and the sizes of the files in the archive.

Since we have all archive files open at all time, we never need to use the expensive open/close system calls. As we always have the table of contents in memory, we can quickly return the size of every file. As all file request are simply seeks inside the already opened archive files, we do not cause extra seeks when we change to read from another directory.

Arthur Hucksake
26th Aug 2011, 21:52
Well good for the devs and their console friendly happier development cycle.

Alot of people still cannot play, and when they can it's stuttering.

ajd155
26th Aug 2011, 21:56
The large archives are used to reduce seeks.

So where did you find that from? Certainly not this thread...

Is this something they had prepared in already before the game came out? If so, then they KNEW.

cupojava
26th Aug 2011, 21:58
So where did you find that from? Certainly not this thread...

Is this something they had prepared in already before the game came out? If so, then they KNEW.

Not trying to be rude, but I'll just say this... the programmers are very smart. If the solution is just to unzip the files ahead of time, then they would have done it.

This is like you going into a hospital and trying to tell a doctor what to do after reading WebMD for 30 minutes. It just makes them laugh inside.

Arthur Hucksake
26th Aug 2011, 22:02
Not trying to be rude, but I'll just say this... the programmers are very smart. If the solution is just to unzip the files ahead of time, then they would have done it.

This is like you going into a hospital and trying to tell a doctor what to do after reading WebMD for 30 minutes. It just makes them laugh inside.

So smart their idea in this instance has obviously failed, where as many other games that don't use this method... work.

Doctors get things wrong all the time. Just like devs release most games broken.

funkRush
26th Aug 2011, 22:08
For many people the game works just fine so the technic works. Because of the wide varity of PC platforms and setups there are always going to be problems with released games. The developers can't test any possible actual or outdated PC configuration.
Give them time to figure out whats failing on certain systems. An offical statement would still be very appreciated.

cupojava
26th Aug 2011, 22:09
So smart their idea in this instance has obviously failed, where as many other games that don't use this method... work.

Doctors get things wrong all the time. Just like devs release most games broken.

Ouch. Well, I guess as a programmer I see it from a different perspective than the end-users. You guys have no idea how complicated this stuff gets.

ajd155
26th Aug 2011, 22:11
Not trying to be rude, but I'll just say this... the programmers are very smart. If the solution is just to unzip the files ahead of time, then they would have done it.

This is like you going into a hospital and trying to tell a doctor what to do after reading WebMD for 30 minutes. It just makes them laugh inside.

Er, I work with programmers every day. They can be smart as hell but it takes one moron from marketing or the the business division to destroy all that smartness. Brains have nothing to do with it. Nothing, because the programmers do not run the show.

A better way to put it would be: It's like going to the doctor and he already has a prognosis before even looking at you or picking up a stethoscope.

Whenever you read the words "platform independent" your brain should automatically covert that to "not optimized for any platform".

cupojava
26th Aug 2011, 22:17
Er, I work with programmers every day. They can be smart as hell but it takes one moron from marketing or the the business division to destroy all that smartness. Brains have nothing to do with it. Nothing, because the programmers do not run the show.

A better way to put it would be: It's like going to the doctor and he already has a prognosis before even looking at you or picking up a stethoscope.

Whenever you read the words "platform independent" your brain should automatically covert that to "not optimized for any platform". I can see that these files are not "always in memory" by just looking at how much ram Deus ex is using. It's not hard. It doesn't take a smart programmer to see it.

Funny that you put it that way, since I'm a programmer that owns a marketing company. So I see both sides of the coin.

The non-technical people are always demanding "I just want xyz, why is it so hard for you to do?" It only seems easy because you're not the one who has to implement it.

That quote I posted was from an article meant to explain why things are packaged into large archive files....you automatically zoomed in on the "console" part of it. That wasn't what I was trying to point out at all and I guess it went above your head.

Lamargo
26th Aug 2011, 22:18
Wish it were that simple. Worth risking a 6 month stable system because of one badly coded game? Not sure it is.

"badly coded game" is pushing it a bit there, don't you think? There is still no common cause for this issue and lets not go overboard and assume that everyone is getting this problem. The majority aren't. Not trying to belittle that there is a problem here, but lets stay objective and try to figure out the cause instead of pointless finger pointing.

A game which is just released is tested against 'today's' systems, which are updated fully. This includes, BIOS, drivers, the whole kit and caboodle! :) In order to troubleshoot this issue properly, you have to make sure your system is fully updated first, so as to reduce the number of factors which can be attributed to the issue. Updating the system BIOS is a part of that. Have you had a look to see what updates are available even? Most times when I have checked for BIOS updates I find that along with specific fixes, there can be general performance increases also. :)

Arthur Hucksake
26th Aug 2011, 22:48
"badly coded game" is pushing it a bit there, don't you think? There is still no common cause for this issue and lets not go overboard and assume that everyone is getting this problem. The majority aren't. Not trying to belittle that there is a problem here, but lets stay objective and try to figure out the cause instead of pointless finger pointing.

A game which is just released is tested against 'today's' systems, which are updated fully. This includes, BIOS, drivers, the whole kit and caboodle! :) In order to troubleshoot this issue properly, you have to make sure your system is fully updated first, so as to reduce the number of factors which can be attributed to the issue. Updating the system BIOS is a part of that. Have you had a look to see what updates are available even? Most times when I have checked for BIOS updates I find that along with specific fixes, there can be general performance increases also. :)

A common factor is the Alice Garden pods area is causing a crash. That's the only specific common thing i've come across on various forums. That and it's generally related to nVidia hardware, 5xx series in particular.

That's one example.

http://forums.steampowered.com/forums/showthread.php?t=2080441

Outright strange GPU usage also deserves a mention. 187mb of vram used? Is that all? 580mb of ram?
Why bother with minimum specs? Someone has mentioned only one CPU core gets used, not checked for myself yet.

I played the Detroit city hub without any problems, apart from the odd stuttering. Crashing started either when the last patch landed or when I got to the Chinese city hub. If I switch to DX 9, it's fine but stutters like crazy.

Running an i7 2600K, 8Gb Ram, 240GB SSD and 2 x 570 GTX SLi

http://forums.steampowered.com/forums/showthread.php?t=2080828 Another mention.

And another bunch of people. http://forums.steampowered.com/forums/showthread.php?t=2080828&page=2

Only common factor are the 5xx series of cards and/or i7 Sandybridge CPUs that keep popping up.

Was the game even tested in-house on nVidia hardware?

Arthur Hucksake
26th Aug 2011, 22:54
Another unlucky person. http://forums.nvidia.com/index.php?showtopic=208723&st=0&gopid=1284745&#entry1284745

nVidia again.

ajd155
26th Aug 2011, 22:58
"badly coded game" is pushing it a bit there

Granted it's emotionally charged but maybe a little accurate. Perhaps it should be called "poorly optimized" or even "rushed".

ajd155
26th Aug 2011, 22:59
Another unlucky person. http://forums.nvidia.com/index.php?showtopic=208723&st=0&gopid=1284745&#entry1284745

nVidia again.

I do think the quality at Nvidia is going downhill quickly. This will be my last nvidia card but not because of deus ex.

Since refunds on games are generally impossible I would be very in favor of a law that requires all games to list the hardware they were tested on. (Or one that let's us return games, but that will never happen.)

Arthur Hucksake
26th Aug 2011, 23:10
I do think the quality at Nvidia is going downhill quickly. This will be my last nvidia card but not because of deus ex.

Since refunds on games are generally impossible I would be very in favor of a law that requires all games to list the hardware they were tested on. (Or one that let's us return games, but that will never happen.)

ATI were known for driver problems for years, lately they seem to rush out fixes and CAP updates almost weekly. nVidia, your lucky if you get a beta driver once every 3 months. Took them 3 months to get the Witcher 2 working properly. (Atleast it didn't crash)

Hope that's not another case here. Getting to the point now where there isn't any point in buying a game on launch.

Industriality
26th Aug 2011, 23:12
Stop blaming Nvidia, their drivers are way better than AMD.

I run two 580 in SLI and everything runs smooth and stable.

The only issues I have are with sound being delayed, but it's not hardware related.

Heinosity
26th Aug 2011, 23:20
Having the same issues here as everyone else...stuttering / loading / lagging every 10 seconds or so while getting a solid 60 FPS otherwise...

Please Eidos, this game is awesome, and it is a crying shame that so many players are having this problem. I have tried all of the different settings in the game's setup, tweaking settings in CCC, running the game with high priority, and even reinstalling drivers. My system is clean, defragged, up to date and all that and what not, and it seems like nothing helps.

My specs:

AMD Phenom II X6 1055t @ 3.36 GHz (Removing the overclock doesn't help)
8GB G.SKILL Ripjaws DDR3 1600 MHz
2 x AMD Radeon 6850 CrossfireX @ Stock
Western Digital Black 500GB
Windows 7 64-Bit
Catalyst 11.8 w/ 11.8 CAP2

I just want to play this incredible game, and this frustrating stuttering is driving me crazy!

:mad2: :mad2: :mad2:

Arthur Hucksake
26th Aug 2011, 23:23
Stop blaming Nvidia, their drivers are way better than AMD.

I run two 580 in SLI and everything runs smooth and stable.

The only issues I have are with sound being delayed, but it's not hardware related.

Run the 280.26s and monitor your fan speeds, voltages and gpu usage. Then tell me how awesome their drivers are, in a permanent state of something bad about to happen.

Also noticed another common denominator. Windows 7 64 bit. (But nearly everyone runs that now, so it figures)

funkRush
26th Aug 2011, 23:26
Someone wrote on the forum that he had no problems after reverting back to the 275.33 driver from the 280.26 driver. Give it a shot?

Arthur Hucksake
26th Aug 2011, 23:31
Someone wrote on the forum that he had no problems after reverting back to the 275.33 driver from the 280.26 driver. Give it a shot?

Tried that. Still noticed a hard lock crash around the Alice Pod Gardens area in the Chinese part.

DesaanUK
27th Aug 2011, 00:13
The PC version is using virtually no video or system memory. Xbox 360 has GDDR3 RAM clocked @700 MHz, PS3 uses 256MB GDDR3 video memory and 256MB of XDR DRAM system memory (very high performance in small amounts) an effective 512MB combined. Current system memory being used by DE:HR on my system 580mb (4GB Corsair Dominator DDR3 @1600 MHZ). Current V-Ram being used on my ATI 4890 1GB GDDR5, a whopping 187MB.

It's almost as if I see a pattern developing, hmmmmmmm.

Anazzar
27th Aug 2011, 00:29
Figured I would post in here instead of creating another thread

Getting an unplayable amount of load stuttering my spec is

CPU: AMD 955 BE
RAM: 4GB DDR3 1333mhz
MB: MSI 790FX GD70
GPU: 5870CF
OS: Windows 7 64 bit

Getting well over 80fps but walking about the city just constantly stutters when I go walking about so far I have tried

*turning vsync on/tripple buffering
*turning Dx11 off
*lowering settings
*turning AA off
*turning off crossfire
*setting GPU clocks to stock
*defragging system

Bit gutted about being reccomended the PC version and it turning out like this but I have patience and other games so I dont mind waiting for a patch. My only worry is if eidos dont bother addressing the issue which has been the fate of other ports (looking at you saints row).

Ilaniol
27th Aug 2011, 00:49
I also had pretty bad stuttering/ frame rate drops with similar hardware to what many of you hear have, I turned DX11 ON and the performance was dramatically smoother. Weird, here are my specs:

~Phenom II X4 955 Black edition @ 3.9 Ghz
~8GB DDR 3 Ram in duel channel
~onboard 7.1 realtek sound
~ GTX 460 1GB
~Msi motherboard, cant remember exact model but its an 870 or somthing like that
~20 inch widescreen monitor

tet5uo
27th Aug 2011, 01:24
It's as if the game is steaming in data in very small chunks.. almost as if to compensate for a system with very limited RAM.

I have 12gb of system RAM and 1.5gb of VRAM, please load more into it at once, I hate the stuttering when walking about.

Heinosity
27th Aug 2011, 01:45
It's as if the game is steaming in data in very small chunks.. almost as if to compensate for a system with very limited RAM.

I have 12gb of system RAM and 1.5gb of VRAM, please load more into it at once, I hate the stuttering when walking about.

Yeah, I have noticed the game only uses around 700MB of system RAM, and while using the monitoring in MSI afterburner I noticed each GPU is only at 50-60% utilization. Just now I was playing and noticed that the hard drive activity light comes on every few steps and of course, the stuttering comes on with it.

Seems like the game just needs to use more resources...I dunno.

numinous
27th Aug 2011, 04:43
Man... this was so predictable. Who would have thought another console port FPS would be unoptimized?!

I've got the same problem as most of this thread. Whenever I look at a new asset it freezes. If I turn a corner or turn around quickly it'll lag for up to 3 seconds. FPS otherwise sits on 100+. No fixes/options have changed anything. Had the exact same issue with CoD BlackOps and they didn't fix it for 3 months. This is why I have no faith in modern video games.

E6550
GTX 560
4GB Ram
1 HDD Sata

:mad2::mad2::mad2::mad2::mad2::mad2:

CollegeShinobi
27th Aug 2011, 05:06
Okay, after taking the painstaking hours of time to read every post thoroughly I have seen people toss around many ideas and I found one that worked for me and figured I would share.

I went into the Task Manager and set "dxhr.exe" to a High Priority process and I have not seen the shuddering since.

It would only occur between loading zones and when there was a sudden large onscreen set of graphics, such as the city hubs. This didn't just stutter the frame but stopped my character movement too for about half a second. Very annoying. However, I experimented with my Nvidia Card and Direct X11 settings to no avail. It has to be processor-oriented.

Bit of info:
Windows 7 (64-bit). DXHR is a *32 exe.
8GB DDR3 RAM.
AMD Pentium II 2.6 GHz
DxDiag 6.01.7601
No Nvidia 3D Vision installed.
VSync on.
Triple Buffering on.
Manually set pre-rendered frames to 5 instead of 3.
16x Anisotropy
High Antialiasing
SSAO Off
Manually configured Nvidia control panel to override Deus Ex and use my global settings for performance instead of quality. No noticeable detail difference. Plays smoother.

I set the process to Realtime just for funsies and it plays great. FYI.

Woopzilla
27th Aug 2011, 05:17
I'm getting stuttering and 'micro' freezes every 10 to 15 steps as I walk around the city too (no audio issues though). I was really not expecting this as the graphics aren't exactly as incredible as other recent games (I play Witcher 2 maxed out with absolutely no lag or stutter). It really does seem like the game just isn't making use of the resources available to it and keeps loading things in chunks and quickly clearing it once it's out of sight.

Windows 7 64-bit Pro
Intel i5 750 @ 2.67GHz
Asus P7P55D-LE Mobo
4GB DDR3 1333Mhz Corsair
XFX ATi HD 5850 XXX Edition
24" WS Samsung 2433 @ 1920x1200@60Hz

All drivers are the latest.

JustDave
27th Aug 2011, 05:33
Stuttering is happening for me too. When I use a 360 controller it seems a lot smoother. Also, when I disable SSAO and/or force on Vsync and turn on Triple Buffering in the nVidia CP, it seems to work somewhat better with a k/m setup.

Just like everyone else in this topic, I'm getting high FPS and stuttering issues. If I just don't use the mouse then everything is great.

Without any above tweaks, on maxed settings, I get a consent 120-100fps inside and 100-80fps outside. Sometimes the outside fps has gone higher but this is just a rough estimate. Even with such a great framerate, the stuttering just kills it. What's the point in investing money in all this power when the game won't even let me implement it properly?

Specs:
Intel i7-920 3.6GHz OC
EVGA X58 SLI
EVGA GTX 570 Classified w/EVGA GTX 285 PhysX
G.skill 12GB (6 x 2GB) DDR3
Acer GD235HZ 1920x1080 120hz

Either a game patch or video driver would be appreciated. :D

Update: Actually, forget the nVidia CP tweaks. The stuttering is better but the FPS takes a massive his when outside. The in-game Vsync and Triple Buffering work better for me.

However, for me, turning SSAO off almost completely takes away the stuttering. I can't even tell a difference in the graphics with it disabled.

Also, a weird thing I noticed on the title screen, not sure if anyone else noticed it. At the main menu, if you move the mouse around, not only will the background start to stutter but I would lose frames as well. It would drop from like 80 to 60 and sometimes even 50 just by moving the mouse.

david75sk
27th Aug 2011, 05:36
So I have the same problem as you :/ Game stutters constantly while moving.

C2D E8200 @3,2GHz
2x2GB DDR2 800MHZ
GTS450 1GB DDR5
Asus P5K Pro
onboard audio

It looks same as problem with Call of Duty Black Ops. They something ****ed up too. They fixed it a bit, but the game is running 2 times better (literally on every computer) on Windows XP even almost year after release. I have tested on mine with dual boot and its true. In Windows 7 I am getting stuttering in multiplayer and like 40FPS, but in the XP is an another story and the game is very smooth with no stuttering at all and constant 70-90fps.

I have already installed XP to test Deus Ex: HR and what I can say is that I have better FPS and less stuttering. In Detroit city hub (right when you leave Sarifs HQ): Win 7 - 30FPS and stuttering like from hell on every second; Win XP - 50FPS and it stutters only when new location is loading, like when you move in/out of the buildings... Of course I have the same settings on both OS and both OS are fresh installations.

So I have read steam forums and this forums and the brand of GPUs and CPU are different, someone stutters on AMD, someone on Intel, Nvidia, Ati (AMD)... But I noticed you all didint mention your soundcard. That makes me think you have onboard audio, probably Realtek HD Audio. And Why it runs better on XP? Because Windows 7 is using different method working with audio.

My friend have C2Q, 4GB RAM, Ati 6870 and game runs like butter on win 7, but he has Sound blaster Audigy.

jeremygrim
27th Aug 2011, 06:11
Yep, same problem as all the rest of you. Decided I'm not gonna play the game til it's fixed, it's just too frustrating. I really hope they fix this soon, it's such a bummer. Only stutters when looking at new areas.

jack_black_91
27th Aug 2011, 06:16
Okay, after taking the painstaking hours of time to read every post thoroughly I have seen people toss around many ideas and I found one that worked for me and figured I would share.

I went into the Task Manager and set "dxhr.exe" to a High Priority process and I have not seen the shuddering since.

It would only occur between loading zones and when there was a sudden large onscreen set of graphics, such as the city hubs. This didn't just stutter the frame but stopped my character movement too for about half a second. Very annoying. However, I experimented with my Nvidia Card and Direct X11 settings to no avail. It has to be processor-oriented.

I tried this, and it worked really well:D I started the game with all settings on highest (Tessellation: ON, Triple-buffering: ON, Anti-aliased: MLAA, Anisotropic filtering x18, Shadows = Soft, Depth of field = High etc) and it runs better than it did previously, though it still has the occasional "studder" here there, overall it runs pretty damn good, not silky smooth but this is a start.

jeremygrim
27th Aug 2011, 06:20
I tried this, and it worked really well:D I started the game with all settings on highest (Tessellation: ON, Triple-buffering: ON, Anti-aliased: MLAA, Anisotropic filtering x18, Shadows = Soft, Depth of field = High etc) and it runs better than it did previously, though it still has the occasional "studder" here there, overall it runs pretty damn good, not silky smooth but this is a start.

I tried it too and it seems like it would fix the problem but it's not having any noticeable effect for me... :(

jack_black_91
27th Aug 2011, 06:29
I tried it too and it seems like it would fix the problem but it's not having any noticeable effect for me... :(
That's odd. From reading others posts on this thread too, the problem does seem to be pointing towards allocation of the games processes. And, possibly GPU allocation.

bughole5
27th Aug 2011, 07:03
im sure theyll fix this like they did every other issue so far

tet5uo
27th Aug 2011, 07:09
well, on max settings with AA and triple buffered vsync, the game is only using 330ish megabytes of VRAM. It's too bad there isn't a higher than high setting for PC's that can handle it. Or at least make it so that powerful machines like mine don't stutter loading stuff every few seconds that could be already in cache somewhere.

It's nowhere near gamebreaking stutter for me, but I have an overkill PC, so i can imagine it might be more stuttery on alot of machines with more reasonable specs.

Zekzt
27th Aug 2011, 07:42
Well i can ad some confirmation myself about the issue.

Since i have acess to 4 difrent rigs and i tested the game on all of them including my own two machines.

But to start of :

PC no1 [my own old machine]

C2D E8400 [4.0 OC] GTX 260 65nm EVGA Superclocked, 4 GB RAM DDR 2 800 Kingston, ASUS P5K-E, Win XP 32b SP3 [DX9 Rendering]
Game runs fine in terms of perfomance, indor - 60 fps, outdor 45-50. But it stutters of course like in everyone else cases. Mostly when entering new area, and looking around, it looks like the game loads in real time the data [textures, terrain]. The issue is very similiar to the stuttering problem in latest COD and earlier in Alpha Protocol [both games had very similiar issues that was fixed]
I had to add that changing the graphical setting, turning them all off or on have no effect.

PC no2
i5 2500k, GTX 460 Gigabyte, Gigabyte GA-870A, GoodRam 4GB DDR3 1600, Win 7 32b
The same issue as above, it stutters in both renderings, dx9 and dx11.

PC no3
i5 2500k, Vertex3D Radeon HD 6950, AsRock P67 PRO3 B3, GoodRam 2x4GB 1600MHz, win 7 64b
The same issues, nothing can eliminate them on this rig as well.

PC no4 [my current rig]
i7 2600k, EVGA GeForce GTX580 , Corsair 8GB (2x4GB) DDR3 1600MHz CL8 Vengeance, Asus P8P67 PRO Rev. 3.0, OCZ Vertex2 E 60GB SSD, Samsung 500GB 7200rpm 16MB F3, Win 7 64b

The game stutters like in all previous machines. But here i was able to test the hard drive sugestion - it didnt helped, loading times become shorter sure [from 12-14 seconds on HDD to 8-9 on SDD], but stutterings still occur, no mater wich rendering i use or what settings or resolution i chose.


Its for sure not hardare related issue, we are too many in numbers here and we all have the same exact issue.
The one thing that helped a little thou was turning off the v-sync and tripple buffering in game setup and forcing it on in D3DOverrider. Stuttering still occurs, but its slightly smaller.
Probably people before me posted this already, but the stutters [in micro version] occurs in dialouges too, wich looks quite horrible in estetic and visual experience.

I hope dev team people acknowledge the issue already and they are working on some hot-fix/patch. Its damn good game, one of the best ever made, but this technicall issue is horrible and annoying.
I also hope we wont wait for the patch or hot-fix for this, for another year...

TROOPER181st
27th Aug 2011, 07:48
Well i can ad some confirmation myself about the issue.

Since i have acess to 4 difrent rigs and i tested the game on all of them including my own two machines.

But to start of :

PC no1 [my own old machine]

C2D E8400 [4.0 OC] GTX 260 65nm EVGA Superclocked, 4 GB RAM DDR 2 800 Kingston, ASUS P5K-E, Win XP 32b SP3 [DX9 Rendering]
Game runs fine in terms of perfomance, indor - 60 fps, outdor 45-50. But it stutters of course like in everyone else cases. Mostly when entering new area, and looking around, it looks like the game loads in real time the data [textures, terrain]. The issue is very similiar to the stuttering problem in latest COD and earlier in Alpha Protocol [both games had very similiar issues that was fixed]
I had to add that changing the graphical setting, turning them all off or on have no effect.

PC no2
i5 2500k, GTX 460 Gigabyte, Gigabyte GA-870A, GoodRam 4GB DDR3 1600, Win 7 32b
The same issue as above, it stutters in both renderings, dx9 and dx11.

PC no3
i5 2500k, Vertex3D Radeon HD 6950, AsRock P67 PRO3 B3, GoodRam 2x4GB 1600MHz, win 7 64b
The same issues, nothing can eliminate them on this rig as well.

PC no4 [my current rig]
i7 2600k, EVGA GeForce GTX580 , Corsair 8GB (2x4GB) DDR3 1600MHz CL8 Vengeance, Asus P8P67 PRO Rev. 3.0, OCZ Vertex2 E 60GB SSD, Samsung 500GB 7200rpm 16MB F3, Win 7 64b

The game stutters like in all previous machines. But here i was able to test the hard drive sugestion - it didnt helped, loading times become shorter sure [from 12-14 seconds on HDD to 8-9 on SDD], but stutterings still occur, no mater wich rendering i use or what settings or resolution i chose.


Its for sure not hardare related issue, we are too many in numbers here and we all have the same exact issue.
The one thing that helped a little thou was turning off the v-sync and tripple buffering in game setup and forcing it on in D3DOverrider. Stuttering still occurs, but its slightly smaller.
Probably people before me posted this already, but the stutters [in micro version] occurs in dialouges too, wich looks quite horrible in estetic and visual experience.

I hope dev team people acknowledge the issue already and they are working on some hot-fix/patch. Its damn good game, one of the best ever made, but this technicall issue is horrible and annoying.
I also hope we wont wait for the patch or hot-fix for this, for another year...

Great contribution!! I have the same rig: i2500K @4,5Gz 4 Gb DDR3 HD 6950 and count me in " the Stutterclub " :o

Mystery
27th Aug 2011, 08:02
Excellent post, Zekzt.

Another proof, that the reason for the stuttering isn't the OS, CPU, GPU or video settings. From WinXP 32bit to Win7 64bit, from low end rigs with old dualcore CPUs (like mine) to high end 6-core rigs with SLI/Crossfire GPUs and from 800x600 with everything off to full HD with very high detail, SSD/HDD...the stuttering is always there. Sometimes less, sometimes more, but it's there and it's annoying.

It's related to the PC code of DXHR and there's nothing we can do about it. It needs to be fixed by Eidos/Nixxes.

I assume it's got to do with the streaming of the level/texture data, which works great for consoles but was poorly ported to the PC.

david75sk
27th Aug 2011, 08:35
So I tested it again. Two hours of gameplay. Damn that game is really good. But stuttering is big issue for me. I noticed that game after two hours used only about 550-600MB of RAM and 250MB of VRAM. So they definitely need improve this. Why the hell is this game not using my 4gigs of DDR2 (even CoD4 in MP is using about 7-900MB, with small map) and 1GB of DDR5 on my GPU?

Also I have problem with exiting the game after long play. It takes too long (like 2 or 3 minutes) and HDD doesnt seem to do anything.

TROOPER181st
27th Aug 2011, 10:24
Hmmm i found something interresting what helped quite a bit :

while playing;
CTRL+ ALT + DEL, in the taskmanager you will see at the active processes dxhr.exe, press right mouse while highlighted that one, set priority at the highest possible setting... return in game voila! stuttering a whole lot less!

DesaanUK
27th Aug 2011, 10:36
Hmmm i found something interresting what helped quite a bit :

while playing;
CTRL+ ALT + DEL, in the taskmanager you will see at the active processes dxhr.exe, press right mouse while highlighted that one, set priority at the highest possible setting... return in game voila! stuttering a whole lot less!

Confirmed, for me at least. Even so, only one of my cores is being fully used the other 3 are sitting at 30%. Couple this with the terrible usage of available memory the game chooses not use and you have a pretty terrible port.

Zekzt
27th Aug 2011, 11:18
I can confirm that :

Turning off V-sync and Tripple Buffering in game setup and forcing it on instead in D3DOverride + setting high priority [but not real time on!] help a little.

It minimise the stuttering that occurs durning the camera [mouse] rotating, it reduces a bit the stuttering when we walk forward in big new area [like walking in Detroit from one part of the town to the other].

Still it only reduce the amout of stuttering, but not the whole case.

Some people reported that DEHR uses core 0 mostly, without using rest of cpu cores [depending on the core amout of course] efficiently, i can confirm this as well, it looks slightly like CPU management related issue. Maybe engine or game coding do not use the CPU properlly, its not looking like a GPU realted issue.

I have my small theory - i think the game is a little crappy written. I mean the code looks like its loading the areas all the time, in real time it loads on the run all elements in the background and it releases previously loaded content that is left behind our back [thats why camera stutter when we rotate it - terrain is loaded straight ahead of us, but when we look back or around it loads again and the FPS stutters]

The other thing - game may be cuted into areas, like old Morrowind was coded [the game itself was cuted in squares, we eneter one square, it all loaded up, but when we entered other square of terrain game loaded it in the moment we stepped in - and bah stuttering occured, DE looks slightly similiar in construction]

Another thing - it may be related to the memmory leak issue, i didnt have the time to check it, from now on it do not looks like a typical mem leak, still we cant say for sure its not somehow related.


I could test the game on some notebooks/laptops as well, but i doubt it will change anything i can bet the results will come the same.
I can add here another rigs as well, my friends confirmed that on their PC games stutters as well : E7200, GF 8800, 4GB DDR2 667/ i3, GTS450, 4GB DDR3 1333 - slightly worse rigs that the one i tested myself [including my two PCs] still capable of hadling the game without any issues in slightly lower setting.

So for all new people that come here - we can asume its for sure not hardware related. It may be driver related, but we cant do anything here until ATI and Nvidia acknowledge the specific issue and correct it via their new driver release in the future [but still i bet this is engine issue if its similiar to COD or AP stuttering issues it will not be so hard to fix by dev, we just need to sit still and wait, and we can start typical **** storm after couple of months if the wont fix it :) but i doubt such great team will abandon us, in the end i hope they want to make more cash on DE franchise, giving us some good big DLC or maybe even big expansion]




P.S.

I forget to add - some people playing the game on X360 reported micro-stutters too, as well as some micro-freezes when entering new areas.
For now the only free of technicall issues of that kind game version is PS3 oe [as far as i know none PS3 ower of DEHR eported any kind of that issues so far]


P.S.2

Sorry for my grammar, its quite some time i ahd to write something in english [its not my primary language], i can consider myself quite decent talker but im for sure not the best writer when it comes to grammar :)

ax3r0n
27th Aug 2011, 14:26
I get lag, shutter and low framerates in game, my drivers are all up to date, can someone help me

M4verick
27th Aug 2011, 14:32
This games performance is such a ******** letdown, I can play almost every game on ultra settings and yet the outdated TR engine is stuttering on my PC (gtx460, E8400, 4gb RAM)

I am highly dissapointed in this game, too bad all the ******* praising reviews on gamespot and IGN didn't mentioned this ... same **** like with "black oops".

FIX THIS ASAP!

Joey Ravn
27th Aug 2011, 15:49
By this time, my post is just anecdotal, but hey. Another one for the pile:

Windows 7 x64
Intel Core 2 Quad Q8400 OC'd @3.2Ghz
NVIDIA GeForce GTX 460 1GB
4GB RAM 800MHz
500GB Seagate Barracuda 7200.12

Tried everything people posted in this thread to no avail. I support the idea of this being an HDD problem. When the game is not stuttering, it's running at solid 60 FPS without any problem, regardless of the scene itself. I can be very crowded or inside an elevator, but when it stutters, the FPS drop to 0, the game freezes for a few seconds, then picks up at 60 again.

lolwot
27th Aug 2011, 15:51
I also get stuttering on my PC, but I'm not sure whether the software or my computer itself is at fault. I've also had terrible stuttering issues with Mirror's Edge and Bulletstorm, and I'm beginning to suspect that my hard drive might be damaged. The framerate issues seem to happen mostly when the HDD activity light is blinking and the game is streaming textures. In Human Revolution, the game becomes basically unplayable when I leave Sarif Industries and start walking around the city of Detroit. Every few seconds, the framerate drops nearly to zero FPS.

Cloakmachine
27th Aug 2011, 16:01
I think I see what the problem is now. The game seems to only pull the resources a CONSOLE would pull to run the game.

Of course it's smoother with a controller, it's smooth but it also moves slower. Gives the console the time to load everything. Except, a PC could just load the ENTIRE level and be done with it. No weird turning problems then.

XXBladeRunner
27th Aug 2011, 16:06
Another one here.

Intel Core i3 550 @4.60 GHz
GTX 560 1024MB
Kingston HyperX GG 8GB
Asus Xona DG 5.1 PCI Sound Card
Seagate Barracuda 1TB
Win7 64 Bit
Steam Digital Purchase.

Serious letdown. I've put this game aside, i can not play it like this.

Its obviously loading/coding issue and needs to be addressed now. If it isn't i'll have serious reservations about future eidos games.

INSTG8R
27th Aug 2011, 18:10
The real stuttering I get is when moving thru the city hubs. My FPS is 59-60fps at all times but its constantly stuttering despite the consistent FPS. The other thing I have had happen when playing for long periods of time is I am getting the "Windows Basic Error"when exiting the game. Which to me tells me there is something wrong with the memory allocation here.
Sys Spec:

i7 2600K 4.6 HT on
8Gig 1600 CL9
5870 Vapor-X
WD Caviar Blacks 1TBx2 in RAID 0
X-Fi Fatality Pro
Win7 Pro x64

bughole5
27th Aug 2011, 19:19
they fixed loading and crash, and since so many people are having these stuttering issues im sure theyll fix it

DeRicheau
27th Aug 2011, 19:53
I've been getting this stuttering problem too. My specs are:

i5 2500k
Ati 5870
8Gb ram
Windows 7 home premium 64bit

Running in Direct X 11 with all settings at their highest at 1920x1080. FRAPS is showing pretty good framerate (around 60-80) but I still get these little stutters when I walk.

I have found though that switching shadows to 'normal' pretty much gets rid of the problem (frame rate stays much the same, but the stutters are gone.)

The stuttering only appears in hub areas (and Adam's appartment, strangely) for me and is most prevalent when walking - looking around doesn't seem to cause the same problem.

INSTG8R
27th Aug 2011, 20:53
I've been getting this stuttering problem too. My specs are:

i5 2500k
Ati 5870
8Gb ram
Windows 7 home premium 64bit

Running in Direct X 11 with all settings at their highest at 1920x1080. FRAPS is showing pretty good framerate (around 60-80) but I still get these little stutters when I walk.

I have found though that switching shadows to 'normal' pretty much gets rid of the problem (frame rate stays much the same, but the stutters are gone.)

The stuttering only appears in hub areas (and Adam's appartment, strangely) for me and is most prevalent when walking - looking around doesn't seem to cause the same problem.

Identical systems, identical issues, identical settings. I will try turning off the Soft Shadows and see if that helps:thumb:

FrameRate
27th Aug 2011, 21:06
I have game worthy hardware and yet this game is essentially unplayable due to frame rate drops/ stuttering. I am experiencing frame rate drops on a regular basis through the first level.

Other games have bugs here or there, sometimes game breaking but this is just terrible for such a popular release. I have stopped playing this game until they fix it. It seems to be a loading type issue as the skip or frame drop is reproducable at set locations.

example : After you leave the office on the elevator and duck under the glass emergency door. At the bottom of those stairs there is a loading period.

I have closed all non essential background programs and even use game booster which closes unessential services.

Turning down graphics and removing ALL advanced graphical features does not FIX this problem :(

Win 7 - 64 bit w/ updated drivers
Core i7 920
WD Caviar Black (higher end fast HD)
GTX 460 1 GB w/ updated drivers
6gb 1600 mhz DDR3

AdamJensensAugmentedArm
27th Aug 2011, 23:33
I just tried changing the priority level in task manager and it helped out quite a bit, but it's still nowhere near smooth. As much as I wanted that to be the fix I was looking for, it was not. This might be a good idea if you started out with very slight stuttering, but if it was as bad as mine was to begin with, it's probably not going to solve your problem.

Kohokz
28th Aug 2011, 02:40
Just wanted to add my rig to the list of stuttering/lag: m17x r2-I7920xm-1333mhz 4 gigs of ram-5870sx2-256oczssd. This is mostly moving in and out of new areas, frame drops to a crawl then goes back up within a couple seconds.

cyborg34572
28th Aug 2011, 02:50
Hope we get the patch in monday, cause i really want to play this game, its great, just the stuttering puts off my mood. Im putting this game aside till this is fixed, its a great game and ill play it when its fully fixed.

FaintDeftone
28th Aug 2011, 02:51
Of course, I have the same issue. Once I start into a new area, I get a lot of studdering for several seconds before everything starts running smoothly for me. I'm running everything on high but even if I lower settings, nothing helps it. My rig is:

ATI Radeon HD 5770 1GB
4GB DDR3 Crucial RAM
7200RPM Western Digital Caviar Black HDD SATA
AMD Athlon II X3 3GHz triple core processor

The game runs perfectly fine at a good framerate, but the studdering and load times were my only issues (and load times were fixed).

libindi
28th Aug 2011, 04:08
I got stutter too

I5 2300
GTX460
6GBRAM
Windows 7 32bit

david75sk
28th Aug 2011, 06:52
tried to disable onboard audio in Bios and problem still persist... Maybe game doesnt like certain chipsets, or keyboard mouse omg so sad.

My specs:
C2D E8200 3,2GHz
2x2GB 800MHz DDR Kingston Dual Channel mode
GeForce GTS450 1GB DDR5
ASUS P5K Pro
onboard audio
Hitachi HDD 250GB
LG DVDRW

Windows XP Pro & Windows 7 Home Premium 64bit
latest drivers for everything
in Windows XP Pro I have installed only service pack 3, updates, drivers and steam with the game. Cleanest installation you can find. And still poor performance and stuttering. Game itself runs on 40-70FPS.

My problem looks like this http://www.youtube.com/watch?v=uFyW1Sa7Cuo maybe even worse.

I have played leaked beta and there was same problem. I was hoping that developers can fix it in two month... guess I was wrong. http://steamcommunity.com/id/dav1d90

Mrmonkey2
28th Aug 2011, 09:37
Same problem for as in http://www.youtube.com/watch?v=uFyW1Sa7Cuo

Spec:

Windows Vista
4gb memory
Geforce GTX 560ti

TROOPER181st
28th Aug 2011, 09:58
i5 2500k @ 4,5Ghz ( stable stockcooler )
2 x 2GB DDR 3 Corsair
MSI P67A-GD65 (B3)
Sapphire HD 6950 1GB
Samsung Spinpoint F3 HD103SJ, 1TB
onboard sound
Windows 7 64 bit
Ati. 11.8 driver

Outdoors
happens almost only when i am outdoors on the streets of detroit, especially in the alleys..turning around a corner or facing a unspecific direction on the streets, walking from different locations.

Indoors
Indoors i didnt notice it alot..only when i do a takedown from behind an enemy, and inside the Sarif building in Detroit when i am on the 2/3rd floor and looking at the hall where the receptionist is sitting.

there are 2 issues to be more specific;

Stutter
A.) the walk around / turn around / take down-stutter despite having a constant 60 + FPS with v-sync on, even happens with a 120 FPS with v-sync off, it still stutters when walking or turning around and viewing some unspecific direction. The world around me is smooth fast ( NPC's/ enemies walk around smooth etc ) but when i start to turning my view or start walking ( the world stays smooth ) stutter stutter stutter..

Frameratedrops
B.) i noticed that when i climb ladders on the streets, staring at walls ( dont ask why hahah:lol:) the framerate drops from 60+FPS to around 45+ FPS it comes back quick to 60 FPS very noticeable and thus ruining the game experience. Also happens sometimes when facing the streets of Detroit.


i'll be more specific now on the framedrop:
B1.) i start at point A ( Sarif building ) walk to B ( the LIMB clinic ) and back looking from some spot into the streets i notice a FRAMERATE DROP from 60 +FPS to 43FPS. Ok so i now loaded those area's right?
B2.) I walk the same route exactly there and back again to the same spot i was before looking into the streets NO Framerate drop Hooray!!
BUT!! ( and there is always a but..)
B3.) 3rd time i do the same procedure framerate drop comes back...


Lowering settings didnt fix anything, although i did notice a little improvement in lowering the shadows from SOFT to HIGH..But hey i have a very high-end PC i bought to play every modern game on the highest settings and not lowering the settings.
all drivers are up-to-date
CTRL + ALT+ DEL and setting affinety of DEHR the highest priority didnt helped alot..
reading and doing all the things people suggested didnt work.. iam on the end of my wits..

Its a big shame how some technical problem can have an impact on gaming experience, but what makes it worst is that i read some people are stop playing the game anymore because of this...
Please guys do something about it quick its important to us very important.


PS did you guys saw the anouncement in game at the start screen ? 29 -8 -2011 22:00GMT there will be a big announcement!

Joey Ravn
28th Aug 2011, 10:54
Can anyone link me to the post where one of the devs (or moderators, I don't really know who) claimed this was caused by an end-user problem, not because of the game is somehow faulty?

Edit: Nevermind, found it. Wow.

Spookyy
28th Aug 2011, 11:35
Yep, same as http://www.youtube.com/watch?v=uFyW1Sa7Cuo.

The devs got there proof, now we wait..

grimeleven
28th Aug 2011, 11:36
Hello, just registered to report that i have the same issue, stutter,lag when moving camera discovering new areas.
Love the game btw :D. I tried to put all settings to off/low, exit all programs, AV exception etc.

Core i7 920 @3.5Ghz
6GB RAM
eVGA E758 MB
Ati 4870X2 1GB w/Artic cooler w/Cat 11.8 CAP2
OCZ 120GB SSD
SB X-Fi Titanium
Antec 750W
Win 7 x64

As some might already know, it all seems related to the missing "variables" that the game do not allow to change for example "PoolSize". Like many other thread on the net, games like Singularity, Tom Raider, Batman AA, Alice, etc which all use the UE3 engine, have issues similar to DXHR.

http://forums.guru3d.com/showpost.php?p=4017864&postcount=118
http://forums.eidosgames.com/showthread.php?t=96494
http://ve3d.ign.com/articles/news/55774/Singularity-PC-Plagued-By-Texture-Streaming-Problems-Fix-Found
etc.. google it

I've tried to add some of these tweaks and it did improve the game performance but not eliminate all the "stutter"
Here's some you guys can try. The core parking fix did improve FPS, 4 cores were utilized before but only 1 used more than 45% now it's 1 for 90% and 30% for other logical cores.

Windows 7/Vista users, disable core parking
http://ultimatecomputers.net/forum/viewtopic.php?f=7&t=3644

Easier method for process priority, right-click shortcut and put this in the "target" box, edit drive/folder to your location

C:\Windows\System32\cmd.exe /c start dxhr.exe /high "D:\Deus EX Human Revolution Augmented Edition\dxhr.exe"

Registry Tweaks, create new dword 32bit with these values


HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR\Graphics
bUseBackgroundLevelStreaming=1
bUseTextureStreaming=1
UseTextureFileCache=1
EnableHighPolyChars=1
OneFrameThreadLag=0
PoolSize=256 (decimal)

Now those variables might be hard-coded in the .exe or have no effect so i hope devs could change the way we can tweak the game or unlock all the settings in a .ini like other unreal games.

aidor
28th Aug 2011, 12:34
There's no need to waste time testing this or that. This is a unfinished game. They have sold us an unfinished game. Let's wait and see if a patch can fix this thing called "video game". Or go to the shop and ask for my money back.

Greatings from Spain! ...and sorry for my poor english.

triggerhappy686
28th Aug 2011, 12:42
Think ive found a decent temporary fix... heres my thread:

http://forums.eidosgames.com/showthread.php?t=120565

grimeleven
28th Aug 2011, 13:09
There's no need to waste time testing this or that. This is a unfinished game. They have sold us an unfinished game. Let's wait and see if a patch can fix this thing called "video game". Or go to the shop and ask for my money back.

Greatings from Spain! ...and sorry for my poor english.

And yet you wasted your time to register just to reply about an unfinished game? LOL go back to your cave, there is no fix coming if users like you do not even try to fix their problem, you can't expect any game to work for 100% computers out there. No wonder game devs are moving to consoles..

Mrmonkey2
28th Aug 2011, 13:23
Think ive found a decent temporary fix... heres my thread:

http://forums.eidosgames.com/showthread.php?t=120565

I tried this, had no effect for me at all, stuttering problem did not disapear.

grimeleven
28th Aug 2011, 13:33
@Mrmonkey2, On topic i tried http://forums.eidosgames.com/showthread.php?t=120565 too, no effect.

atomMan
28th Aug 2011, 13:50
Just started the game.
Walking around beginners area and getting all kinds of stutter and jerky framerate.

I play all my games pretty much maxed, so what's really going on here?
Really sad to see that DXHR is by far the worst performing game in my collection.
It doesn't feel smooth even with high FPS.
And there is nothing on screen that should make this resource heavy game.
Pretty much tried all kinds of "fixes" to no avail.


--
Intel Core 2 Quad Q9500
Gigabyte EP45-UD3P
NVIDIA GTX 560 Ti / 280.26 WHQL
8GB RAM
Tagan PRII 680W
1TB WD black (AHCI mode)
ASUS Xonar DX 7.1
Win 7 x64

Levelgrinder
28th Aug 2011, 14:34
Game stutters badly here to and i have huge framedrops aswell.

I have installed the latest drivers and have tried to run the game with all possible settings and different resolutions all with the same result.

Steam version

Intel Core i7 860 2.80ghz
MSI P55-CD53
AMD Asus HD 6970 2gb/ cat. 11.8
8gb Corsair XMS 1600mhz
Silverback 650W
500GB WD
Win 7 Home Premium x64
BenQ T2200HD 60hz
Realtek High Definition Audio

TROOPER181st
28th Aug 2011, 14:50
something strange occured to my game...
I GOT RID OF THE STUTTER....(?!) or at least its almost gone

I quit the game then started it back again but i selected from the screen in Steam where you can selecte PLAY or SETUP.. the setup and selected everything to high the highest possible setting except the shadows i put those back from SOFT to NORMAL..
started the game saved right away exited the game and started the game, i noticed no stutter or at least it was reduced to 50% for me

DONT CHANGE THINGS IN THE INGAME SETTINGS!!

try it out see if it helps..

david75sk
28th Aug 2011, 14:57
Nothing helps and never will. We must wait for patch. Hope they release it in this week.

I am using clean installation of Windows XP Profesional SP3. I have installed only updates, newest drivers, msi afterburner, steam and Deus Ex and it still stutters, low CPU usage... So its game problem. There is just something on our HW combination that game doesnt like.

These fixes are only placebo... Just wait for the patch. Only developers know why the hell its not running on every computer without problem.

Its same like Black Ops.

EDIT: @TROOPER181st: just placebo.

Ibrulz
28th Aug 2011, 16:23
Hay guys. I think I've found out the problem for sync problems during cutscenes. It appears to be some sort of CPU/Motherboard communication problem. I have an ASUS motherboard and EPU-6 software used to monitor my computers energy usage and boost or decrease as applicable in order to save energy. On Turbo mode it decreased my stutter to a bearable amount. Then I tried switching off my energy saving software restoring it to High-Performance Mode and everything seems fine so far. Hopefully for others with a similar setup as mine and similar problem, this will rectify the problem. I'll also post my setup below for comparison. :D

OS: Windows 7 Ultimate 64-bit
CPU: Intel i7 x980 12x3.33GHz
RAM: GeIL Evo Two DDR3 Dual Channel 2x4Gb
GPU: Zotak GeForce GTX580 AMPi Edition
Monitor: ViewSonic VX2268wm 120Hz @ 1680x1050
Motherboard: ASUS P6X58D Premium

atomMan
28th Aug 2011, 17:13
Been there, done that....

liberte
28th Aug 2011, 17:59
For me really helped reg tweaking, I was almost unable to play before, moving in the city was like 3 sec animation then 3 sec stutter.. not even that good as the YT samples showed here earlier.. and after registry editing it was like WOW - now we are talking! I turned all the setting back to max again, and even now I have maybe 1 second of stutter on 5 minutes of play(in the city, other locations dont stutter at all).. I really recommend to check this:

HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR\Graphics
bUseBackgroundLevelStreaming=1
bUseTextureStreaming=1
UseTextureFileCache=1
EnableHighPolyChars=1
OneFrameThreadLag=0
PoolSize=256 (decimal)

and by mistake I added the same commands to HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR (not in the graphics folder)maybe that helped too, and for sure that is not a placebo- difference is so big that cannot be missed/mistaken.

my rig:
dual core pushed to 3,6GHz
GF 560Ti
4GB RAM
SSD OCZ Vertex II
and 60FPS are now almost stable - sometimes it drops to 40 no less..

Big thanks to grimeleven for help.

grimeleven
28th Aug 2011, 18:04
Hey just to let you know i made a new thread so more people searching for this issue find this solution. http://forums.eidosgames.com/showthread.php?t=120603

rename dxhr.exe to conviction_game.exe problem solved no more stuttering!!!

@liberte, glad this helped you! time to kickass!

blacklabel67k
28th Aug 2011, 18:24
Interesting how my last post got edited somehow.

Read through this thread and take a look at some of the responses received from employees at eidos interactive. I'll leave it at that since apparently I said something wrong in my previous post and it got delete. I didnt think I said anything out of line.

http://forums.eidosgames.com/showthread.php?t=120380

Levelgrinder
28th Aug 2011, 23:05
I have done some CPU stress testing with the game now and it seems that whatever setting i run the game in it uses about 90% of one thread on one of the four cores available.
This game is supposed to be optimized to run on all four cores at the same time or am i wrong?
Can anyone who have it runnig smoothly confirm that the the game puts all CPU load on one thread or if its sharing load on all eight threads/four cores?

Anti Matter
29th Aug 2011, 03:42
Meh, stuttering issues also

My rig =

Processor = i7 920 d0 @ 4.00ghz
GPUs = 2x 6970 crossfire (no overclock or voltage tweak and drivers are 11.8 and 11.8cap2)
RAM = 8gb corsair vengence 1600mhz 9-9-9-24-2T
HDD = Samsung 7200rpm 1tb (Ordering SSD for this game but it prolly won't help).
PSU = 1200w Corsair ATX PSU
Motherboard = Gigabyte EX58 UD5
Sound = onboard realtek (updated to latest realtek driver hd audio, even swapped to AC97 codec to try out).

First off I always have a solid 60fps with vsync on.

I have tried numerious fixes and I think I resolved the frame skipping when you are looking at an object and can see lag while moving around it. I did update my realtek drivers and headset drivers (Sound blaster headset) and that seemed to help for some odd reason but everytime I go into a new area it hitches (like everyone else is describing) also another issue I have which is prolly not relevant to this thread but I have sound delay with automatic weapons. Pop off a shot and half a second later I hear it.

Oh and also I did a fresh install of Windows 7 SP1 for this game (Massive fan of Deus Ex) :D but alas I cannot play this game like this.

If there is any other input I can give on my system, let me know.

jeremygrim
29th Aug 2011, 04:33
Wow seriously where's the fix? Or some word of a fix coming? It's been about a week...

Jtrizzy
29th Aug 2011, 04:42
Same...2600k/580 setup built about one week ago. Just gonna wait till they patch it at this point, the game is too good to play with such ****ty performance. Yay turn of all the DX11 effects you paid for so you can get bunch of janky gameplay.

cmdrmonkey
29th Aug 2011, 06:23
I'm also getting horrible stuttering to the point where the game is unplayable, and despite otherwise high framerates. Funny how none of the bought and paid for reviews mentioned this, and how Eidos won't even acknowledge there's a problem. I can max out most other games at my monitor's resolution (1680x1050), including Crysis and Crysis 2, and to be honest, this game doesn't look anywhere near good enough to be performing this poorly. Heck, Source engine based games look and run a lot better than this.

E6600 @ 3.0ghz
4GB Corsair XMS DDR2
1GB GTX 460 OC
Intel Bad Axe 2
Corsair TX-650V2
Windows 7 64-bit Ultimate

Eidos needs to get its ***** together. This kind of thing is totally inexcusable in a supposedly finished product.

Woopzilla
29th Aug 2011, 07:19
Yea, I've gone back to playing The Witcher 2 instead of this until a patch comes out. TW2 is one of the most polished and beautiful looking games I've seen in a long time and, despite that, runs so smoothly. I really hope to experience Deus Ex in a similar fashion sometime soon. Right now it's just a horrible stutter-fest.

Intel i5 750
Asus P7P55D-LE Mobo
4GB DDR3 1333Mhz Corsair
XFX ATi HD 5850 XXX Edition
24" WS Samsung 2433 @ 1920x1200@60Hz, Windows 7 64-bit Pro

This 'mystery announcement' in the menu had better be a patch and not a money-demanding DLC... but I highly doubt they would announce a patch in a such a fashion.

If it's not resolved/acknowledged sometime soon via a news announcement, then I'll think twice before buying an Eidos game again.

cmdrmonkey
29th Aug 2011, 07:32
I hope so too but I doubt they would release a patch that quickly. I kind of wonder if they'll release a patch at all.

I love how they made the PC out to be the lead platform in previews, and what we get instead is a sloppily done, badly optimized Xbox 360 port with some last minute DX11 stuff thrown on top.

david75sk
29th Aug 2011, 07:40
I hope so too but I doubt they would release a patch that quickly. I kind of wonder if they'll release a patch at all.

I love how they made the PC out to be the lead platform in previews, and what we get instead is a sloppily done, badly optimized Xbox 360 port with some last minute DX11 stuff thrown on top.

Well if its working on other computers, there must some small problem, some ******* small bit in operations, that makes on our computers lags and CPU&GPU usage spikes... I am hoping in patch before the weekend.

jeremygrim
29th Aug 2011, 07:50
I hope so too but I doubt they would release a patch that quickly. I kind of wonder if they'll release a patch at all.

I love how they made the PC out to be the lead platform in previews, and what we get instead is a sloppily done, badly optimized Xbox 360 port with some last minute DX11 stuff thrown on top.

I feel the same way. I'd love to think it's gonna get fixed soon but I'm just having a hard time believing it. Not even a word from the devs.

Well, I won't be buying another Eidos game. Just hope they fix the one I did buy.

Tommando
29th Aug 2011, 10:46
My optimism to pessimism ratio on this issue is 50/50 right now. If you look at the problem with excessive loading times there was very little preamble to that getting fixed. No official announcement or acknowledgement as far as I know, they just dropped a patch suddenly and there you go, much better load times.

Makes sense to me, since acknowledging a problem and then saying we can't or won't fix it(and they may not yet know if it's feasible to solve it)may look worse PR-wise than quietly ignoring it. That's not to say it won't get fixed, but if it does I'd just expect a patch dropped out of the blue one of these days. If it never gets fixed I wouldn't ever expect to hear anything concrete about it.

aidor
29th Aug 2011, 10:54
My optimism to pessimism ratio on this issue is 50/50 right now. If you look at the problem with excessive loading times there was very little preamble to that getting fixed. No official announcement or acknowledgement as far as I know, they just dropped a patch suddenly and there you go, much better load times.

Makes sense to me, since acknowledging a problem and then saying we can't or won't fix it(and they may not yet know if it's feasible to solve it)may look worse PR-wise than quietly ignoring it. That's not to say it won't get fixed, but if it does I'd just expect a patch dropped out of the blue one of these days. If it never gets fixed I wouldn't ever expect to hear anything concrete about it.

Well, change your optimism ratio: http://forums.eidosgames.com/showthread.php?t=120687 The stuttering issue has been fixed. New patch for you when you connect to Steam, :) So.. it was oooobvious, a patch is the only thing that can fix the stuttering issue. But it has been fun seeing people trying this and that to find "a fix" for an unfinished game. Now is finished.

drewho
29th Aug 2011, 11:12
Well, change your optimism ratio: http://forums.eidosgames.com/showthread.php?t=120687 The stuttering issue has been fixed. New patch for you when you connect to Steam, So.. it was oooobvious, a patch is the only thing that can fix the stuttering issue. But it has been fun seeing people trying this and that to find "a fix" for an unfinished game. Now is finished.

patch is from the 26th for long load times and does nothing for stuttering :scratch:

jaywalker2309
29th Aug 2011, 11:18
Well, change your optimism ratio: http://forums.eidosgames.com/showthread.php?t=120687 The stuttering issue has been fixed. New patch for you when you connect to Steam, :) So.. it was oooobvious, a patch is the only thing that can fix the stuttering issue. But it has been fun seeing people trying this and that to find "a fix" for an unfinished game. Now is finished.

There IS no new patch.. simple as..


patch is from the 26th for long load times and does nothing for stuttering :scratch:

Exactly not sure what aidor is doing, either has been offline since last week or is just stirring things up..

aidor
29th Aug 2011, 11:30
There IS no new patch.. simple as..



Ok... that's what happened in my case, in Spain: Connected to steam one hour ago and it downloaded 12,7 mg for deus ex. And the stuttering is gone. If you say this the 25th august patch, I don't understand, because I connected to steam several times in the last three days and no update for Deus ex has been downloaded.

I think the communication in "your" company is no good enough as it should be.

jaywalker2309
29th Aug 2011, 11:34
Ok... that's what happened in my case, in Spain: Connected to steam one hour ago and it downloaded 12,7 mg for deus ex. And the stuttering is gone. If you say this the 25th august patch, I don't understand, because I connected to steam several times in the last three days and no update for Deus ex has been downloaded.

I think the communication in "your" company is no good enough as it should be.

So fact i am here discussing things i can with everyone shows bad communication? hmm okay. :)

Its great that your game seems to be no longer stuttering, however i can assure you we're still hosting 622.0 as the current version.

Steam handles the exes and will redownload IF it thinks it needs to.. so you probably triggered a flag within steam client that said `best redownload the exe to reconfirm the game/user`

Its a bank holiday weekend here, so am actually at home, and yet am STILL online talking to people and helping people.. :)

drewho
29th Aug 2011, 11:37
Ok... that's what happened in my case, in Spain: Connected to steam one hour ago and it downloaded 12,7 mg for deus ex. And the stuttering is gone. If you say this the 25th august patch, I don't understand, because I connected to steam several times in the last three days and no update for Deus ex has been downloaded.

I think the communication in "your" company is no good enough as it should be.

If you think it fixed the stuttering just keep playing, it'll be back.
I thought i'd fixed it loads of times already with the hundreds of tweaks and adjustments people have posted, just so happens i was on a level with little to no stutter, when i went back to Detroit stutter is just as bad as ever

cyborg34572
29th Aug 2011, 11:46
Ok... that's what happened in my case, in Spain: Connected to steam one hour ago and it downloaded 12,7 mg for deus ex. And the stuttering is gone. If you say this the 25th august patch, I don't understand, because I connected to steam several times in the last three days and no update for Deus ex has been downloaded.

I think the communication in "your" company is no good enough as it should be.

Parhaps your stuttering was caused by something else my friend, because the latest path (one that came out on 25th) doesnt fix anything related to stuttering. Its great your not stuttering anymore tho, but again theres no new patch released that adresses the stuttering .

aidor
29th Aug 2011, 12:00
Parhaps your stuttering was caused by something else my friend, because the latest path (one that came out on 25th) doesnt fix anything related to stuttering. Its great your not stuttering anymore tho, but again theres no new patch released that adresses the stuttering .

maybe you are right guys... all I know is that Steam downloaded 12,7 mb, and after that stuttering is gone. All I have done is check "cache integrity" in game's properties, and t says everything is fine. After that, 30 minuts later more less, steam downloaded 12,7 mb. The game's .exe size is 13 mb more less. Maybe steam downloaded a "new" .exe, and now it works. If anybody want to check this, it may help to improve performance.

Arksun
29th Aug 2011, 13:05
maybe you are right guys... all I know is that Steam downloaded 12,7 mb, and after that stuttering is gone. All I have done is check "cache integrity" in game's properties, and t says everything is fine. After that, 30 minuts later more less, steam downloaded 12,7 mb. The game's .exe size is 13 mb more less. Maybe steam downloaded a "new" .exe, and now it works. If anybody want to check this, it may help to improve performance.

When you start the game, what does it say in bottom right corner in red text. .622? thats the version we're all on. If thats fixed all your stuttering lucky you.

We're still waiting for a new patch to fix that 500mb system memory cap limit and reduce the virtual memory usage which I'm hoping is a large part of the reason why there's soo much stuttering. Seems to make the most sense anyways.

aidor
29th Aug 2011, 13:25
When you start the game, what does it say in bottom right corner in red text. .622? thats the version we're all on. If thats fixed all your stuttering lucky you.

We're still waiting for a new patch to fix that 500mb system memory cap limit and reduce the virtual memory usage which I'm hoping is a large part of the reason why there's soo much stuttering. Seems to make the most sense anyways.

Yes, my version in the bottom right corner is 1.1.622. But I'm sure something in my Deus ex folder has been "updated" or "changed" after verify my deus ex cache integrity (12mb). And after that, the stuttering is gone. I just test it for 30 or 40 minutes, but no stuttering while this 30-40 minutes.

libindi
29th Aug 2011, 13:30
Yes, my version in the bottom right corner is 1.1.622. But I'm sure something in my Deus ex folder has been "updated" or "changed" after verify my deus ex cache integrity (12mb). And after that, the stuttering is gone. I just test it for 30 or 40 minutes, but no stuttering while this 30-40 minutes.

The question is has anyone else got this patch?

jaywalker2309
29th Aug 2011, 13:33
Yes, my version in the bottom right corner is 1.1.622. But I'm sure something in my Deus ex folder has been "updated" or "changed" after verify my deus ex cache integrity (12mb). And after that, the stuttering is gone. I just test it for 30 or 40 minutes, but no stuttering while this 30-40 minutes.


The question is has anyone else got this patch?

Everyone legitmate has this patch and has HAD this patch since Thursday. Steam will constantly update your folder to make sure it matches the base server which everyone has.. the verify resends the exe thru again, and redoes the directx installation etc..

libindi
29th Aug 2011, 13:39
Everyone legitmate has this patch and has HAD this patch since Thursday. Steam will constantly update your folder to make sure it matches the base server which everyone has.. the verify resends the exe thru again, and redoes the directx installation etc..
OK,i will check if there is a patch,i am glad it comes out so soon,just completed the game yesterday and waiting for this patch。

Belonger
29th Aug 2011, 13:48
@aidor: Or can you share the .exe file? If it's allowed, of course.

libindi
29th Aug 2011, 14:00
No,i dont get the new patch。。。

aidor
29th Aug 2011, 14:21
No,i dont get the new patch。。。

As I said, it's not a patch what I downloaded. I thought it was a patch, but is just that steam changed some files. I don't know which file/s has been changed. Jaycw2309 said that steam resends the .exe again. YOu can check if it helps you. You just need to go to game's properties and verify cache integrity. You may want to cut and paste your original dxhr.exe from your game folder to another folder (keep it save), and then you can go to game's properties and check cache integrity. It should download a "new" dxhr.exe. In my case (i5 2500k, GTX 570, 4GB Ram, SSD), it's been an amazing improvement.

cyborg34572
29th Aug 2011, 14:37
i just verified my game cache, and it did download something, ill compare my exe now to the old one and see if theres a difference, and test performance aswell

EDIT:
Nope its the same exact exe for me, same filesize and everything, it just downloaded a new one for some reason. Stuttering still exists.

david75sk
29th Aug 2011, 15:02
OMG, Eidos/Nixxes say you are working on patch, or I want my refund!

jaywalker2309
29th Aug 2011, 15:24
I would say `i told you so` but it seems i get over looked if someone new comes out with a random statement :)

libindi
29th Aug 2011, 15:29
I would say `i told you so` but it seems i get over looked if someone new comes out with a random statement :)

Wow,i just checked you imdb link,and i see you have worked on the hitman fanchise,what a surprise,im a big fan of hitman.

david75sk
29th Aug 2011, 15:44
@cmdrmonkey
I think Deus Ex HR looks great. If they fix stutter problem and few minor bugs, than we have already GoTY on our hardrives.

@jaycw2309 It looks like the game is not using multicores at all.

This was taken from Core i5 2500k 4,4GHz, 8GB RAM, HD5870 http://img840.imageshack.us/img840/6274/dxmapfooling.png but the game runs without problem on this PC.

aidor
29th Aug 2011, 15:47
I would say `i told you so` but it seems i get over looked if someone new comes out with a random statement :)

You are right. It's my fault here, I apologize. I really thought it was and update: 12mb has been downloaded and then the game runs smoother...

david75sk
29th Aug 2011, 15:49
You are right. It's my fault here, I apologize. I really thought it was and update: 12mb has been downloaded and then the game runs smoother...

Placebo.

aidor
29th Aug 2011, 15:57
Placebo.

Not placebo at all. I said smoother, and it's smoother. I played for 30 minutes and didn't see any kind of stuttering. Before the "new exe download" the game was completly unplayable. And now is completly playable. I think this is not placebo. Maybe I need to test it more and check in some other game's areas. But, even this, as there's still so many people with this stuttering problem, a patch is still needed to fix it, of course.

jaywalker2309
29th Aug 2011, 16:40
@cmdrmonkey
I think Deus Ex HR looks great. If they fix stutter problem and few minor bugs, than we have already GoTY on our hardrives.

@jaycw2309 It looks like the game is not using multicores at all.

This was taken from Core i5 2500k 4,4GHz, 8GB RAM, HD5870 http://img840.imageshack.us/img840/6274/dxmapfooling.png but the game runs without problem on this PC.

The game will use multiple cores, you can see its using multiple cores, just not maxing them all out.

david75sk
29th Aug 2011, 16:57
The game will use multiple cores, you can see its using multiple cores, just not maxing them all out.

but on dual cores is gamebreaking... Why every game is using my CPU to the max (except very old ones, hell even Half life 2 is using my dual core better than this) and run without problem and Deus Ex is not doing so and stutters on every corner like hell?

Are you (Eidos/Nixxes) working on stuttering fix?

cmdrmonkey
29th Aug 2011, 17:02
but on dual cores is gamebreaking... Why every game is using my CPU to the max (except very old ones, hell even Half life 2 is using my dual core better than this) and run without problem and Deus Ex is not doing so and stutters on every corner like hell?

Are you (Eidos/Nixxes) working on stuttering fix?

I doubt it. They got our money, so what do they care at this point?

libindi
29th Aug 2011, 17:12
jaycw2309,it would be nice if you can get some words from developers.

david75sk
29th Aug 2011, 17:14
I doubt it. They got our money, so what do they care at this point?

PR maybe? Who will buy their games in future?
(http://forums.steampowered.com/forums/showthread.php?t=2075294)


Are you (Eidos/Nixxes) working on stuttering fix?

TROOPER181st
29th Aug 2011, 17:25
jaycw2309,it would be nice if you can get some words from developers.


Wel they already know.. a couple of days ago there was an thread also about the stuttering problem and if Eidos would comment on that.. the tread is closed by an admin because people got a little bit "angry" on them.
But i can recall that JAYCW2309 or that other admin told us that they ( and i presume with "they" are the developers of DXHR) were being informed by the admins..
AND that the developers are reading our forum..
So i give them now the time and patience for fixing this with a patch.

paulberndson
29th Aug 2011, 17:39
Just wanted to tell that i got the same framedrops (when going around corners loading new stuff etc) on my 560 TI.
On my old 8800 gts it runs perfectly....

david75sk
29th Aug 2011, 17:45
Just wanted to tell that i got the same framedrops (when going around corners loading new stuff etc) on my 560 TI.
On my old 8800 gts it runs perfectly....

You just swapped your GPU or is different rig.
I played preview version with 9600GT on same PC an I had same lags...

madi0000
29th Aug 2011, 17:54
yes, of course this works best on old hardware...it works best on my old computer: 512 mb RAM; 6800 geforce, 60 gb hdd, 8 (???) core cpu and blueray drive....in other words: on my ps3!

Ashkandi
29th Aug 2011, 17:57
I'm very impressed. Other companies never post anything on forums or they just simply lock the threads what is about something buggy. Good to see a real community manager on an offline game forum who help and answer. The guys from those companies should learn from you.

TROOPER181st
29th Aug 2011, 18:05
Well it was Te5uo who wrote that this stutter problem was the same as in the beginning days of Call of Duty : Black Ops.. people got a patch fix which involving the sacrificing of these two :

http://3.bp.blogspot.com/-ZiOcWjOrEPA/TjjEIQH6eWI/AAAAAAAABaE/fCyhFzg-DkI/s1600/goat113.jpg


so lets do it!! we want the-stutter fix!!! sacrifice themmmmm!!

jaywalker2309
29th Aug 2011, 18:05
Wel they already know.. a couple of days ago there was an thread also about the stuttering problem and if Eidos would comment on that.. the tread is closed by an admin because people got a little bit "angry" on them.
But i can recall that JAYCW2309 or that other admin told us that they ( and i presume with "they" are the developers of DXHR) were being informed by the admins..
AND that the developers are reading our forum..
So i give them now the time and patience for fixing this with a patch.

Ooh never seen my named `capped` before :) the dev guys have posted on here, and i'v posted a lot, and i talk to the dev guys a lot.. i forward links to them of things if i think something could be of relevance or use. Its a fine art to read a forum :)


I'm very impressed. Other companies never post anything on forums or they just simply lock the threads what is about something buggy. Good to see a real community manager on an offline game forum who help and answer. The guys from those companies should learn from you.

Am not a community manager, as i've said before i am just a guy whos been around for so long at Eidos/Square, i've worked on every title we've produced since 1998. :)

paulberndson
29th Aug 2011, 18:12
You just swapped your GPU or is different rig.
I played preview version with 9600GT on same PC an I had same lags...

Just the GPU, same computer...

cmdrmonkey
29th Aug 2011, 18:26
I guess I should have known after Invisible War not to expect too much from a Deus Ex sequel, like for the game to actually work and be playable.

timothydog76
29th Aug 2011, 19:14
The stuttering is an issue (maybe worse for others) but cut them some slack. The game hasn't been out a week yet and they have already made one patch. I suspect they will get to it soon. Unfortunately I'm about 22 hours into the game and the stuttering did affect my enjoyment a little. I probably won't go back and play it over again when I'm done.

Arthur Hucksake
29th Aug 2011, 20:58
The stuttering is an issue (maybe worse for others) but cut them some slack. The game hasn't been out a week yet and they have already made one patch. I suspect they will get to it soon. Unfortunately I'm about 22 hours into the game and the stuttering did affect my enjoyment a little. I probably won't go back and play it over again when I'm done.

The issue is far too much of a problem to even allow the game to be released, there isn't an excuse for it. Just publisher greed really.

Just better to buy their future games from the bargain bin or wait to see what other poor paid beta testers are suffering before shelling out coin.

Ram and Vram usage is stupidly low, they perhaps should look there. I wasn't aware the minimum system requirements were for pocket calculators too.

Gaming aint what it use to be.

What makes it worse is that the game is actually awesome.

kall
29th Aug 2011, 21:01
I disagree with cutting them slack. How long has this game been in development? And what about this quote” The game has been brought to consoles by Eidos-Montreal, but the developer enlisted the help of PC veterans, Nixxes Software, to optimize Deus Ex: Human Revolution for the powerful platform. “First off, Nixxes developed a DX11 renderer that is used on the PC, when available,” said Jurjen Katsman, founder and president of Nixxes. “We did leverage this by adding several features you will see when you have DX11 hardware on your PC: real-time tessellation, improved Screen Space Ambient Occlusion, improved blurs and depth of field”. Come on. Optimized? Where?

libindi
29th Aug 2011, 21:10
What?Nixxes Software is PC veteran?i thought they dont have any experience on making pc game.

Mrmonkey2
29th Aug 2011, 21:21
I must say I think it is shocking that I buy a game to find it virtually unplayable because of an issue like this. I cannot understand or grasp the fact that a game is released in this state, nor do I understand Eidos attitude towards ppl who vent their discontent about the issue.

When I buy games I never rly looked at the developer of the game as a deciding factor in a negative way, but this has surely changed that for me.

Eidos for me is a big no go from now on.