PDA

View Full Version : Tessellation Causes Artifacting



apocalypsebrad
23rd Aug 2011, 10:31
I'm using a gtx560 and I've tried a dx11 benchmark with tessellation and had no problems, but for some reason when I turn tessellation on in DE:HR it causes artifacting on npc skin textures- they get small black dots all over their faces. Is this an issue with the game or is my card to blame for this?

jaywalker2309
23rd Aug 2011, 10:40
I'm using a gtx560 and I've tried a dx11 benchmark with tessellation and had no problems, but for some reason when I turn tessellation on in DE:HR it causes artifacting on npc skin textures- they get small black dots all over their faces. Is this an issue with the game or is my card to blame for this?

This could be an issue in the new drivers from nVidia, it was not an issue in the previous drivers.. We're looking into it..

Darktronik
23rd Aug 2011, 11:36
Same here and here:
http://forums.steampowered.com/forums/showthread.php?t=2074888&page=2

Turning off Tess solves the problem.

Should a patch solve this or is it driver related?

GTX560Ti + 180.26 WHQL

Merc1138
23rd Aug 2011, 11:44
Turning off tesselation with 270.51 drivers from nvidia for my GTX570 stops the artifacting.

Unfortunately now transparent textures all flicker at once. For example in the hallways to go visit the guy who gives you your first quest, the windows all flicker, the power cords all flicker, and the blue circle lights around the security cameras flicker constantly. This only happens with tessellation turned off.

edit: exited and reloaded the game, now only some objects flicker like the mounting brackets for the security cameras, and things like the pizza boxes and coffee mugs on the table. They're gray and then the texture randomly flickers to be visible...

I guess that's somewhat playable but come on...

It would also be nice if windows didn't pop up a dialog claiming the application crashed every time I exit to desktop. Yeah, I've been hyped up about this game for months, but I don't like buying it and finding out I'm a beta tester on launch day.

ShaunOfTheFuzz
23rd Aug 2011, 11:45
Hi there,

First off, I love the game so far, excellent job.

I'm having the same issue with the white/black dots, I can confirm turning off tessellation fixes the problem, but obviously keeping tess. on would be nice.

I noticed the problem on the Nvidia 275.33 WHQL drivers so it may not be an issue exclusive to new drivers.

My rig is:
i7 920
Nvidia GTX 570
6gb 1600mhz Corsair Dominator RAM

Foxpass
23rd Aug 2011, 14:31
This could be an issue in the new drivers from nVidia, it was not an issue in the previous drivers.. We're looking into it..

I just updated to the latest drivers attempting to troubleshoot this problem. It existed with the 275.33 (previous WHQL release) as well. With what driver version did you not have this issue? (Actually I am not sure if it was 275.33 or 275.50, but it was definitely 275.xx and post 275.27)

WhiteZero
23rd Aug 2011, 14:41
Hi there,

First off, I love the game so far, excellent job.

I'm having the same issue with the white/black dots, I can confirm turning off tessellation fixes the problem, but obviously keeping tess. on would be nice.

I noticed the problem on the Nvidia 275.33 WHQL drivers so it may not be an issue exclusive to new drivers.

My rig is:
i7 920
Nvidia GTX 570
6gb 1600mhz Corsair Dominator RAM

I have not noticed this on my GTX 570 with 275.33 and Tess enabled.

SyphonX
23rd Aug 2011, 17:21
I have this problem also. It's general artifacting with geometry, various textures, not just character models. Can't tell if it's shadow related or not. Definitely goes away if I turn Tess off, which is unfortunate, as I'd like to have it.

I'm running the latest 280.26 WHQL set (nVidia obviously), and I'm about to try reverting to an older set. Shoulda just kept my older set installed anyway, there are no major improvements for the 280.xx series from what I can tell, other than causing problems with new releases...

Fielding two 480's in SLi.

SyphonX
23rd Aug 2011, 18:32
Reverted to 275.33, and still have artifacting with Tess enabled.

No clue. I'll try without SLi.

MrDionne
23rd Aug 2011, 18:40
I confirm, I have this problem too! I must disable tesselation to turn off artifacting!

My config:

GTX 580 (280.26WHQL drivers)
i7 2600K @ 4.2GHz
8 Gb of RAM
Windows 7 pro 64bits

Jontron
23rd Aug 2011, 20:35
just confirmed with my GTX 480 works fine with tessellation off. artifacting with it on. WHQL ver: 275.33.

Shaderhacker
23rd Aug 2011, 20:44
Arrghhh! I don't like this!

apocalypsebrad
23rd Aug 2011, 21:41
Arrghhh! I don't like this!

hahaha, you and me both! I was up way later than I wanted to be last night ocd'ing over trying to find a solution. The good thing is that other people are experiencing this problem as well, so hopefully Eidos can find a solution soon. In the meantime, anyone that is having these issues should download a benchmark with tessellation in it to make sure that it runs properly. I already have and didn't experience any issues on it whatsoever, so I'm blaming the software.

ericvstiffany
23rd Aug 2011, 21:45
hahaha, you and me both! I was up way later than I wanted to be last night ocd'ing over trying to find a solution. The good thing is that other people are experiencing this problem as well, so hopefully Eidos can find a solution soon. In the meantime, anyone that is having these issues should download a benchmark with tessellation in it to make sure that it runs properly. I already have and didn't experience any issues on it whatsoever, so I'm blaming the software.

same here

Parsalyn
23rd Aug 2011, 22:42
Nvidia 470
Win 7 64-bit
280.26 Drivers

I was having the same issues, until I found this thread here http://forums.eidosgames.com/showthread.php?t=119697

Basically change FXAA to High instead of using MLAA. I turned tesellation on and restarted the game and now it is pretty well fixed. There are a few dots here and there, but mainly when an NPC is in front of a orange highlighted door. With both settings, NPC's in front of orange highlighted doors have a lot of fiery pixels all over them.

Abram730
23rd Aug 2011, 22:52
Change the AA mode. I think it's FXAA.
Worked for me.. It's a game-Nvidia driver thing and I've had it in a few games(fallout NV, Witcher..ext)

There is a way to force compatibility mode with nhancer, but I don't have the info.

oldmen
23rd Aug 2011, 23:24
i'm experiencing this too. can we please get some kind of fix so that we don't have to turn off certain options? if you guys are positive this is a driver thing, please say so

StingingVelvet
24th Aug 2011, 04:30
Changing from FXAA to MLAA fixed this for me.

ShaunOfTheFuzz
24th Aug 2011, 13:38
I can confirm that switching to FXAA allowed me to turn tessellation back on with no issues, hurray!

It makes sense to, I just found out that MLAA is ATI tech and FXAA is Nvidia tech. If everyone tries switching to the right AA for their card it might fix it for everyone.

Saltank
24th Aug 2011, 14:36
Same issue here.

I have to point out that I recently experiences extreme artefacting in pretty much all newer games (DX10 onwards) with the latest drivers.
Intel i920 2.6Ghz @ 3.4 overclock
ASUS Direct CU II GTX570

I put the CPU to Auto *Stock* speeds and the artefacting vanished. However in DE:HR I get the same issue as poster with older drivers *275.33

KrubixCube
24th Aug 2011, 17:38
Just to add to Eidos' knowledge base, I updated my graphics drivers and this did not fix the issue, so it doesn't seem like a driver issue (at least with a specific version).

Turning off tessellation does fix the issue.

Now if only the crashes were fixed...

SyphonX
24th Aug 2011, 19:20
Likewise, drivers change didn't yield any difference.

It is.. possible.. it could be related to my overclocked CPU/RAM.. but I don't have any anomalies in other games, and I play a lot of games.. so..

Thing is, I haven't had a -single- crash with DX:HR yet. Not a one. I've even had the client open all day today, active or minimized when I'm not playing it. So stability isn't an issue apparently.

So..

Neither 275.33 or 280.26 sets are different with the artifacting, and I think it's safe to assume it's not an overclock issue on my end (which would be a logical assumption with the artifacting) because I'm stable... so, I have no idea what would be causing it at this time. I've even made sure every possible graphics setting is defaulted via nVidia Inspector, so I don't have a rogue setting causing issues either.

Beats me. I'll be following this thread and others.

(Game looks pretty great anyway tho, so not a total loss really.)