PDA

View Full Version : Drops to 1 FPS goes Back to Normal, Unplayable, I’ve Tried Everything Need Help.



smooch
20th Jul 2011, 23:29
SOLUTION:
Run a spyware check.

I recently picked up BAA GOTY off steam. It’s running v1.0 (however I don’t think there are any patches for the GOTY version).

At first everything was fine. Actually for the first six hours everything was fine. I had the game running on max settings at ~30 FPS easy. Great no problems.

I go to play one day and the game freezes for about 5 seconds. Here’s what happens. Game freezes, if someone is talking the sound continues normally, about 5-7 later the game is back at 30 FPS running perfectly. I walk around a little bit? Freeze, unfreeze. Select a gadget. Freeze unfreeze.

Basically the game is unplayable.

Here are my specs


CPU: I5-2500k
GPU: GeForce GTX 560 Ti
Ram: 4 gigs
OS: Windows 7


Here’s what might have happened. I *think* when I booted up my PC that day it said something like “Service pack 1 successfully installed.”

Here’s what I’ve done:


Turned down settings a little bit. No change.
Turned down all settings, lowered resolution, disabled Nvidia Physx. Same freeze, same duration.
Verified game integrity via Steam utility. No change.
Checked for updates on driver. None. Reinstalled for good measure.
Tried editing some .ini settings (specifically ones related to sound). No change.
Uninstalled all recent updates and those related to service pack 1. No change.
Uninstalled game. Deleted Eidos folder in Documents. Reinstalled. Started fresh game. No change. Used old save file. No change.


Here’s what I think it might be related to

The freezing usually happens when an animation goes off. So if I select a gadget it won’t always freeze, but then when I wield it, the game will freeze. If I try again right away it doesn’t freeze. This happens fairly consistently. If I crouch sometimes it will freeze. Those doors that take their time opening (the ones that scan you) pretty much guarantee a freeze. In combat, almost every connecting hit will result in a freeze. This isn’t a 100% but it feels like once an animation has gone off once it won’t cause a freeze.

This leads me to believe that it has something to do with animation but I don’t know enough to actually do anything with this knowledge.

Other symptoms


Noticeable lag on startup.
Windows mouse and in-game mouse are both visible.


Video Drivers

My 3D vision drivers are uninstalled. This is due to the Witcher 2 having some issues with this. But they were uninstalled during the first six hours when the game was running perfectly.

Nvidia Graphics Driver: 275.33
Nvidia Update 1.3.5
Nvidia HD Audio Driver 1.2.23.3
Nvidia PhysX System Software 9.10.0514


I’d appreciate any help, I feel like I’ve tried everything and I’m running out of ideas. The one thing I can think of trying now is to uninstall some components of my drivers (like PhysX or the Update).

I've also posted this on the Steam forums.

sir biscuit
21st Jul 2011, 05:04
Steam "should" automatically install the patch.. Now I have to check on my sister's pc to see if they are having any problems w/their GOTY from Steam. Wait a minute,are you using the nvidia audio driver? If so,uninstall it & use motherboard sound drivers if onboard is being used. Their (nvidia) sound driver causes lots of problems ! Your system should be able to run it w/physics on normal setting. How does it run the benchmark program ?

smooch
22nd Jul 2011, 00:16
Thanks for the reply! I'm currently doing a "proper" uninstallation and clean of my video drivers. I'm following the advice given to me at the the Steam forums, and it seems that both of you suggest to uninstall the Nvidia audio drivers.

I'm about to reinstall my drivers right now, and I'll definitely avoid the audio ones.

smooch
22nd Jul 2011, 00:41
1. Install Phyxion's Driver Sweeper 3.1.0 (latest).
2. Uninstall your video drivers through Device Manager (clean out the driver software while you're at it).
3. Uninstall the 3D Vision Driver, Nvidia HD Audio Driver, and PhysX through Programs and Features.
4. Delete the driver files in the Nvidia folder (where they're usually kept if you install drivers from Nvidia's website).
5. Boot to Safe Mode and run Driver Sweeper. Clean out Nvidia Display and PhysX files.
6. Restart
7. Install Nvidia Drivers and PhysX. DO NOT INSTALL THE HD AUDIO DRIVERS (if you really need some beyond what MS installs, use Realtek's since you're probably using their integrated chip).

I followed all of these steps to the tee. Sad to say that there's no change. Still freezing at the same spots.

I ran the benchmark which also froze at certain spots. My results were:

Min FPS: 0
Max FPS: 61
Average FPS: 58


Any other suggestions?

sir biscuit
22nd Jul 2011, 04:41
AA & ambient occulision turned off also ?

smooch
23rd Jul 2011, 17:02
AA & ambient occulision turned off also ?

Yes I've turned everything off, still had no effect.

I'm starting to think that this has something to do with an update to the .NET framework. Even if I've uninstalled all recent updates (the ones after Batman), I think there could be some legacy code somewhere that's interfering with the game.

It's starting to look like reformatting my PC would be a viable option -- except I probably wouldn't go that far.

smooch
23rd Jul 2011, 17:57
I have fixed the problem. I have it running on max settings at 60 FPS and no drops to zero.

For years I've been using a great program called Spybot Search and Destroy, so every time I hear "spyware" I chuckle to myself and think how smart I am.

Turns out I forgot to actually use the immunize option in SBSD and I had some pretty bad spyware. I ran the cleaner, removed everything and the game works perfectly.

Specifically I think it had something to do with a "bit coin miner" if anyone is interested.

sir biscuit
24th Jul 2011, 08:50
Glad to hear you got it going !