PDA

View Full Version : Failed to initialise PhysX



Snipe*Star
11th Aug 2010, 19:25
for a while now i have been unable to play this game- i get the same error message box that pops up saying "Failed to initialise NVIDIA PhysX. Please install the latest NVIDIA physX system software.

ive tried verifying the integrity of the game cache, deleting and redownloading, and uninstalling the nvidia drivers with driversweeper and then reinstalling drivers-- it has never gotten the message to stop.

it doesnt matter if i have PhysX set to Off or not, it still wont play.

using Win7x64, 2 GTX285s in SLI and latest drivers 258.96, although it hasnt worked for a while with any of the previous drivers. i dont know what changed, i hadnt played it in a long time, my friend wanted to see it, and the error message came up (this was a couple months ago now) and ive never been able to get it to work.

Snipe*Star
12th Aug 2010, 19:23
wanted to add that i had gone to nvidias site and downloaded just the physx installer file and that never fixed it either..

i run several different spy/malware programs, i am thinking that one of them is interfering with physx while it installs or tries to run... i have no idea really what else could be causing this..

edit edit edit::

i browsed to nvidia's site and re-downloaded the latest physx software and installing it again anyway to see what happens. it started uninstalling the older physx then a box came up saying i needed an Nvidia PhysX software disc (the same kind of box that pops up, prompting for a Windows disc if you try adding/removing windows components)

that hadnt even happened before, when i had tried running just the physx installer by itself in the past.

juliancallan
14th Aug 2010, 11:04
I am having this exact same problem, just downloaded the latest PhysX drivers and having this problem.

I'm on an Acer Aspire 6935 with a GeForce 9600m GS and 3GB of Ram.

Now that I think about it, I had this exact problem with the Mass Effect 2 demo as well.

Snipe*Star
15th Aug 2010, 22:28
glad to see i not the only person having the one problem that absolutely nobody has an answer for.. :mad2:

Beastie
15th Aug 2010, 23:53
i do not know if thiw will help or not

go to add remove programs and try to repair physx

Snipe*Star
16th Aug 2010, 15:41
i do not know if thiw will help or not

go to add remove programs and try to repair physx

no, that was tried a long time ago, that did not help at all.

the problem is that some time ago, during one of the many driver updates i performed, physx installed incorrectly-- that file can't be removed. Driver sweeper, CCleaner-- nothing is able to repair or uninstall the damaged physx file-- when i try it asks me to provide a source disc, which i can not, then the uninstall aborts.

i have the feeling only a reformat is going to work..:mad2::mad2::mad2: