PDA

View Full Version : DX Error 3 on game start



roboticowl
9th Aug 2010, 04:36
I haven't been able to launch Just Cause 2 on my computer at all yet. Every time I try to start it (either through steam or directly from the shortcut) I get a Direct X error, Code 3. I have updated my drivers and Direct X and tried reinstalling the game by deleting and re-downloading through steam. The latest video driver available was released by Dell on 7/19/10 (the drivers directly from nvidia don't seem to recognize the card -- probably because it auto-switches with integrated graphics with optimus).

I also tried using an older driver for the video card as someone on the forum had suggested. This seemed to help a bit. I no longer got the DX code 3 error but the game would just show a blank black screen and crash right away (program stopped working pop-up from Windows).

I'm playing on a Alienware m11x r2 with an i7 processor, 4gb ram, windows 7 (64 bit) and a geforce gt 335m graphics card with optimus (I double checked and it supports DX 10.1).

Thanks for any help or advice you have.

FatalError
17th Aug 2010, 01:25
*sigh*
Another one i guess. Just like you i have the same exact specs same exact model. And yes i have also heard to download the stock driver but i dont want to sacrifice performance on other games just to make this game work and according to you this game still doesnt even work. Let me put this simply for you to save you the trouible i went through.
This.
Game.
Will.
Not.
Work.
For.
You.
No exception, no way to fix it. Thats just how it is i have emailed steam forums, the alienware forums i have tried contacting an alienware agent i have emailed squareenix for help and nothing helps. But if yo would like i can show you why this will not work. Please go into ur search and search up dxdiag. Run program and copy ur specs onto here and i will see what i can do.

Ecophyber
20th Aug 2010, 19:26
Machine name: ALEX
Operating System: Windows Vista™ Home Basic (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.100608-0458)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Inspiron 531s
BIOS: oC)Phoenix - AwardBIOSTeDell System v6.00PG
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ (2 CPUs), ~2.3GHz
Memory: 1982MB RAM
Page File: 1613MB used, 2594MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
DxDiag Version: 7.00.6002.18107 32bit Unicode