PDA

View Full Version : Demo crashing on 64bit system at multiple points (not MP)



Skribble
30th Jul 2010, 14:31
Hey everyone, I see the forums are filled with complaints about the demo crashing at numerous points. You'd have thought since the first game was an absolute bomb on the PC, Eidos might have tried a little harder with their port, but hey...

First off the demo wouldn't even let me load the game. Showed Square Enix's logo and then gave me one of those completely useless 'Unknown Errors'. So I had a look around for a fix and someone mentioned that you can copy some files from your System 32 folder - OpenAL.dll and wrap_oal.dll - and chuck them in to the root of your K&L demo folder, so I tried that. Still not working.

(Note: Apparently the issue with these files is a carried over issue with many UE3 games)

I noticed that OpenAL.dll was actually called OpenAL32.dll - I assume this is because I'm running 64bit Windows 7 - so I thought, "what the hell" and removed the '32' from the filename. Oh look at that, the game starts now!

I thought I was golden: checked the settings, changed controls and started a new game. BAM! The game freezes on the circlular loading icon, but I can still hear Lynch calling his wife. The call ends and then the game hangs until I end the process. Left it on this screen for about 10 minutes and nothing happened.

I've tried a number of graphics options including the lowest and highest settings, with and without vsync. I've tried reinstalling and not touching any of the settings. I've even tried downloading the .dll files from another location and using those. I've tried rolling back my graphics card drivers to versions up to 3 times older than the newest Nvidia drivers available. Tried running in compatibility mode from XP to Vista, all service packs. I've downloaded and installed all of Windows latest updates. Nothing works.

I don't want to rip on this game, it was honestly going to be a day one buy for me; I love the look and feel of the game, and the characters are among the most original and interesting I've ever seen in a game. Despite the constant crashes and issues of the first game, I still enjoyed it and I was really looking forward to a more refined sequel. But I don't have the money to waste on games that don't work. Especially if this game is supported as much as the first game. Read: No support at all.

So, sorry Eidos, unless you officially come out and fix these issues and assure us that the full game is not as buggy as your demo, you've lost my sale, and I'll be telling my friends not to trust the game until official word details these issues are solved.

Good luck with the games release.


Brendan


My setup:

Windows 7 64bit Ultimate
Core2Duo E6750 2.66ghz
500+250GB Sata drives
6GB of DDR2 800mhz RAM
Geforce 8800GT 512mb
Asus P5k Motherboard
X-Fi Xtreme Gamer 5.1 sound card
500watt PSU
Direct X 11
No antivirus or firewalls - Windows Firewall is disabled - as I did a fresh install less than 3 days ago

TheMoD
30th Jul 2010, 23:37
Well I can at least get into the game but it's already "stopped working" on me a couple of times. Here's when it happens to me:
Sometimes it happens when I push something just after I start the game, you know when the eidos and Io logos show up. so I just wait them out now.. It happens pretty frequently on mp, usually after playing 3 rounds, which is a real pain in the ass, considering I'd wanna rank up. It's also happened to me in singleplayer once.
I too have windows 7 64bit.
(Intel core i7 2.67ghz, 4gb ddr3, radeon hd 4890)

joe the janitor
30th Jul 2010, 23:44
This might help? http://forums.steampowered.com/forums/showthread.php?t=1384695

Kamiz
31st Jul 2010, 11:14
Thanks joe the janitor :thumb:

But someone can help me, because I did not all understand (I'm French) ^^

I must put the 2 files (openAL.dll, wrap_oal.dll) in the game directory :
C:\Program Files/STEAM/Username/steamapps/common/kane & lynch 2/

.... And i don't know too if i must place these 2 files in :
C:\windows/system32

Thanks :D