View Full Version : Just Cause 2 PS3 Fatal Error

28th Jul 2010, 01:53
Whenever I try to load my Just Cause 2 disk for the PS3 it just says "Fatal Error while loading disk, please restart". This happened after I let my friend borrow it for a few weeks and he said he didn't do anything to it. He said he started using it on his PS3 slim and it had loading problems then this happened. I've tried cleaning the disk and restarting and nothing works. The disk is pre-owned but it worked perfectly when I first got it. It's 99% clean.

Is anyone else having these problems? :(

Rocket Propelled Rocket
28th Jul 2010, 03:32
That's strange, I would call Sony for some support, or you could call Eidos customer support. Other than that I can't help ya. :(

28th Jul 2010, 20:00
Aww man, this sucks cause my warranty on the game is up. :(

I was only 40% done with the game too.

Well, I've heard of others having this problem with a clean disk, strange.

Crimson Rambler
16th Sep 2010, 08:45
Post written over several days while I tried to fix the problem:
PS3 all updates done
at about 40% I would occasionally get glitches where buildings, people would not show up. A restart would fix it for a while. Once it restarted the game and reinstalled it on it's own. One other time I erased the game data and it reinstalled and worked okay. Now at 64 % I get a disk error on the start of some missions, including the next agency mission, where you have to choose 1 faction to side with. I've re-installed with and without the patch. The game still will freeze or get glitchy if I'm moving very fast for a long time with fast graphics changes, (fastest boat or car, not plane). I've double checked the disk and washed it with eye glasses cleaner and cloth. It was used and the disk seems thinner than most games but there is no visual damage. Other games work well with no pauses.

I have a second PS3 and can check it later but hate to start a new game to get busted at 60% again. Hopefully I can transfer the saved game.

Bad news, game works 100% in the second PS3, without problem. So, possibly a problem in the first PS3. So I backed up what games that would and did a data rebuild and it found errors but that didn't fix it so I followed it with a full factory reformat. No go, and the disk read errors have progressively worsened. But, they still only occur in Just Cause 2 and on one system.

I must have the Blu-Ray Laser going bad :(


Tried it , still same error. Did a factory reset, same error, tried a different disk (used from gamestop, returning it tomorrow), same error. The errors are on both PS3 systems and one of them is new. All other games, no matter how long played (hosted all night lan party recently) work well. I even erased game data, saved games, and used the new disk to start the game and still had graphic faults, important things like bridges not showing up, and disk read errors.
I've had it with 2 disks and 2 systems, we can't be the only ones with this problem.