View Full Version : USER INTERFACE Keybindings reset

15th Oct 2013, 19:27
For some reason my custom bindings don't seem to completely apply when I play as a vampire.

As humans the buttons are as they should be, as in exactly as I put them in the options menu.
But as vampires, the action buttons seem to be mixed up.

For example, as a tyrant the charges melee attack is displayed as being activated by pressing RMB, even though according to the options menu I have that button unbound.
The first ability is Q, as it should be (it was default if I recall correctly), but the second ability is activated by pressing F, even though my second ability has been bound to E and F is my interact button.

2nd Mar 2014, 15:12
hi guys, I'm currently having a few issues with my key bindings as they seem to randomly re-assign themselves every so often and it doesn't always show up as any different on the in game menu.

The first (and probably the most common of these) involves one of the control schemes blanking every key binding to "None", so nothing works - this shows up as such under the bindings menu, but takes ages to fix in the middle of a match.
Next, one I got yesterday was not on the menus and is perhaps the most confusing - every button press switched out of the game and opened a shortcut to my computer. This eventually sorted after a reset, during which time I'd got frustrated enough to try and sort out a gamepad solution.
After getting the gamepad up and running with a little help from xpadder for the sticks, I got another unshown one with all my traverse/sprint buttons switching to 'show scores' instead of allowing me to climb walls. Again a reset sorted it out, but I soon got another bug where the entire control scheme blanked to "None" again.

I've had all of these in the last couple of days and it's beginning to become a bit irritating, hope this helps resolve :)

9th Mar 2014, 23:36
I've got just a small bug to report. The game seems to randomly change my custom key bindings back to default. It seems to happen randomly; sometimes they change between matches and sometimes it won't change for about a day of playing. Like I said, nothing huge but if I forget to check them before a match starts it usually costs me a death.

14th Mar 2014, 15:44
Would be nice if this didn't happen. I use Dvorak, and since the game doesn't auto detect this, I can get into a game and have to hope I don't get killed while I rebind each key in the menu.

14th Mar 2014, 15:50
That's probably because of the patch released yesterday. Does it happen randomly, every time you launch the game or only after downloading a patch?

14th Mar 2014, 15:56
I think each big patch resets your keybindings unfortunately. I wish this wasn´t the case :/ nothing worse when you are trying to play a match and realize they´ve been reset.

14th Mar 2014, 15:58
Not all of them do. That being said, when I fixed my first one this time it actually deleted ALL of my movement bindings, which I found odd.

14th Mar 2014, 18:08
Its more than just the keybindings. Resets a bunch of settings. I have had keybindings, audio, and video settings reset. For audio, i like to turn off game music and for video I change texture quality from Higher to High. These get reset back to game music on and texture quality Higher.

21st Mar 2014, 17:04
Hi guys!

I'm fairly new to this game so forgive me if this is a reported issue already but still wanted to let you know that the keybindings don't save at all in the current beta build.
I sadly live in a country where for some reason we don't use QWERTY keyboards so WASD for you guys is ZQSD for us.
So obviously I changed the keybinds but they would reset even during mid-match pause when the teams swap.

Also I'm not sure what's going on with the mouse sensitivity slider but that doesn't seem to do anything at all for the most part.
As a semi-pro competitive gamer I taught myself to play with a very very low mouse sense and in this game the sensitivity is just nuts :D
There are ofc ways around it by manually setting DPI but hey.

Anyway I'm looking forward to playing some more Nosgoth as it looks like a very fun game :)

Thanks for the time!

27th Mar 2014, 02:23
Hi...I know this may not be the right area to post this, but I cannot make a new thread in the technical area...now I play with the Home, Delete End, and Page Dn keys. However, when I go to bind my keys, I cannot select my delete button and I find it difficult to play since I've used the same key bindings for years...it's just easier for me, I don't know if the creators of the game would be able to do something about this or not, but I was looking forward to playing the game. And after playing a little bit (And failing miserably) I want more. But I want my own key bindings :\ so if anybody would be able to provide an answer or something, that'd be awesome

27th Mar 2014, 09:33
I'm not sure why you can't select these keys as it's not like they are being used for anything - technically you should be able select any key on the keyboard...

27th Mar 2014, 15:48
I have been trying constantly to bind this key...unfortunately, it's not working and it's frustrating me now. I've never come across a game that won't let you select these keys...

27th Mar 2014, 17:14
Hi Shadow,

I just did a quick test with my own keyboard. For me, I was able to assign all the keys you mentioned except for "Delete". If you have a number pad, I would recommend trying turning NumLock off, and then trying to set Home, PgUp, PgDown, and End from there, saving the bindings, and then turning NumLock back on. This should then result in the usual keys working.

I will make the team aware that binding Delete does not appear to work. Other keys that purposely can't be bound are Escape, Windows Key, Menu Key, and Print Screen.

27th Mar 2014, 17:46
I did attempt what you had said to do, but to no avail. I still cannot bind my Delete key. I hope this is fixed soon as I am looking forward to playing the game

5th Apr 2014, 22:22

6th Apr 2014, 06:11
Here, my keybindings are always reset to default after a update of nosgoth.

6th Apr 2014, 09:55
Baz, your issue about launching shortcuts is probably not the game. Sometimes Windows will get in a state where it thinks one of the modifier keys (shift, control, and alt) is pressed down, even though it's not. Sometimes you can jog it out of that state by pressing the left and right modifier keys several times, but sometimes it gets stuck until a reboot.

The rest of the problems you mention do sound like a problem with the game though.

15th May 2014, 08:49
I’ve noticed since the last update my key bindings are being strange – though that said it might be the Chat itself…since Team Speak come out I’ve changed my key bindings slightly…

I use T for Team chat, G for Game chat and H for Push to Talk.

Randomly during matches – I’m talking mid-way through the game – or just random pushes of the buttons they’ll seem to switch around and the wrong chat will appear…

Example: I’ll push T but it will bring up the open Game Chat instead of the Team Chat – or I’ll push G to talk on the open Game Chat and it’ll bring up the Team Chat…so I have to check if the (Team) prefix is there all the time – and exit it if it isn’t and press it again…

…last night it posted a few times in the wrong chat…which was annoying…not sure if it’s the key bindings or a Chat bug though!

30th May 2014, 16:03
I am totally unable to save different configurations for T and Y to chat in game. I try to move to somewhere out of the way like N and M or anything else but even though the chance appears in the keybindings it makes no difference in game. This of course incites no small amount of gamer rage as T is where my finger goes to reload.

I also don't know why it's necessary to press esc twice to get out of a chat window. When giving instructions to your team them pressing escape to get or enter to get back to the game the chat box closes but your cursor is in a "minimized" chat window which is super infuriating as it appears as if you are back ingame until you try to move only to find out you are still typing. This seems totally unecessary.

30th May 2014, 16:13
Yeah, this bug has been around for quite a few months - very irritating when you are trying to attack and it brings up the chat instead... I have solved it by putting the T binding on my side-mouse cause it was unbearable..

30th May 2014, 16:19
hate this, happens and i die lol

18th Jun 2014, 22:17
This is so far the most frustrating and ridiculous thing I've had to deal with in a game.
Every single update you guys put out resets all of my ingame loadouts and keybinds and I'm severely curious as to why.
I've never had a game do this once let alone EVERY update.
Is it intentional?
I can't believe that it is.
EDIT: My post was moved here since I made a thread outside the beta forums while my access to them was revoked.
It seems to have been a problem since last year and it still hasn't been "fixed".
I'm going to believe that it's intentional until I see a Pyonix employee tell me otherwise.
Were it not intentional I'd like to think this would have been fixed months ago.

19th Jun 2014, 01:58
Had posted about this a while ago...figured I'd re-post since my issue still hasn't been resolved. I am trying to bind my Delete key in the Home, End, Page Down area of my keyboard. Delete is the ONLY key that I can't bind for my setup. Everything else is fine. Please help me figure this out or fix it. Thank you.

19th Jun 2014, 10:10
I believe you are not the only one who has asked about certain keys not accepting bindings. At present there isn’t a way for this to be able to be done your end…so I’m afraid it’s just a case of waiting out for if changes are applied by the devs.

22nd Jun 2014, 05:15
Been trying to change some of my key bindings, specifically the skill keys and noticed that even when you change them they still stay bound to the original key along with the new one that's set. Anyone else notice this. It bothers me particularly because it competes with my voip ptt, that is I use a skill everytime I talk. Hope this can be addressed.

22nd Jun 2014, 07:47
hit the default button to turn it back into the original key... then hit your new key.

If you hit your new key then hit the old key it will log both of them

22nd Jun 2014, 09:03
hit the default button to turn it back into the original key... then hit your new key.

If you hit your new key then hit the old key it will log both of them


22nd Jun 2014, 10:00
Thanks for response, but I'm not too sure what you mean. I tried to rebind it but nothing changed. My ability 1 is bound to 'c' and even says that it is in the in game interface, but when I press 'q' it goes off regardless.

22nd Jun 2014, 20:58
Whenever i rebind a key, the game keeps using the old keybind too.
I use F for my voicechat outside the game, so i rebind the 2nd skill to my mouse thumb button. But when i use my voicechat to talk to friends it will use the 2nd skill because the game wont unbind the old F key.

I just quit the game because this pissed me off and makes it unplayable for me.

23rd Jun 2014, 12:04
This sometime can happen where they will intermittently change - may I ask which mouse do you have? I know there are some that have a few issues.

23rd Jun 2014, 21:04
I use a Steelseries Sensei mouse.

24th Jun 2014, 07:21
I use a Steelseries Sensei mouse.

Hmm this is not the mouse I've heard people saying they have issues - it maybe the reset issues that are just generally happening with the game since the last patch. Though maybe raise this as a bug/issue with the SE Support Centre (https://support.nosgoth.com/system/templates/selfservice/nosgoth/#!portal/1001)

3rd Jul 2014, 19:43
Could you please not reset the key bindings when you but out a patch? It is very annoying and should not be thing in 2014. And yes I know it's beta, which is why I'm reporting this as something that should be fixed.

Also, when you set up custom keys, you should not have to press "Ok" after you pressed to new key, it makes the process cumbersome.


3rd Jul 2014, 20:10
pressing ok is not an issue, and while i dont like the re bindings i dont care that much is it really necessary to plea for this? (not ripping on you just my opinion)

4th Jul 2014, 04:08
Got really frustrated after downloading newest patch because my gamepad keybindings reset (I didn't know it might be a problem), and the default setting is awful. With sprint/traverse mapped to a face button (A, I think it was, using Xbox controller) you can't TURN while sprinting, unless you hold the controller in a really freaky way. Or have 2 thumbs on your right hand.

No offence if you like it (or have extra digits), I just find it awful to deal with.

4th Jul 2014, 09:31
Could you please not reset the key bindings when you but out a patch? It is very annoying and should not be thing in 2014. And yes I know it's beta, which is why I'm reporting this as something that should be fixed.

Also, when you set up custom keys, you should not have to press "Ok" after you pressed to new key, it makes the process cumbersome.


I feel for you. On patch day the first match with mumble starts with some "uhhh not again..." followed by either a bored or a wiped human team. For some reason I like the default binds but my friends change them a lot.
And no, we dont remember to do it before the match. Be it cause were dumb or not used to do it by other games or both.

Hitting Ok for every key shows some lack of usability knowledge and shouldnt be the case in 2014.

19th Aug 2014, 19:55
My issue with keybindings is that i change them in the main menu and they just swap to Default when in-game.

BUT, if i hit Esc (while in a match) and go to Options, even if i do nothing in the menu and just continue play, my keybindings will work then. Kind of a workaround for me at least.

20th Aug 2014, 04:10
Simple workaround for default keybindings, edit DefaultInput.ini located in ...\Steam\SteamApps\common\nosgoth\BCMPGame\Config\ save this file with the read-only attribute and delete: ...\Documents\My Games\Nosgoth\BCMPGame\Config\BCMPInput.ini [it will be recreated with custom keybindings after you launch the game].