PDA

View Full Version : Black Screen issue with 5850



klassbottle
14th Mar 2010, 01:20
Every time I start up the demo, I just get a black screen (aka no video) with only sound. I tried updating my drivers, redownloading, verifying game cache, and it's still not working - no idea what to do, when every other game I have runs fine.

I've also tried tried running in compatibility mode and run as admin. No luck :(

Specs:

AMD Phenom II 955
4GB DDR3 1333
Sapphire HD 5850 - 10.2 Catalyst drivers
Windows 7 32 bit

Appreciate any ideas or suggestions I could try. Thanks.

mixterz
14th Mar 2010, 11:53
Every time I start up the demo, I just get a black screen (aka no video) with only sound. I tried updating my drivers, redownloading, verifying game cache, and it's still not working - no idea what to do, when every other game I have runs fine.

I've also tried tried running in compatibility mode and run as admin. No luck :(

Specs:

AMD Phenom II 955
4GB DDR3 1333
Sapphire HD 5850 - 10.2 Catalyst drivers
Windows 7 32 bit

Appreciate any ideas or suggestions I could try. Thanks.
Have you installed the latest DirectX ?

And why do you run a 32bit system with 4gb?

klassbottle
14th Mar 2010, 17:24
Have you installed the latest DirectX ?

And why do you run a 32bit system with 4gb?

Compatibility issues with 64 bit. Also, yes I have :/

Thanks for the suggestion though.

Lakers
23rd Mar 2010, 22:35
I've got the same problem, do you have Asus GamerOSD or Asus smartdoctor installed,

They seamed to be the problem for me.

Looks like it's the same problem as Fallout3. :/

Uninstall those programs and it worked for me.

MarcusVel13
19th Jul 2010, 20:50
i have the same problem and close to same specs as you