View Full Version : Unplayable Graphics

7th Mar 2010, 17:40
So I have played with all the graphics settings to try and solve this problem. It looks like my screen is covered in black smoke and is flickering. running 196.21 nvidia drivers. None of the graphics settings seem to make any difference and have tried everything maxxed with incredibly smooth gameplay, its just i cannot see anything at all! as i said its a smoke effect so the game is barely visible but not enough to be enjoyable by any means.

cpu : e8400 @ 3.9ghz
gpu : 9800gx2
ram : 6gb corsair xms2
os : vista 64

Seems like a fun game but currently would rather set fire to it lol.

7th Mar 2010, 17:47
If you're on Steam, try verifying the game files. Right click on the game -> Properties -> Local Files tab -> Verify Integrity of Game Cache.

Not sure what to do after that. I'd say something's up with your video card since it might be a really bad case of artifacts, but don't throw it out right away.

7th Mar 2010, 18:54
dont think its my card as no other game has this problem. ME2, SC2, WoW, Mirrors Edge, etc.

7th Mar 2010, 20:24
(working the video)

7th Mar 2010, 20:47
Go into the video settings and try the brightness/contrast and gamma settings.

7th Mar 2010, 21:32
its not that, i check gamma and brightness. looks very different in the video, trying to get it to upload right now. also if it was gamma/brightness then the lettering from the side menu would be affected as well. as you can see the side menu is perfect.

7th Mar 2010, 21:45
http://www.youtube.com/watch?v=WVK0ap6yqsI (being processed at the time of posting here)

7th Mar 2010, 23:05
Just watched the video. Wow...that's really weird. Wish I could help you, but if you said that it works fine with other games, I dunno.

Reinstall the demo?

7th Mar 2010, 23:35
Try other drivers, that might do the trick.. Not sure tough

8th Mar 2010, 21:05
Tried older drivers as well and no cange. going to try to delete/reinstall and hope it works. I had steam verify the game files and it found no problem as well. Anyone from Eidos got any ideas? anymore info about my computer needed?

8th Mar 2010, 22:06
I've got the same problem. It plays fine but it's all dark and flickery and the cutscenes are completely unwatchable.

I've got the Steam version as well, files verified. I've got an I7 920 not overclocked, 12g of ram, GTX285 in SLI with Vista 64. Can't remember what drivers I've got going, think it's 182 something. I tried to update to the 19x drivers before but I kept running into problems with WoW. It'd let me alt tab out but not back in, so I went back to the 182's to fix it.

8th Mar 2010, 22:34
I didn't change anything, but when I loaded the game back up the flickering was gone. Everything is still dark and the cutscenes are still unwatchable though no matter what settings I change.

8th Mar 2010, 22:40
Could it possibly be something with vista 64? same os i am running. what service pack do you have?

8th Mar 2010, 22:59
Could it possibly be something with vista 64? same os i am running. what service pack do you have?

I have no idea actually, how would I find that out?

Edit: dxdiag says "(6.0, build 6001)" under OS if that helps.

9th Mar 2010, 00:18
control panel > system
it will say on the top part of the window which service pack you have. I am using service pack 1.

btw : uninstall and reinstall = no change for me.
no way i can shell out cash for this game if i cannot be certain the final product will have the same problem. now that im not the only person that has this issue this could be a possible concern. has an eidos dev looked at this thread? are they looking into this? just trying to find out whats causing it.

9th Mar 2010, 03:00
Yeah it's service pack 1 here too.

9th Mar 2010, 22:20
/bump anyone got any ideas on what's causing this and how to fix it?

10th Mar 2010, 00:39
I haven't got any ideas on how to fix it, but it does remind me of a similar problem with DX11 mode in Aliens vs Predator. This is apparently a "known issue", according to the AvP readme:

x) Currently in the DX11 version the gamma video option is not compatible
with Nvidia video cards. You should leave the gamma at its default setting
(0.5) in these circumstances. This may be addressed in a future driver

Btw, are you both running in SLI? You could try disabling that, to see it if it helps.

Just to be clear: I'm using the 196.21 drivers with a Geforce 260GT (192 cores) and am not experiencing these graphical issues with JC2 (but do have 'em with AvP).

10th Mar 2010, 01:04
Runnin my 9800gx2 in sli with 196.21 drivers from nvidia. gamma is set to default as well. trying now without sli.

*update* turned off sli and now works. wonderful so the game is unplayable with sli on >.< such a drop in performance.

Eidos Support
10th Mar 2010, 09:17
Sli requires profles to work correctly, I'm sure nVidia will release a SLi profile update for JC2 at some stage. You could always check www.nvidia.com and install the latest SLi profile package, it may help.

10th Mar 2010, 14:11
Thank you very much Mr. Annonymous Eidos Support Person! I was a bit surprised as this is the first game I have ru into that had a problem with running Sli without a profile for the game. Could there be a conflict between the game and drivers that is causing this? I am more knowledgeable of hardware then software and just want to understand what caused this with JC2.

After playing the demo through a couple times it is an absoltely fun game. May I sugest a stunt competition of sorts? Craziest stunt gets a free copy of the game? Oh the possibilities lol.

12th Mar 2010, 09:47
Could it possibly be something with vista 64? same os i am running. what service pack do you have?

No problems here running it with Vista X64.

30th May 2010, 02:36
I have the same problem. Vista 64bit, Q6600 2.4GHz, 4Gb ram, GTX 280 1GB. everything maxed, on, would i have accidentally installed SLI Drivers.