PDA

View Full Version : My friend's demo won't start. Just gets generic Windows error message.



SpankyTheElf
7th Mar 2010, 03:38
512MB 9800GT (the 196.21 drivers)
AMD Athlon 64 X2 4600+ 2.4Ghz
4GB RAM
Vista 64bit

He's downloaded the demo twice from Steam and has restarted him computer but can't get the demo to start. He gets the generic "This program has stopped working. Windows has closed it and is looking for a solution" or something like that.

The computer is capable enough to run it and I have no clue why it's not working.

Any ideas?

dark_angel_7
7th Mar 2010, 09:54
This happened to me too. You'll need to download the latest driver, related to your card, from the nVidia site:

http://www.nvidia.co.uk/Download/index.aspx?lang=en-uk

SpankyTheElf
7th Mar 2010, 17:28
This happened to me too. You'll need to download the latest driver, related to your card, from the nVidia site:

http://www.nvidia.co.uk/Download/index.aspx?lang=en-uk

They pulled down the "latest drivers" because of fan speed control issues (cards were burning up). I was lucky and downloaded them before everyone found out (I use RivaTuner to turn my fan up to 100% when gaming), but I know other people who rolled back their drivers and haven't had any issue playing.

SpankyTheElf
9th Mar 2010, 00:42
He's still getting the error. http://i50.tinypic.com/4t1403.jpg (Not his screenshot, it's from a thread on the Steam forums)

Tried launching it in windowed mode but that didn't work. He has DirectX 11 and Service Pack 2 for Vista 64-bit.

He basically has the same specs as me and I can run it fine.

AMD Athlon 64 X2 4800+ 2.5GHz
NVidia 8800GT 512MB
8GB RAM
Vista 64-Bit

We've been looking around online for 2 days and can't find anything.

It's not troubling me that he can't play it, it's troubling me that I can't find out the answer lol.

mixterz
9th Mar 2010, 06:32
Install the latest DirectX drivers, that are in the steamapps/common/just cause 2/directX
click on DXSETUP.EXE

Still not working?

I see you have a 64bit windows, in steam rightclick "Just Cause 2 Demo" and choose Properties, then set launch options, in there write "-64bit" exactly, without the quotes. It worked for me!

SpankyTheElf
9th Mar 2010, 20:48
He got it to work. I think his NVidia drivers were corrupted or something because he said he updated (he already had the latest version) them and it work.

*shrugs* Whatever, as long as it worked haha.