PDA

View Full Version : Strange peoblem going backwards



gravy1
12th Jan 2010, 17:20
Hi... I've played thief 3 loads of times before but just recently each time I play it.... after a short while garrett starts walking backwards and apart from continually holding down the walk key the only way to stop it is to save then reload and on a lot of occasions this doesn't help I have to close the game and restart but the problem often comes back. I'm wondering if it might be a problem caused by my usb mouse and keyboard or whether I've done something when using a registry repair program... any ideas please ?

theBlackman
12th Jan 2010, 21:10
Do a search for USB in the tech forum, and read the stickies there.

USB devices, joysticks, and gamepads have a history of causing these kind of problems.

gravy1
14th Jan 2010, 15:00
thanks anyway but...... I did search but only came across people with similar problems and no solution just "USB devices cause problems" I'm surprised Eidos haven't made a fix patch for this yet.... I have enjoyed the thief series but will wait to buy thief 4 until I see if there are usb problems...

jtr7
15th Jan 2010, 04:05
No patches have been released for any of the problems that have existed or come up since the companies that made them closed their doors.


Anyway, exiting the game, unplugging the USB controllers, starting up the game again, and plugging the USB controllers back in might fix it. Updating drivers, or rolling them back is a possible solution.

gravy1
15th Jan 2010, 06:34
Thanks anyway.... anything and everything is worth trying because whenever I format thief 3 is always the first thing to go back on.... as a last resort I've bought a ps2 mouse hoping that solves it. Just hope its not caused by my usb keyboard ;-)

Keeper_Riff
15th Jan 2010, 10:38
The only solution I stumbled upon is this one:


The game acts like some button is always pressed! (usually "Up" or "Down" key). I'm not using any gamepad, but I have a USB Gaming Keyboard.
Go into Device Manager and look under Human Interface Devices for two or more entries named USB Interface Device. What you want to do is double-click on each USB Interface Device entry; then look on the Properties tab and make sure that it says USB Gaming Keyboard next to Location.

After you’ve located the right entries, right-click on them (and only them) and select Disable from the pop-out menu, answering Yes to any prompts. One of the entries will not have Disable as an option when you right-click on it — that’s the one that obviously should be left as-is.

It's written for Saitek Gamers keyboard, but may also work with others.

gravy1
15th Jan 2010, 16:37
Thanks DJ Riff that worked perfectly. The devices disabled are the shortcut keys on my Saitek USB keyboard and do not prevent the keybord from still working perfectly but it solves the problem thanks.
I think your solution should be posted and set as a sticky it will help a lot of people in the future.