PDA

View Full Version : OK...I'm tired of the freakin' lag!!!



pockyking535
20th Dec 2009, 02:54
Ok. So I download the demo of B:AA from "Steam". For about 2 months, the game plays flawlessly on my PC. The only problem was that I couldn't change the video settings for it, but I'll leave that for a different post. Then, about a week ago, for no apparent reason, the game is suddenly EXTREMELY slow and full of lag. I mean, I must have been averaging about 30 FPS before this week, and now, I'm seriously at MAYBE 2 FPS. It's in slow motion. There is nothing wrong with the sound or anything. I found that I could go into the games config file and manually change the setting, so I changed everything to low, or "false" in my case. Originally, the resolution was at 1024 by 768, but I now have it at 800 by 600. The game, even with these new low settings, is still VERY slow. I'm at my wits end. I have no idea how to fix it. Please help! :mad2::lmao::nut:

Here are my settings...

CPU - Intel Core2 Quad Processor Q6600 (2.40 GHz)

GPU - ATI Radeon HD 2400XT 256 MB Video Card

Motherboard - MSI NVIDIA MCP73PV

Memory - 4 Gigs

HDD - Western Digital 750 GB Serial ATA II Hard Drive With 16 MB Cache

Monitor - 19 inches (Native Resolution: 1024 by 768)

P.S: I know, my GPU isn't much to look at, but it seriously did play the game VERY well, without PhysX of course.

Viceroy Phoenix
21st Dec 2009, 02:41
Gosh I Know eh? (Yeah I'm Canadian) But the lag started as soon as played! I don't WHAT is wrong with the demo, or maybe my computer needs a good cleanup of old files, just to get everything, you know, "Moving"

Nemesis296
21st Dec 2009, 11:57
Did you try restarting your computer before playing it? I know sometimes games would run really slow if you didn't restart before playing them. Also, your graphics card is preeetty low for this game. I tried running everything on low with a 512MB card (and I only had 2GB of RAM) and everything was DOG slow, to the point that I couldn't even play it. I upgraded to a much better card and more RAM and now it runs flawlessly :)

pockyking535
21st Dec 2009, 16:23
Did you try restarting your computer before playing it? I know sometimes games would run really slow if you didn't restart before playing them. Also, your graphics card is preeetty low for this game. I tried running everything on low with a 512MB card (and I only had 2GB of RAM) and everything was DOG slow, to the point that I couldn't even play it. I upgraded to a much better card and more RAM and now it runs flawlessly :)

Yeah, I know that it's not that good a card. But, I'm only playing on a 19-inch monitor, so the resolution isn't that hard on it. I mean, I can play "Crysis" on it with everything set to medium and it works just fine. Why can't it play this game? lol and as I said before, it worked perfectly up until about a week ago. I just can't find the problem. But I will try restarting my PC as you suggested and see if that works.

Thanks,
Pockyking535 :D

pockyking535
21st Dec 2009, 17:14
Ok, I think that I fixed it...but I'm really confused at how I did it. I went into the config file (UserEngine) and I put everything back to the original settings, except for PhysX which I put up to 1 (that means that I turned it on!!!). So now, the game is back to it's normal settings (actually, I turned some stuff on that I don't think was EVER on in the first place i.e. "Dynamic Lights" "Dynamic Shadows" "Motion Blur") and it's working fine! I think that it has something to do with having the PhysX on or off. However, as you can see from the posts above, I have an ATI Radeon HD 2400XT 256 MB Video Card....How is this card able to produce PhysX and not lag at all??? And don't you need and nVidia GPU to run nVidia PhysX??? I'm so confused right now...O.O