PDA

View Full Version : Need help with control toggle



Panther10
14th Dec 2009, 00:29
I'm using a logitech gamepad for the PC version of this game but for some reason it wont configure correctly. Especially with the D-Pad or the left analog stick. whenever I push up to go forward I move backwards, and when I try to invert the directional settings, they still remain at that same configuration. how do I fix this issue?

Moonwolf1968
21st Dec 2009, 19:50
It does that to me also. Edios says they can only give support for Xbox 360 controllers. What a bummer. Guess we need some home-tech to figure this one out.

Someone please help. The game is great but the controller issue takes the fun out of it.

homeycdawg
21st Dec 2009, 20:32
I made a thread about this when I got the game and realized the dumb XBox controller thing. Look at this thread.

http://forums.eidosgames.com/showthread.php?t=97603&highlight=xbox+controller

Or for the summarized version, you need a Xbox controller emulator to make the game think your directX gamepad is a XLive one.

I use this one with my Thurstmaster and it works great for me in Batman (after some configuring).

http://virusdev.ovh.org/files/

Hope that helps.

Moonwolf1968
21st Dec 2009, 20:45
I have a Logitech Dual Action 12 button game pad. Still inverted control when walking. Even tried to turn inversion on and off in the game setup but niether had any effect.

homeycdawg
22nd Dec 2009, 02:22
Sorry guys, I didn't really investigate any further than I needed to get it to work for me.

I'll agree that forcing people to buy XBox controllers when DirectInput is a superior API is weak-sauce. I personally don't like XBox controllers.

Moonwolf1968
31st Dec 2009, 22:57
I've found that you you use the logitech device profiler you can invert the joystick. When setting up the profiler you must manually add the game to it's lists. Also it must be pointed to the ShippingPC-BMgame.exe and not the other two .exe files or it won't work. lol I got so used to backwards movment controls that now it's hard when it's working properly.

Moonwolf1968
1st Jan 2010, 10:35
my bad, thought it worked but nope :(

funnyromeo
24th Aug 2010, 12:27
Logitech Dual Action Gampad fix for Batman Arkham Asylum.

1. Download This File http://hotfile.com/dl/35250827/032677... This the Batman Config File

2. go toMy Documents-Edios -Batman Arkham Asylum -BmGame - config.

3.Copy the file and paste it in config folder.(Click Copy and replace)

4.Go to BmInput's properties- click security tab - click edit -Select system - mark the box thats says write and put deny for all.

5. click on your user or adminstator do the same thing again click deny on write.Set all options to deny.

(step 4 & 5 is necessary bcoz when you restart the game it reassigns to default.You are just making it write protected)

6.Load Batman Arkum Asylum and kill the baddies.

This is fix for dual action logitech and other joypads gamepads as well.

WhatIsTheMatrix
25th Aug 2010, 08:19
Same happened to me last night all I did to fix it was to invert the controls and they work fine.

njones1980
11th Sep 2010, 23:36
I've read many variations on how to do this and was left Totally confused. But after many a try this is THE most solid way to take care of the the inverted control issues with the left thumbstick.

1. Make sure your settings are where you like 'em, 'cause if you change the settings, you'll have to do this all over again.

2. go to documents/Eidos/Batman Arkham Asylum.

3. Open up the BmGame folder and then open BmInput.

4. This next part will be tedious for some, easy for others. Scroll through the bindings list and look for the following code:

Bindings=(Name="XboxTypeS_LeftY",Command="Axis aBaseY Speed=1.0 DeadZone=0.3")

5. Change "Speed=1.0" to "Speed=-1.0" There are three different places that you do this and there's one line where you have to change it twice. That looks like the following (shown after the fix):

"XboxTypeS_LeftY",Command="Axis aBaseY Speed=-1.0 DeadZone=0.3 | Axis aRawLHJoyUp Speed=-1.0 DeadZone=0.0" )

This will make sure you're not gonna be messed up when you have to fight.

6. Save the file and then go to BmInput's properties and change to read-only.

7. Load the game

Guaranteed to work.

Marcus
13th Sep 2010, 09:03
From what people have reported, in the Game of the Year edition you can just use the invert option in the launcher. In the older version that option apparently doesn't work properly for all controllers.