View Full Version : Batman Mansion and Update Issues

12th Dec 2009, 02:01
I received a Batman game, it was from Russia. I play the game up the the following point.

I come from Arkham Island East, through a vent on Arkham Mansion that must be taken down with the batclaw (after defeating four snipers, two bellow that same vent). I enter Arkham Mansion, defeat 3 guys. As I go to the door, the only point, it at the door, and if I grab it, I end up being pulled thru the wall and end up in a black area.

I've tried to run the update program, and it doesn't see the game installed on my computer, I also tried the russian patch and it also doesn't see that the game is installed.

Can someone help me get the patch installed, I lost the game, because my hd went down and had to re-install everything, and I don't want to play all that way again, just to get the glitch again.



12th Dec 2009, 15:16
I have a problem in the same place, only a bit different. First of all, from what I've read on your post, I think that you're not going on the right way. That door should be locked, so try looking around. If after you found out the correct way in, your problem persists, let me know.

My issue is that I can't stay for too long on the room on the other side of that door. This is a bigger problem than it seems because we will have to be in that room more than once, and as fast as I could be, I haven't made it through yet. The game crashes to desktop or I get a blue screen.

So it seems that that room is not our friend. Our problems might have something in common. If I find a solution to mine, I'll let you know so you can try it out if you're still stuck. But first try to use an alternative route. There is one. If you know of something to make it work, please post it here.

I've contacted Eidos and they seem to be trying to help so far. But from all the possible solutions they gave me, not a single one worked.

12th Dec 2009, 19:36
I'll let you know. I had to restart the game over, because I received a virus or something weird and had to blow my C: drive away. I didn't get all the files, but it's about 20% finished and I'm currently over 12% at this time. I should be there in a day or so.


12th Dec 2009, 22:51
Try not to grapple whenever unecessary, and keep an eye out on where you are aiming the hook at.

13th Dec 2009, 00:12
This time I got past, but now having issues in Doctors youngs office. 1/2 the time, after I beat up the 3 guys, and I then get onto the desk, and pull down the grate. 1/2 the time I'm able to get a (F) point to shoot up, and then get into the office, but I can never seem to get out, without it going off into so black area. The other half, I pull off the grate, and there is no point to shoot the grappling hook to..

I love this game, but at time, the glitches, or having to be in an 100% exact spot are a pain.


13th Dec 2009, 12:26
I was able to get past this point. I didn't receive the error that you had. I'm getting some other weird errors, but I had to download a trainer to see about getting past them. I hope you were able to get past the error you were getting.

13th Dec 2009, 17:17
Glad to hear that. Usually, you can just go to the library and after you save the hostages there, and get back to Dr Young's office you can grapple back up to the vent you came in from.