PDA

View Full Version : BmGame Has Stopped Working -- @ Med Facility, Lower Corridor



SerinFel
5th Dec 2009, 10:49
Haven't had any problems until this point. Be warned, spoilers, and many details:

I'm at the Medical Facility, Lower Corridor, inside the walls. I see Gordon through the vent, who begs for help and is dragged away. Next, I rip off the vent cover from the vent shaft, and oddly enough, BM's eyes start glowing the same color as the orange lights in the shaft (this didn't happen before installing the 1.1 patch). I exit the shaft, walk to the end of the hall where what appears to be Gordon's body lies, and immediately once I reach the T intersection of the corridor, the game crashes with a "BmGame has stopped working" error.

I have all the latest nVidia drivers, I have the latest sound drivers, I have the 1.1 patch, and PhysX is turned OFF--disabled in the game settings and double-checked it is disabled in nVidia control panel. Even tried dropping game specs to lowest, same result.

System specs:

Vista 64 (up to date)
Asus M3A79-T Deluxe (sound on the board, up to date drivers)
Phenom 1 X4 9950 2.6Ghz
8GB ram
Asus GeForce GTS 250 1Gig (primary, up to date drivers for both directly from nVidia)
BFG GeForce 9600 GT 512mb (secondary)

I've double-checked my system temps and voltages with CPUID and everything is normal; temps averaging 127°F all around (CPU and both GPUs in the same neighborhood temp), which is normal for my machine.

Briefly considered the possibility of the problem being caused by having both graphics cards simultaneously, though I doubt that is the cause; they're getting along fine with my other games (FEAR2 Project Origin and Reborn, Force Unleashed, Mirror's Edge).

Going to try reinstalling the 1.1 patch over itself again (linked file from the boards here), going to try uninstalling PhysX and my graphics drivers and then try reinstalling them--it's worth a shot.

Any ideas as to what is causing this are welcome.

Thanks guys!


--Serin

deders
5th Dec 2009, 11:04
The eyes thing is supposed to happen
Which version of the drivers are you using? i'd recommend 191.17

SerinFel
5th Dec 2009, 11:09
195.62 (11-26-09) is what I'm using now. I'll uninstall and try 191.17.

Edit:
I'm seeing 191.03 (beta) and 191.07, no 191.17 (assuming you meant 07). Grabbing the latest PhysX from nVidia while I'm at it. Once I downgrade to 191 from 195, I'll upgrade PhysX. I'll post back with results.

As for the eyes, yeah, it makes sense now that I think about it (without giving anything away). Thought it was odd at the time, tho.

SerinFel
5th Dec 2009, 11:55
Ok, uninstalled nVidia 195 drivers, installed 191.07, have not updated PhysX yet, made sure PhysX is disabled, reinstalled BAA 1.1 patch, double checked PhysX is disabled, tested, and game crashing at same point. However, this is new:

http://i65.photobucket.com/albums/h236/catch_22_83/BmGameError.jpg

Any ideas on the image?

Edit:
Just tried again, still crashing, but the above image didn't show up a second time.

Gonna try an uninstall of the game, then a clean reinstall and patch. I'll update here with results.

deders
5th Dec 2009, 12:02
well you need Physx installed to run the game, even if switch it to off in the launcher, the game still calculates some on the CPU. the error looks similar to errors people get when something is missing from Physx.

SerinFel
5th Dec 2009, 12:07
Found the log file containing the error. Basically the same as the image:

Log: Log file open, 12/05/09 03:47:20
Log: Virtual memory allocation size: 0.00 MByte (0 Bytes)
Log: Physical memory allocation size: 0.00 MByte (0 Bytes)
Log: Virtual memory allocation size: 0.00 MByte (0 Bytes)
Log: Physical memory allocation size: 0.00 MByte (0 Bytes)
Log: Virtual memory allocation size: 0.00 MByte (0 Bytes)
Log: Physical memory allocation size: 0.00 MByte (0 Bytes)
Critical: appError called: Couldn't find file for package Medical_B6_Static requested by async loading code.
Critical: Windows GetLastError: The system cannot find the file specified. (2)

Gonna try updating PhysX before a reinstall of BAA.

Edit:
Removed and reinstalled PhysX, enabled for my 9600, game still crashes. I'm not seeing an updated log file, though. Curious.

deders
5th Dec 2009, 13:04
yep, my bad, 191.07

SerinFel
6th Dec 2009, 06:32
Got it working!

I think reinstalling Visual Basic did the trick. I got the vcredist_x64 from MS and installed that, now it works. I researched the file MSVCR80.dll and discovered it was part of Visual Basic, so I tried a reinstall of that.

So, a recap of everything I've done:

Uninstalled NVIDIA drivers
Uninstalled PhysX
Installed NVIDIA drivers 191.07
Installed PhysX (updated version, installed separately)
Uninstalled the game
Reinstalled the game
Installed the 1.1 patch from Edios
Tried installing Visual Basic from the x86 version of vcredist on the BAA disc, which failed (expected that, since I'm running 64-bit, but it was worth a shot)
Installed Visual Basic 64-bit (vcredist x64)
Proceeded with various reboots through all of this--I could have listed when I rebooted every time, but that would just be annoying for everyone reading this.

Now, no crash at the end of the T-junction in the Lower Corridor of the Medical Facility.

For anyone else having similar crashing issues and who have already tried reinstalls of the game and graphics/audio driver changes/updates, I suggest trying to reinstall Visual Basic. That seems to have done the trick for me.

Thanks for your help deders. Hope this works for anyone else with this or a similar problem.


--Serin Fel