PDA

View Full Version : Gtfo gfwl



Powerban
1st Dec 2009, 12:37
System Specs
Dvd Bought
Win7 RC1 32bit
Radeon HD4870
(The rest doesn't really matter)

Alright, like a lot of other users I played the game in offline mode first as this computer didn't have the internet connected until today. There were no problems for me until I plugged the internet in and decided to try and go online with this game.

It asked me to update games for windows live upon going online through the internal GFWL in batman. I'm not sure if I had GFWL on my computer (that wasn't in-built into batman, of course, and remember this computer had no prior microsoft windows updates) and everything went smoothly.

I then realised I had to get a whole bunch of windows updates, So I did that too. I got all of them, including the GFWL one it asked me to get there. I restarted, It gave me more updates, and yet another GFWL update to which I restarted again.. Hoping to get back to my game.

Well, now I load it up and it's just a blank screen. I sit there for a bit and then alt+tab to see what is going on. Low and behold, there is a new window there.

http://i106.photobucket.com/albums/m255/NuKillar/xlive.png

It's basically telling me xlive hates me. With a bit of research on this I came across the fact that you can't just download any xlive.dll and place it in your System32 folder. At this point I updated the game to 1.1 manually with nothing changing. I then uninstalled the game and tried again, no luck. Next I removed GFWL and the redistributable via the add/remove program option in the control panel, tried it, didn't work, with or without patch, same error. Lastly I tried uninstalling and re-installing one more time.. but yes, no luck.

I found this thread here on the GFWL forums: http://forums.gamesforwindows.com/t/7698.aspx

Which details the same issues that I had with not much help at all. Lastly just for fun I uninstalled PhysX to see what happens and got this message:

http://i106.photobucket.com/albums/m255/NuKillar/GeneralProtectionFault.png

I know it was pretty pointless to do it but I was trying everything. I need to try and install the patch by doing the whole change folder name/install patch/combine trick noted here, I just thought I'd explain in detail every step I took for future reference.

Will update this message when I try it out.... Maybe I should install it on my C drive as well


Update: No good. Still stuck with this error. Thinking of doing a system restore soon.

deders
1st Dec 2009, 18:22
Which patch did you use to manually update it? did you find it on this forum?
Some people have resolved some Xlive issues by putting the Xlive.dll into the game's binaries folder
You will need Physx installed to play the game as it still uses a small amount of CPU calculated Physx during the game.

Powerban
2nd Dec 2009, 01:48
Thanks for the response. I tried one xlive.dll that I downloaded in the binaries folder but it still had the same problem. After reading your response I figured that moving the one from system32 would of been the best idea.

It works great now, maybe include the dll in the next patch.

Just another quick question to anyone that can possibly answer it. Will there be more support for ATI cards in future releases? As in the hassle of forcing MSAA being fixed and maybe some sort of equivalent to the PhysX. (I don't know if PhysX only helps the cpu out or it actually creates better physics or not)

Thanks for the help.

Powerban
2nd Dec 2009, 02:11
Alright I guess I jumped the gun a bit too early. The game loaded up fine, But windows live doesn't seem to be showing up so I can't sign in, nor load/save my game. I press home in the menu, no luck. I pause the game, quit to menu.. click LIVE... still nothing happening at all.

I put it to the fact that xlive.dll probably relied on other files in the system32 folder to get it up and running. Merely putting it in the binaries folder is a simple bypass. Although I could be wrong.

Any advice from here would be great.

deders
2nd Dec 2009, 02:14
Is there any way you can install the old G4wl?

floydier
2nd Dec 2009, 02:29
the only thing that has helped me with this sort of situation is to reinstall the game and update it again. Get the physX update and start over i guess..?

Powerban
2nd Dec 2009, 04:06
No.. and no to both of those questions. Nothing is working. Is there a guide to completely remove GFWL from my computer?

Powerban
2nd Dec 2009, 08:39
Alright after removing xlive.dll from the binaries folder it has suddenly started working and it asked for the updates for windows live. It downloaded the first update, then the second. the update process went through fine but then when I tried to load it up again it gave me the same error.

I'm just going to try and emulate what I did before and play it in offline mode. This is ridiculous.

Powerban
3rd Dec 2009, 01:56
Well this is stupid. I uninstall GFWL, re-install batman and play in offline mode, works fine.. then windows updates GFWL itself.

Now I need to go back and do it all over again. GFWL is a joke. I'm taking this game back.

deders
3rd Dec 2009, 01:58
for the time being, you could turn automatic updates off, might need to check g4wl settings aswell.

Powerban
3rd Dec 2009, 02:03
It seems to get the xlive.dll issue as soon as it's updated. Turning automatic updates off isn't what I really want to do either. I don't know whether I should wait for some sort of update to this problem or take the game back.

It's disapointing because this game is good.

deders
3rd Dec 2009, 02:08
I always have automatic updates off, that way Windows still notifies me if I there are updates available, but I choose when to download and install them.

lhaymehr
3rd Jan 2010, 16:02
I too hate that thing from the bottom of my heart. Which idiot figured that loading a .NET assembly in a video game would be a good thing? First off it takes a minute for the game to get to the start menu because of SLOW JIT compiler. Second, we all know how hungry garbage collectors are in .NET with memory.

However, your problem is just that, a problem with retarded assembly dependancies. Talk abaut dll hell solution from Microsoft.... You can fix it by uninstalling ALL .NET frameworks from your PC and then install the latest one (3.5 SP1 as of now) then install latest GFWL.

FAIL FAIL FAIL FAIL FAIL FAIL FAIL FAIL MICROSOFT FAIL FAIL EPIC FAIL!!!!

// Edit

Oh and BTW, since xlive.dll is basically a .NET assembly wrapper you can't just slap it into your system32 folder. There are true .NET assemblies being installed with GFWL installer alongside xlive.dll and those need to be registered with the new SxS (side-by-side) mechanism which is much more complex (****tier and confusing) than simply calling regsvr32 on a DLL.

Any .NET app you plan on using in the future, use the installer. Otherwise expect problems in 100% of cases.

homeycdawg
3rd Jan 2010, 19:34
GFWL is epic fail. I've said it before (just like everyone else) but I just couldn't resist saying it again. I played through gfwl for a while, but only offline now. I pray that GFWL isn't tacked onto the sequel.

cyborg34572
3rd Jan 2010, 20:32
I dont like GFWL too. A kinda similar thing happend to my game aswell .
Oneday i opend up the game and gfwl was forcing me to update to patch 1.1, which i dont even want cause i have an ati card. But it woudnt let me play if i didnt update so i was forced to. Then after the update my game would not launch at all!!. So what i did is i uninstalled ,deleted everything , then reinstall and playedthe game in an offline account. Gfwl never buggd me about updates again.