PDA

View Full Version : Batman was slow, now won't even work



seabeast
9th Nov 2009, 06:29
I got Batman AA from Steam with my new GTX 260 card purchase.

I installed it on my PC, and tried playing it. It worked, but was really sluggish and had frequent pauses, making it mostly unplayable. I ran the framerate test, and it reported an average of about 20fps, with a range from 1 to 63. It was the 1's that made the game unplayable. :)

I saw a posting (here) about a patch to improve performance, so I tried installing the patch. Then I realized the patch didn't apply to Steam versions, but I had already installed it. So I uninstalled the whole game, downloaded it again from Steam, and reinstalled it. This time, when I launched the game, I went directly to the Settings and turned down the resolution and graphics setting, and also turned off Phys-X. But when I tried playing the actual game, it locked up. It now does this every time, usually with a repeating snippet of theme music. I can't even make it past the Eidos banner.

So I'm not sure if the prior patch install left behind some turd that's messing up the current game, or if I just got lucky the first time I ran it (I should point out that even the time it "worked", the game crashed when I tried exiting). So I've never actually run Batman without it ending in a crash.

My computer meets all of the minimum requirements, and most of the recommended requirements. The only area where it falls short is the CPU: I've got an Athlon 64 x2 4200+ processor, which is a little slower than ideal. But with 3GB of RAM and a GTX 260, I'd expect the game to be playable, at least at 1024x768.

Any suggestions? I'm stumped. :mad2:

/Seabeast

deders
9th Nov 2009, 07:07
you should have no problem running it at 1680x1050 or lower. Physx set too high is likely to make the game sluggish, normal is recommended for a single 260.

Are you entirely sure that the game has completely re-installed properly?. Some people had similar problems because it wasn't. You could try deleting it from steam, then going into your steam folder and the registry and making sure that all traces are gone. then try re-installing it, you may have to be patient as it istalls the 1.1 patch via steam.

seabeast
13th Jan 2010, 20:53
I'm still stuck with an unplayable game. After another full uninstall and re-install, the game worked again, but it's still crazy slow. Even on low detail settings with PhysX disabled.

And now, Eidos support has abandoned me.

After getting a lot of runaround between Steam and Eidos over just whose problem this is, Eidos finally offered "help" in the form of suggesting that I update my drivers. I had already tried that a couple times, but a new driver version had come out since my last update, so I updated again. It didn't help.

So I reported this, and the response was "Eidos only provides support for the original purchaser of the game. Since this game was provided to you as a free download, it seems like we have exhausted our resources in order to assist you with this game title." Pretty annoying that games bundled with a new graphics card aren't supported by their developers.

Anyone else have any suggestions? Anyone know of any other games that use the same (or similar) game engine, for which there's a playable demo I could try out?

/Seabeast

bbb
13th Jan 2010, 22:51
Have you tried the Batman demo?

seabeast
16th Jan 2010, 02:17
Have you tried the Batman demo?

Yes, and it was also really, really sluggish. It actually seemed maybe a little bit faster, but still unplayable.

I then downloaded and installed the Portal demo, and it ran great. So great, in fact, I played a few levels before remembering it was just a test. :)

/Seabeast

trancer-necromancer
16th Jan 2010, 03:00
I've got an Athlon 64 x2 4200+ processor, which is a little slower than idealyour cpu is the bottleneck...so your board also is dated, meaning your pci express throuput will be also slow compared to newer boards

seabeast
16th Jan 2010, 22:17
your cpu is the bottleneck...so your board also is dated, meaning your pci express throuput will be also slow compared to newer boards

Would that really explain it, even with low detail settings? The CPU exceeds the stated minimum requirements, so I could see this making things slow, but it ought to still be playable. I'm seeing frame rates on the order of 1 or 2 fps, sometimes lower.

/Seabeast