PDA

View Full Version : Keyboard Stops Working!!!



rayneman
4th Nov 2009, 17:33
I can't find anyone with a similar issue...but the game run just fine on my pc but for one problem. Randomly, my W,S,A,D and Space keys stop functioning. Crouch works, the mouse works as does all my mouse buttons, but I can't move!

When this happens on the ground, I can usually use my left control and whip the mouse around while pressing all the mouse buttons and usually I regain control over Batman somehow. However, when this happens and I am perched on a Gargoyle, I am screwed because all I can do is hang, but not drop (space) glide or move. I can throw batarangs to my heart's content, but I am forced to end the game because I am stuck.

As far as I know, all my drivers are up to date, I have no viruses or spyware, my pc is well above minimum requirements (like I said, otherwise the games runs very well) and this dones't happen on any other game I've played. There isn't anything I notice that directly precedes this happening.

Any ideas?

THANKS in advance for any help!!!

Rayneman

Marcus
4th Nov 2009, 18:04
Got MSN messenger running? It can sometimes trap keyboard commands.

deders
4th Nov 2009, 18:32
maybe there is something wrong with the keyboard wire? or batteries if it is wireless. have you tried playing any other games since this started to occur?

rayneman
4th Nov 2009, 18:48
maybe there is something wrong with the keyboard wire? or batteries if it is wireless. have you tried playing any other games since this started to occur?


Its a laptop...all other games work just fine (as well as anything else that required the keyboard). This is very strange!!! If I keep tapping W,S,A and D during one of these episodes, it will start beeping.

I am not running anything alongside of the game...I disabled everything that I safely can.

deders
4th Nov 2009, 18:59
What about icons in the taskbar?

rayneman
4th Nov 2009, 19:09
What about icons in the taskbar?

I am not sure what you mean, but my taskbar has plenty (quick launch on the left and most everything you'd normally have on the right when using Vista.

deders
4th Nov 2009, 19:15
Well messenger has been known to override Ctrl-Space, so some people have to disable messenger when playing. Other programs running in the taskbar (on the right) may have similar functions that take over when a certain key combination is pressed. May be worth closing any unecessary taskbar icons and seeing how far you get. Also most laptops have special function keys that may cause the keyboard to react differently after being pressed.

rayneman
4th Nov 2009, 19:31
Well messenger has been known to override Ctrl-Space, so some people have to disable messenger when playing. Other programs running in the taskbar (on the right) may have similar functions that take over when a certain key combination is pressed. May be worth closing any unecessary taskbar icons and seeing how far you get. Also most laptops have special function keys that may cause the keyboard to react differently after being pressed.

You know, this might very well be the cause (I don't use messenger though). Since Batman may require a different set of keys to be held at the same time, or maybe I mistakenly press some other combination that causes this. I wonder how the heck I can figure this out. I will try to experiment.

Thanks for the insight. :)

Nemesis296
4th Nov 2009, 19:32
Its a laptop...all other games work just fine (as well as anything else that required the keyboard). This is very strange!!! If I keep tapping W,S,A and D during one of these episodes, it will start beeping.

I am not running anything alongside of the game...I disabled everything that I safely can.

If it's beeping, the keyboard buffer is full. You've got to be running something in the background that is catching your keyboard commands, or you need to restart your computer. Have you tried restarting the computer to see if that helps?

deders
4th Nov 2009, 19:47
I'd start by disabling all uneccesary taskbar icons.

Usually the keyboard beeps if you press too many keys at once, like Nemesis said, this is because the buffer is full. So either something is stopping it from sending the keystroke signals to the computer, or something in the background is interfering, or both.

rayneman
4th Nov 2009, 22:52
I'd start by disabling all uneccesary taskbar icons.

Usually the keyboard beeps if you press too many keys at once, like Nemesis said, this is because the buffer is full. So either something is stopping it from sending the keystroke signals to the computer, or something in the background is interfering, or both.


Yeah, this has been happening since I started the game...I'm about 20% in so the computer's been restarted quite a few times.

I know when I am fighting, I am probably going forward, hitting left control, Q for the batarang and then the mouse buttons...and probably 5 other keys by accident while I'm doing it lol. Still its odd because much of the time the game is fine, and I've played a few other higher-requirements games like (I guess) GTA IV, Crysis and the like with none of these keyboard issues.

I will pay attention to what I'm doing...I am not very tech-minded so anything in the background would be next to impossible for me to determine.

Thanks for all the replies so far.

homeycdawg
5th Nov 2009, 04:08
It's been a while since I've had a laptop so they might not work like this anymore, but I remember a few times years ago I played a game called FAKK2 at school on it and in my button pressing frenzy I would occasionally pop it into 10-key mode. I remember it would make some keys not work and others work differently. I don't remember what keys activated it, but it was like a "press this key while holding that key" kind of thing.

Marcus
5th Nov 2009, 10:32
Try a usb keyboard instead of the built-in one - it will probably have different combinations of keys that are ok to press at once :)

Or better still, get a wired xbox controller and play with that!

dumariel
5th Nov 2009, 20:09
i have the same problem with keyboard

rayneman
5th Nov 2009, 20:38
Well...I was fooling around with the settings, found "keyboard" via the control panel. The "repeat delay" was set at its shortest, and the "repeate rate" was at its fastest. I backed off these settings and haven't yet had this problem occur. I wonder if that was it..sure would be nice!

dumariel
5th Nov 2009, 21:08
o.k so in my case th problem was with hot keys for language change in os Disabled/changed hot keys and now everything works great

Naman
30th Nov 2009, 01:56
This is an issue of DirectX.. There is a hidden command-line behind when a fullscreen game is on screen. When you press LCTRL+SPACE at the same time(Crouch and Open action), it triggers Chinese Input panel and focus on that invisible command line.

To get rid of this you have to disable Keyboard Shortcuts in Regional Settings in Control Panel.

Batmanfan455
6th Nov 2011, 23:46
I have this very same problem, and these last two posts seem to hold legitimate answers. I attempted to do what they said, but couldn't find everything properly, and google informed that doing what you guys were saying was much harder.


Please, if you could, expand on how I do both those things? (although I suspect they might be the same thing.)

JD_Method
7th Nov 2011, 18:26
I have this very same problem, and these last two posts seem to hold legitimate answers. I attempted to do what they said, but couldn't find everything properly, and google informed that doing what you guys were saying was much harder.


Please, if you could, expand on how I do both those things? (although I suspect they might be the same thing.)

Go to control panel > keyboard. You can adjust repeat delay and repeat rate here.

As for the hot keys, go to control panel > Region and Language > click the Keyboards and Languages tab > click Change keyboards... > click the Advanced Key Settings tab. Now you can change the key sequences for the actions.

Note: this is on Windows 7, your control panel may vary if you are on a different OS. Hope this works for you. :)