PDA

View Full Version : Physics Stops working. Floating Papers...



denney
25th Oct 2009, 19:18
Hey All,

So I recently reconfigured my system so that I'm using my GTX260 as the primary GPU and my old 880GTS as a dedicated PhysX card. I'm running with PhysX on High and AA on 4x and everything else maxed out.

I get acceptable framerates (~ 60), but recently have noticed that after playing for around 20 minutes, physX seems to turn off. ie: the plastic door things in medical no longer move (I just pass right through them), and all the papers/leaves on the ground no longer respond to my movement. Instead they just are floating a foot off the ground.

Does anyone else have this problem? After setting up the dual GPU's I installed the latest Nvida drivers so I thought it might be that. Or I read once that PhysX can detect the current GPU power and turn physX on or off real time so maybe my card is heating up and after 20 minutes no longer able to handle the physx?

Thanks.

deders
25th Oct 2009, 20:20
I've seen the problem where Physx objects just float above the floor, if this happens I restart from checkpoint, usually clears it up. Doesn't happen very often to me.

If this isn't your problem or it happens more often then it could be that your physx card is overheating you could take the side of your case off (and if you can, point a desk fan it it) if it works fine then you may just need to reconsider your airflow.
on the other hand it may be underpowered. what is your PSU? and have you carerfully configured it so all the rails are balanced as best as possible? For instance my PSU has 2 rails, I have 1 dedicated just to graphics power, it has 2 6 pin connectors which I plug in to the first (closest to the back of the PC) power sockets on each card because it draws more power from these sockets than the other 2, which I have connected to the the other rail which also has everything else on. If I plug it in any other way I don't get enough power and my computer will switch itself off when under strain. Your computer may react differently to low power situations.

There was another thread somewhere where someone had a dedicated Physx card and when playing, the screen would go blank, then all the physx would stop working. Slightly different symptoms to what you described but pretty much the same result.

The engine does stop physx objects in mid-air if it detects that there aren't enough free shader cores on your physx card to calculate them without slowing the whole game down. they recommend a 9800gtx+, I'm not sure why the + is needed, its only 148MHz (8%) more on the shader cores, maybe it makes all the difference. as a guideline the 9800gtx+ has 128 cores at 1836MHz, how does this match up to your physx card?
If there is a huge difference i'm sure you could get away with swapping them over so the 260 does the physx work. If you play in XP I'm sure the 320 will have enough grunt to play the game up to 1680x1050.

defaultusername
25th Oct 2009, 20:22
I've never heard of this issue before, but with that rig you should be able to max everything out without problem. Overheating is as good a guess as any, what are your temps?

SCircuit
3rd Nov 2009, 06:15
To fix this problem, disable SLI in the nVidia properties before launching the game. It fixed it for me and my in-game benchmarks improved too! With SLI disabled one of your video cards will be dedicated to Physx and the other will be dedicated to display.

deders
3rd Nov 2009, 09:14
To fix this problem, disable SLI in the nVidia properties before launching the game. It fixed it for me and my in-game benchmarks improved too! With SLI disabled one of your video cards will be dedicated to Physx and the other will be dedicated to display.

that would work if he was actually using 2 identical cards, but i don't think you can SLI a 260 and an 8800