PDA

View Full Version : Scarecrow extreme slow down



Midgar
3rd Oct 2009, 17:48
Hi all, i'm experiencing some technical issues in this most fantastic of games. Everything runs fine until I reach the scarecrow levels. After beginning them the games slows down until it grinds to a complete halt, usually around half way through said level.

Restarting the game generally resorts the issue but is anyone else experiencing it and, more importantly, is anyone aware of a permanent solution?

My rig is:

Windows XP SP3
Intel Core I7 2.66GHZ
3.5MB ram (well 6 but not until i get windows 7)
Geforce GTX 275

This issue is only occurring on the scarecrow levels but it has happened on 3 so far

cyborg34572
3rd Oct 2009, 19:03
well im assuming u have physx turnd on. and during scarecrow levels alot of physx goes on which slows down the game. So i suggest u turn down physx for the scarecrow levels and u can turn them back on after

tenth8sphere
3rd Oct 2009, 19:34
I had a similar issue. Horrible slowdown that was fixed on restarting. Not related to computer specs

SteMot
3rd Oct 2009, 20:47
It's PhysX. Just knock em off altogether and enjoy Batman running at full frames.

ann0x
3rd Oct 2009, 21:32
i had extreme lags in the 2nd scarecrow too, for me it was because of physx.
the scarecrow levels are about the most physx-intensive part of this game, so if it slows down there it's most likely physx related.
just turn physx to "off" while you're there and turn it on again as soon as it's over.

TheChosenOne
3rd Oct 2009, 23:30
It's PhysX. Just knock em off altogether and enjoy Batman running at full frames.

What a dumbass thing to say. His system should run Batman no problems maxed out WITH physixs. Just because you cant play maxed out with physix doesnt mean no one can.

deders
4th Oct 2009, 06:14
I sometimes have this problem. Near the end of the second scarecrow level, when masses of bricks start to come off the wall and fly about, where you have to fight the second lot of skeletons, my framerate drops to around 3fps, even though i've played through this section several times before without any issue on the same hardware. (2x 9800gtx+)

=ColdFire=
4th Oct 2009, 10:42
I have a 8800 GTS, with a 9500gt for PhysX, it slows, but it still very playable, and high PhysX, and high GFX.

Midgar
4th Oct 2009, 10:55
His system should run Batman no problems maxed out WITH physixs.

That was my thinking, If i'm running the game at too high a setting fair enough but i wouldn't have thought i'd be getting such issues on this rig.

It does only seem to happen at these points but it doesn't happen every time... very odd.

Thanks for the suggestion though guys, i'll knock the pyhsx down for those sections - odd that just restarting the game generally sorts it though.

deders
6th Oct 2009, 11:04
Hi all, i'm experiencing some technical issues in this most fantastic of games. Everything runs fine until I reach the scarecrow levels. After beginning them the games slows down until it grinds to a complete halt, usually around half way through said level.

Restarting the game generally resorts the issue but is anyone else experiencing it and, more importantly, is anyone aware of a permanent solution?

My rig is:

Windows XP SP3
Intel Core I7 2.66GHZ
3.5MB ram (well 6 but not until i get windows 7)
Geforce GTX 275

This issue is only occurring on the scarecrow levels but it has happened on 3 so far
what drivers were you using? the 191.03 beta's gave me better performance overall but caused the game to grind to a halt in one place and for the physx not to work properly in another. the new 191.07's are more stable but general performance is lower.

Smashman
6th Oct 2009, 18:21
Personally I think PhysX is a waste of time.
Just run it without.
I played it a bit with PhysX, didn't notice one thing, except FPS drops.

deders
6th Oct 2009, 18:23
Personally I think PhysX is a waste of time.
Just run it without.
I played it a bit with PhysX, didn't notice one thing, except FPS drops.

so you never noticed masses of debris breaking away from the walls and circling around scarecrow? or the paper that burns up in his gaze?

Smashman
6th Oct 2009, 18:26
so you never noticed masses of debris breaking away from the walls and circling around scarecrow? or the paper that burns up in his gaze?

I didn't play the scarecrow bit.
But tbh, I wouldn't have cared that much..
I enjoy games for gameplay not 'Wow' graphics.

cyborg34572
6th Oct 2009, 18:29
I didn't play the scarecrow bit.
But tbh, I wouldn't have cared that much..
I enjoy games for gameplay not 'Wow' graphics.

real gamer right here ^

im the sameway.I could care less about graphics i just want awesome gameplay,Until today i still play the original doom and wolfenstein game's.

deders
6th Oct 2009, 18:38
I didn't play the scarecrow bit.
But tbh, I wouldn't have cared that much..
I enjoy games for gameplay not 'Wow' graphics.

I agree, gameplay should always come before graphics, and for the most part compared to the matured sophistication of the rest of the graphics that are being rendered, some of the physx effects seem out of place, some lessen the realism factor, some make you wonder can there really be that much paperwork just lying about or why would Arkham need flags to promote the Asylum to their own inmates and staff, (if there actually was any competition in gotham, Batman would probably avoid sending supercriminals to Arkham altogether as they seem to escape whenever it's convenient.) and dynamic bog roll is hardly the feature that's on everyone's lips but..... do yourself a small favour, switch physx on just for the scarecrow scenes next time you play, maybe even a bit before.

Shonksta
7th Oct 2009, 13:34
My game becomes a slide show to but only in the 3rd scarecrow bit as soon as the wall starts to tear away, I have a 275gtx and a 8800gt for physx and I run this game maxed out and it runs butter smooth every where else except for this one bit :( hopefully a patch gets put out soon to fix this.

deders
7th Oct 2009, 13:36
My game becomes a slide show to but only in the 3rd scarecrow bit as soon as the wall starts to tear away, I have a 275gtx and a 8800gt for physx and I run this game maxed out and it runs butter smooth every where else except for this one bit :( hopefully a patch gets put out soon to fix this.

I think it's the drivers, when I installed the 191.03 beta's, sometimes the walls either didn't move as they were supposed to or dragged the performance right down. The 191.07's seem to have fixed it, but for me at least overall performance is lower.

Shonksta
7th Oct 2009, 21:40
I went from the 191.03 beta's to the WHQL 191.07's when they came out and still the same thing happens.

lawsie
7th Oct 2009, 22:45
What a dumbass thing to say. His system should run Batman no problems maxed out WITH physixs. Just because you cant play maxed out with physix doesnt mean no one can.

actually, that was pretty dumbass, my system can run it as well but on the 2nd scarewcrow level where the skeletons come, my gasme drops down to around 4 fps, its perfect everywhere else, just that one bit of the game.

Shonksta
8th Oct 2009, 11:31
I just did a uninstall and reinstall of the 191.07 drivers using Driver Sweeper in safe mode etc. and now my game becomes a slide show on all the scarecrow bits, all 3 as soon as the walls break apart. :(!

deders
8th Oct 2009, 11:35
I just did a uninstall and reinstall of the 191.07 drivers using Driver Sweeper in safe mode etc. and now my game becomes a slide show on all the scarecrow bits, all 3 as soon as the walls break apart. :(!

what about going back to the 190.62's? it never happened to me once with those, if that doesn't help then you can pretty much rule out driver issues.

Shonksta
8th Oct 2009, 11:38
I'll give that a go and write back with my results thanks for the reply :)

Zubin5
8th Oct 2009, 12:04
Hi guys.Listen I have a problem with logging in on GFWL.When i launch the game i press the 'home' button.And when i press done it doesn't continue and i can't save my progress.Hence i do have an online account but i just need to download it.Please help

deders
8th Oct 2009, 12:07
Hi guys.Listen I have a problem with logging in on GFWL.When i launch the game i press the 'home' button.And when i press done it doesn't continue and i can't save my progress.Hence i do have an online account but i just need to download it.Please help

you can create an offline account to play the game with if g4wl is being unresponsive

Zubin5
8th Oct 2009, 12:11
I cant do that either

deders
8th Oct 2009, 12:17
I cant do that either

strange, have you tried uninstalling and re-installing the latest version of g4wl?

Shonksta
8th Oct 2009, 13:00
Reverting back to the 190.62 actually made the scarecrow scenes worse so I'm going back to the 191.07's, I also tried just using my 275gtx by its own and the same thing happens :(. The scenes run fine with out Physx so its not a game breaker but still I enjoy having it on for the rest of the game, it ads some really nice details.

P.S Can we please stay on topic, if you want to discuss GFWL issues find another thread on that topic or create your own.

deders
8th Oct 2009, 13:06
Reverting back to the 190.62 actually made the scarecrow scenes worse so I'm going back to the 191.07's, I also tried just using my 275gtx by its own and the same thing happens :(. The scenes run fine with out Physx so its not a game breaker but still I enjoy having it on for the rest of the game, it ads some really nice details.

yeah it is a shame, if its not down to drivers then it must be one of those things like the crashes that seem to be happening with XP users that sometimes works and sometimes doesn't. Strange when you think that computers are digital, work of 1's and 0's and should do exactly as they are told every time.

I've seen this kind of phenomena with other things as well, sometimes after a fresh XP install a particular program would install and run properly, sometimes it wouldn't. I'd be doing exactly the same thing every time, same drivers and everything.

Shonksta
8th Oct 2009, 13:15
Yeah I am using XP 32bit so like you said thats maybe the issue at the moment for me, ohwell hopefully a fix comes out soon or someone finds something to at least help with the problem

omegaferrari
8th Oct 2009, 18:48
This happens to me also but I have a gtx285 ,im playin at 1680x1050 4x aa physx on high ,and on the scarecrow scenes it becomes a slide show, so I decided to play without aa and it runs fine ( just went up to 1920x1200) but I thought my machine could handle more , what's your graphics configuration ? Perhaps not even a gtx285 is good enough for physx on high,my problem is I don't have an sli mobo , do you guys know of any pcie x1 vid card that can run physx (I'm on an ep45-ud3l mobo) maybe a dedicated card for physx is totally required? What benchmarks results are you getting,thanx in advance for the info

deders
8th Oct 2009, 19:28
This happens to me also but I have a gtx285 ,im playin at 1680x1050 4x aa physx on high ,and on the scarecrow scenes it becomes a slide show, so I decided to play without aa and it runs fine ( just went up to 1920x1200) but I thought my machine could handle more , what's your graphics configuration ? Perhaps not even a gtx285 is good enough for physx on high,my problem is I don't have an sli mobo , do you guys know of any pcie x1 vid card that can run physx (I'm on an ep45-ud3l mobo) maybe a dedicated card for physx is totally required? What benchmarks results are you getting,thanx in advance for the info

the thing is that i've run it on my 2 9800gtx+s fine in the past, then for some reason it decides not to work properly, and now i've installed new drivers it's working again, for now. A 285 has nearly as many shaders as I have in total so unless it really need those extra 16, theoretically it should be fine. I've seen reports of people saying that their 280's can handle the game fine but i can't be sure they are talking bout these sections.

Shonksta
9th Oct 2009, 04:05
This happens to me also but I have a gtx285 ,im playin at 1680x1050 4x aa physx on high ,and on the scarecrow scenes it becomes a slide show, so I decided to play without aa and it runs fine ( just went up to 1920x1200) but I thought my machine could handle more , what's your graphics configuration ? Perhaps not even a gtx285 is good enough for physx on high,my problem is I don't have an sli mobo , do you guys know of any pcie x1 vid card that can run physx (I'm on an ep45-ud3l mobo) maybe a dedicated card for physx is totally required? What benchmarks results are you getting,thanx in advance for the info

I've put everything as high as it can go in the games graphics settings including physx, resolution is 1650 x 1080, Vysnc on with triple buffering forced in the control pannel, AA x16 and AF at the games default of x4. My Benchmark results are the same each time I run it:
Max = 60
Min = 33
Average = 56

Zubin5
10th Oct 2009, 08:37
Hey can anyone tell me how to make an offline profile without actually going on GFWL.

deders
10th Oct 2009, 08:39
G4wl has to load in order for your savegames to work but if you press home and sign out, you should then get the option to create an offline profile.

Zubin5
10th Oct 2009, 08:39
yes i have uninstalled and re-installed it about 10 times.

Zubin5
10th Oct 2009, 08:40
Look i can,t even get my Online profile.

deders
10th Oct 2009, 08:41
Look i can,t even get my Online profile.

sorry i've just read what you put further back in the thread.

Zubin5
10th Oct 2009, 08:43
What?

Zubin5
10th Oct 2009, 08:45
Can u just plz help me?

deders
10th Oct 2009, 08:47
Can u just plz help me?

It sounds like your version of g4wl is broken or has issues with your computer. Are you sure you have the latest version?

Zubin5
10th Oct 2009, 08:48
Yes 3.0

deders
10th Oct 2009, 08:49
do you have any other games that need g4wl?

Zubin5
10th Oct 2009, 08:51
Yes Gears Of War,GTAIV and James Bond Quantum Of Solace

deders
10th Oct 2009, 08:53
ok great, now you could try accessing your g4wl in one of these games and creating an offline profile in there. If g4wl doesn't work in any of these then you should probably take your issue up with microsoft.

Zubin5
10th Oct 2009, 08:55
i did all of that

deders
10th Oct 2009, 08:55
i did all of that

so you have an offline profile on your computer now?
or do you have the same issue with every g4wl game?

Zubin5
10th Oct 2009, 08:56
actually no

deders
10th Oct 2009, 08:57
so is g4wl working as it should in the other games?

Zubin5
10th Oct 2009, 08:57
yes but i have this issue in all the games

deders
10th Oct 2009, 08:59
yes but i have this issue in all the games

ok so have you checked your firewall settings to make sure g4wl actually has access to the internet? I remember once installing Internet Explorer 8 and finding that it hadn't allowed itself through the windows firewall, stupid microsoft.

Zubin5
10th Oct 2009, 09:03
well it was ticked and I removed it

deders
10th Oct 2009, 09:08
if it's the windows firewall you are talking about then it should be ticked (are you in XP, Vista or 7?). have you removed it now or just the tick? Is arkham asylum ticked too?
have you checked your computer for spyware, sometimes this can interfere with internet traffic, I'd do a scan with Ad-Aware.

deders
10th Oct 2009, 09:10
one way to rule your firewall out of the equation is to disable it and see if g4wl works. then re-enable it.

Zubin5
10th Oct 2009, 09:13
XP.The Tick.Batman is yes i removed the tick.How to check it for spyware

deders
10th Oct 2009, 09:17
are you asking me how, or saying now to check it for spyware? the keys are very close together.
have you tried turning the firewall off completely and seeing if you can get it to work? that would eliminate the firewall from the problems, remember to switch it back on again once you've finished testing.

Zubin5
10th Oct 2009, 09:20
Im using XP. i have removed the tick. batman arkham asylum was ticked and i removed the tick.How to make ur antivirus not block spyware

deders
10th Oct 2009, 09:20
What country are you living in? is G4wl supported in your country?

Zubin5
10th Oct 2009, 09:21
I used to use an online profile and suddenly this happend and i live in INDIA

deders
10th Oct 2009, 09:28
Im using XP. i have removed the tick. batman arkham asylum was ticked and i removed the tick.How to make ur antivirus not block spyware

1: you want them to both be ticked, so it allows them to access the internet

2: try turning the firewall off completely and then see if it works as it should

3: download Ad-Aware and use it to do a quick scan (once you've updated it) and see if that helps.

you don't want to make antivirus not block spyware.

Zubin5
10th Oct 2009, 09:45
But i already have an antivirus

deders
10th Oct 2009, 09:51
But i already have an antivirus

Antivirus and antispyware are slightly different things. Ad-Aware will detect things that antivirus doesn't and vice-versa. you'll be suprised as to what you might find.

deders
10th Oct 2009, 10:08
But i already have an antivirus

now i see what you mean, Ad-Aware won't interfere with your antivirus as it doesn't has a virus vault or anything that your antivirus will detect. I have Ad-aware, AVG and Spybot S&D on the same machine with no problems.

Shonksta
12th Oct 2009, 12:33
Just wondering if anyone has any updates on the scarecrow framerate issue, any improvements/fixes?

Abyss12321
12th Oct 2009, 21:27
Hi guys,
i have the solution at your problem:
just go to :
-Documents\Eidos\Batman Arkham Asylum\Bmgame\Config\

localize a file name "BmEngine.ini"
make sure that this file is on "read only"
ans find the command :

bPhysXuseGRB=True and set this command in bPhysXuseGRB=False

Don't forget to set "file read only" for the file save and don't change your BmEngine.ini
Make sure the file as save it !

and enjoy, in the scarecrow level is ok, no lower framerate

:wave:

deders
12th Oct 2009, 21:50
Hi guys,
i have the solution at your problem:
just go to :
-Documents\Eidos\Batman Arkham Asylum\Bmgame\Config\

localize a file name "BmEngine.ini"
make sure that this file is on "read only"
ans find the command :

bPhysXuseGRB=True and set this command in bPhysXuseGRB=False

Don't forget to set "file read only" for the file save and don't change your BmEngine.ini
Make sure the file as save it !

and enjoy, in the scarecrow level is ok, no lower framerate

:wave:

is that supposed to turn physx off?

Shonksta
13th Oct 2009, 02:20
Hi guys,
i have the solution at your problem:
just go to :
-Documents\Eidos\Batman Arkham Asylum\Bmgame\Config\

localize a file name "BmEngine.ini"
make sure that this file is on "read only"
ans find the command :

bPhysXuseGRB=True and set this command in bPhysXuseGRB=False

Don't forget to set "file read only" for the file save and don't change your BmEngine.ini
Make sure the file as save it !

and enjoy, in the scarecrow level is ok, no lower framerate

:wave:

It worked!!! :D Thank you very much!!! Abyss for your help even the restart/die crash has stopped happening thx to your fix :thumb: and to deders no it does not turn Physx off as far as I can tell nothing has changed visually, which brings me to another question lol what does setting "bPhysXuseGRB" to false actually do?

deders
13th Oct 2009, 09:30
Awesome, will try it later.

omegaferrari
13th Oct 2009, 16:22
wow , did it worked on all the scenes , what does that change on the .ini does? i will also try it as soon as i get back home , i installed the latest audio drivers for my old audigy 2 zs and upgraded to the latest nvidia drivers , and that seemed to help , but im gonna try the .ini fix , please post guys if you tried it and what gpu congfig are you using(single or sli and which card)feedback ftw.

Zubin5
14th Oct 2009, 10:44
Can anyone tell me how to enable Nvidia PhysX in Batman Arkham Asylum.

deders
14th Oct 2009, 10:49
Can anyone tell me how to enable Nvidia PhysX in Batman Arkham Asylum.

ok, you need the 1.1 patch from here: http://forums.eidosgames.com/showthread.php?t=96538
then open bmlauncher (in the games' install directory) the physx option should be at the bottom.

Zubin5
14th Oct 2009, 10:50
deders can u help.Well the problem is eventhough i have the V1.1 Patch the option is not there in the launcher

Zubin5
14th Oct 2009, 10:53
ok thx i think the one I downloaded is from a pirated website so thx.

deders
14th Oct 2009, 10:54
deders can u help.Well the problem is eventhough i have the V1.1 Patch the option is not there in the launcher

It doesn't say anything at all at the bottom of display settings? where did you get the patch from? does it definitely say 1.1 when you load the game up? what is your gfx card(s)? do you have the latest physx installed?

deders
14th Oct 2009, 10:55
ok thx i think the one I downloaded is from a pirated website so thx.

oh right nevermind then

Zubin5
14th Oct 2009, 11:10
the thing is i have the latest VGA Driver (9400 GT) and it worked smooth in the demo with normal Physx and the latest Physx driver.

deders
14th Oct 2009, 11:12
where did you download it from? tbh, i doubt a 9400gt will work smoothly for very long with physx on

Zubin5
14th Oct 2009, 11:15
didnt u understand VGA(Video Game Acceleration) and from Filefront.com and when i went on it my antivirus said all corrupted

deders
14th Oct 2009, 11:21
didnt u understand VGA(Video Game Acceleration) and from Filefront.com and when i went on it my antivirus said all corrupted

VGA = Video Graphics Array, I thought I understood but now I don't understand what I'm not understanding.
when you say filefront i take it you mean the patch? I meant where did you get the game from?

Even the official patch got falsley identified as a trojan in my Vista 64 version of AVG. when I downloaded and scanned it in XP with the same updated AVG there was nothing.

Zubin5
14th Oct 2009, 11:22
Well i,m in India so Glasgow Computers.

deders
14th Oct 2009, 11:26
Well i,m in India so Glasgow Computers.

once you are sure you have a legal version of the game, download the 1.1 patch from the link I gave you above.

Zubin5
14th Oct 2009, 11:28
I do have the legal version and i realised the patch u gave me is totally awesome and i am already downloading it

Zubin5
14th Oct 2009, 16:34
Thanks for the update i got the PhysX option.Thanks

omegaferrari
14th Oct 2009, 20:18
Back to topic, anyone else got the slowdown issue solved with the bmgame.ini fix ?? I'm still two days away from my home Pc and was wondering if it worked for you guys?
Thanx and the first post of the thread what happened, did you guys have no more slow downs?

deders
14th Oct 2009, 20:21
not tried it yet, been playing a few other things so it doesn't get too repetative, will let you know as soon as i try it.

iceman0124
15th Oct 2009, 05:48
For me my slowdowns occur on Bane, scarecrow, ivy etc if i've been playing for awhile, my GTX260 will downclock (verifyable with EVGA prescion) and requires a restart to get the clocks back to normal, even when I dropped my OC this problem still pops up from time to time and BAA is the only game I've played that triggers it. Core will drop to 400 and lock, shader and mem pretty much half there normal speeds.

Shonksta
15th Oct 2009, 11:15
Back to topic, anyone else got the slowdown issue solved with the bmgame.ini fix ?? I'm still two days away from my home Pc and was wondering if it worked for you guys?
Thanx and the first post of the thread what happened, did you guys have no more slow downs?

Since using the bmgame.ini fix I haven't had a slow down yet and I've played all three scenes a fair bit to double check and I also haven't noticed anything visually different and my Physx is on high. For me this also fixed the restart/die crashes :D

omegaferrari
18th Oct 2009, 14:27
still have the same problem onthe scarecrow scenes still huge slowdowns!:mad2:, any other options that might help , what is wrong maybe we all need a separate physx card , any good pcie x1 cards out there you can recommend? i only have one pcie x16 slot which im using roght now,other than that, i thought my card was good enough for this scenes.

deders
18th Oct 2009, 14:36
It's not the configuration. Sometimes I get the slowdown and sometimes I can play it smoothly on the same scenes. I'm using 2x 9800gtx+'s so if i can play it smoothly with 256 stream processors, you should too with 240. It's like the crashes some of us are having, sometimes it crashes, sometime it works.

omegaferrari
20th Oct 2009, 19:21
so now i dont know if im the only one that keeps getting the slow downs with physx on high, im only playing in 1680x1050 with 4x aa that is not that high,right? , no motion blur or ambient occlusion ,, can you show me a video (maybe using fraps) of your second scarecrow scene , with a single card (or using both cards) , or do i really need a second one for physx , i wasnt thinking about an upgrade but now... i dont know. please some help or videos, or maybe im using the wrong driver, the latest whql, maybe i should go back to the 190.62 how are they for you?

deders
20th Oct 2009, 19:38
I would have thought you should be able to run it fine with your gfx card, the only thing that is really going to slow it down is the Physx setting, but theoretically your card should handle it (could even probably run it with 8xAA), it shouldn't bring it right down to a crawl like it has been doing with all of us whether we have seperate cards for physx or not.
It may be worth waiting to see what happens with hardware physics with directX 11 as to whether you should buy a seperate card or not, It may not be worth it just for a few extra frames per second in a few scenes in 1 game, especially when your problem is most likely due to a random bug.
Physx are calculated on the shader cores in your gfx card, something you have plenty of already.
I find for my setup the 190.62's run better in vista and the latest 191.07's run best in XP. but my gfx chip is of a previous generation so it may not apply to you. I have suffered this major slowdown on all 3 revisions of drivers, and I can safely say i've had it working smoothly on everything but the beta's, so it may be a case of coming back to the game and trying again at a different time.
Myself, I don't understand why something that runs on 1's and 0's would be so temperamental but so far, like some of the crashes people are getting i think it's down to luck.

omegaferrari
21st Oct 2009, 07:22
now this is just wrong!! , i tried disabling physx on my nvidia control panel i disabled it so the launcher bmlauncher tells me it will have bad performance , and all the sudden it runs a little better than with phsyx enablend on the gpu whats wrong with my setup , or card !nvidia and devs please help , maybe its not running the physx on the gpu , any ideas? because it runs almost at the same speed on all the game (more badly in the scarecrow scenes , ) please help maybe someone has a command or something.

Stein7922
21st Oct 2009, 22:31
I've got a problem with the 2nd Scarecrow level. When you are on that one ledge hanging and you go around and try and drop off. Batman won't drop. Just keeps hanging there. It's right before you go thru the gate that heads to the bat signal.

deders
21st Oct 2009, 22:34
I've got a problem with the 2nd Scarecrow level. When you are on that one ledge hanging and you go around and try and drop off. Batman won't drop. Just keeps hanging there. It's right before you go thru the gate that heads to the bat signal.

completely different issue from the thread topic, i had difficulty with this though, it's a case of getting far enough along on the ledge and pressing either space or left ctrl (can't remember which one) at the right point. can be fiddly but not impossible.

omegaferrari
22nd Oct 2009, 14:13
still cant fix this , no help at all it runs like a crawl , any help any news , anyone using a single card cant handle physics on high in the scarecrow levels , when i change drivers versions and start the second scarecrow scenes it works well , so could it be a driver issue??
please help!. any devs out theres , anyone???

omegaferrari
23rd Oct 2009, 18:41
tried fraps it gives me 6 fps at the moment of the rigid bodies appearing in the scarecrow scenes , without the bmengine.ini fix , 11fps minimum on the scarecrow scenes with the fix, am i getting very low fps o that scene? every article says they get 24 min on the same card as mine , any gtx 275/280/285 single card users that have the same problem with physx on high? all those who posted here, have you guys solved it already , should i get a second card so my minimum dont go as low?
please help me .
any ideas?

deders
23rd Oct 2009, 22:24
does it slow down that badly in every scarecrow scene?

omegaferrari
24th Oct 2009, 01:23
Yes , on all three scenes, any ideas I have tried everything what do you get on single card can you post a video with one card and two cards or results please? I would like to know what else I can do , it runs great on normal , I'm running the steam version

deders
24th Oct 2009, 01:32
I could post some results for one or 2 of the scenes but my configuration differs from yours, I would expect a major bottleneck if I only used one of my cards to handle both the rendering and the physx as i'm using 9800gtx+'s with only 128 stream processors on each card. your card is the fastest single card of the generation up from mine with 240 sp's, nearly as much as mine put together. you need someone with a 285 and an additional physx card, at least a 8800/9800gt, preferably more to show you what they get through those scenes before you could make an informed judgement.

omegaferrari
24th Oct 2009, 02:45
Please post some results just to see if getting 11 fps is that bad because of my single gpu, and upgrade, or if it is a bug so I don't upgrade , if even with two cards it won't work, I'm using winxp

deders
24th Oct 2009, 05:20
Please post some results just to see if getting 11 fps is that bad because of my single gpu, and upgrade, or if it is a bug so I don't upgrade , if even with two cards it won't work, I'm using winxp

Ok, after some extensive benchmarking I have some Interesting yet still slightly confusing results.
All benchmarks are from the 1st scarecrow scene. For each run I exited the game to desktop and started again. If it slowed to a 4fps crawl I would restart the computer.

Tests 1 and 5 start from the initial backup savegame starting just as you exit the lift onto the floor. All others were run from the save that was subsequently made, where the game first becomes 2.5d just after the FMV with scarecrows giant hand)

1st run with both cards, I encountered the bug that made the game slow down to 4fps as soon as the floor started to break away.

2nd run with both cards, after a reset, worked fine and didn't dip below 30fps

3rd run, 1 card disabled in device manager, BSOD

4th run, 1 card removed completely, same savegame ran smoothly but with vastly less debris flying around, stayed at around 25fps

5th run, 1 card, renewed the savegame from the initial backup, the gameplay as a whole was much slower, running at around 14fps until it got to the part where you turn the first corner in the 2.5d bit and both walls start to break away, then it was around 11fps, still with much less debris.

6th run, slow to start with like the last run, and as soon as I got round the 2.5d corner again it slowed to 4fps, like it did in the first run but with much less debris

All runs after this resulted in either BSOD's or CTD's when I tried to load the game, each blaming the nvidia driver. These cleared up as soon as I put my second card back in.

So what have we learned?

When the game detects that there aren't enough Stream processors free to handle the physx, (when I take half of them away by removing a card) it reduces the amount of calculations that need to be done to compensate for performance, often resulting in papers that just stop animating in mid air (as Eidos have informed us) or in this case bricks that disappear instead of flying away. This is different to the bug that brings things to a crawl because all the objects are still there, its just not working as it should. Tests 1, 2, 4 and 6 prove this.

What is confusing is the overall difference in performance I got when I used the first savegame again for test 5. The overall performance for normal sections of the game was reduced, i've never seen this before, (even when running the cards in SLI instead of seperately the performance was slower but jerky). This time it was smooth but less than half the normal speed. Also the behaviour didn't change when it got to the 2.5d section when in the previous benchmark (4) it stayed at around 25 fps, even when the heavy physx got involved as I turned the corner. This time I lost another 3 fps but still it wasn't the same as the bug that makes everything crawl at 4fps.

The only difference between the 4th and 6th runs is the 4th came from a savegame that started off running with 2 cards. The 6th savegame was created from the 5th run, with only one card. Which implies that either there is something stored in the savegames that is left over from previous sections, or performance levels are random. (Any comments form developers that can shed light on this would be helpful). the fact that It slowed down to a crawl again I think is the bug that affected the first run, and a seperate issue.

Another bug i've noticed sometimes, but not in these tests, Is even though a few of the bricks break away, 90% of them stay where they are, but scarecrow can still see you through them, as if they weren't there. someone else noticed this when they fell through the floor near the beginning because it looked like the floor was still there.

Another slightly unrelated issue someone has with a 295 and a seperate 9800gt for physx is that after a while the screen will go blank for 3 seconds and when the picture comes back all physx related objects have disappeared.

Ok, so how does this apply to you?

I would say that if you can play most of the game at 30fps+ and it only slows down when the bricks break away then you are encountering the bug and getting an extra card for physx won't help. All I can suggest is to restart the entire computer and try again.

If you were running the whole thing on a single 192 shader 260GTX and the game was running smoothly, I predict you would get a slight reduction in the amount of debris that was flying around (not as much as mine) but it the framerates would still be fairly decent.

If on the other hand perfomance throughout the game is poor, making you play large sections in slow-mo, then a seperate Physx card will help you. The absolute minimum I would recommend for this would be a 9800gt or 8800gt (both pretty much the same card).

omegaferrari
24th Oct 2009, 13:46
thanx for the testing and results , so i guess its a bug and it only dissapears when i change drivers and dont restart the computer, weird stuff ; so , i guess we will have to wait for a patch or new drivers , thanxs a lot and if you find a fix for the bug , please post it , i dont know if any other people are having this problem?

deders
24th Oct 2009, 13:49
thanx for the testing and results , so i guess its a bug and it only dissapears when i change drivers and dont restart the computer, weird stuff ; so , i guess we will have to wait for a patch or new drivers , thanxs a lot and if you find a fix for the bug , please post it , i dont know if any other people are having this problem?

will do, although i found the opposite true in my case, I had to restart the computer to make the bug go away, and It's happened to me on 2 out of 3 drivers i've used, it could be drivers or it could be the game. I think a few people are having the problem.

omegaferrari
24th Oct 2009, 14:46
could it be my os? what are you using , vista or windows 7?just a thought

deders
24th Oct 2009, 15:22
I'm using XP, i've tried it in Vista64 on the same machine but the performance is much better in XP. Saying that the Vista version has never crashed bit i've not played it enough in Vista to notice if these bugs are present.

I see what you mean by not restarting but unfortunately it doesn't work like that, sometimes it will play smooth, then the bug will develop and once it's there it won't go away until you restart.

omegaferrari
24th Oct 2009, 16:49
ok then so i guess its gonna be 1920x1200 4xaa but physx on medium(normal) for now, thank you, any news you get on how to solve this appreciated. thanx for all the info.

eidos please solve this!we got the hardware for your game now let us play it 2the way iots meant to be played" (yeah right)

omegaferrari
16th Nov 2009, 19:29
ok deders heres some news!!
i downloaded the file batman_TU_V1.1_EFIGS.exe file
and had it run, it applied to my steam version somehow, and now when i got to the scarecrow first scene the slowdown is gone and i can play , with only the lowest framerate being 25 fps in fraps. so everyone ,if you have the STEAM version of batman download the update anyway!
good luck! this worked for me gonna check some more scenes , anybody has a saved file or level select .ini for all the scenes? or the third scene any level select ini ? please post them

deders
16th Nov 2009, 22:05
Glad you got it working, but i'm willling to bet that it has more to do with random luck than which patch is installed. I also have the same patch and for me it is down to luck.
No one elses save file will work on your machine thanks to g4wl.