View Full Version : Commandos 2 MP Issues

20th Sep 2009, 14:39

My friend and I are trying to play C2 online with Vista rigs.

We're running the game through Hamachi and after a few initial but painless issues we managed to connect and play through the first training mission just fine. As soon as the mission ended however, the game dropped back to the main menu. This struck me as odd as I seem to recall it going back to the lobby or mission select but it's been many years so I didn't think anything of it.

I set up another game with the next training mission but this time he couldn't connect. He tried connecting to me over TCP/IP Internet and vice versa. We even tried connecting over a LAN since that's the purpose of Hamachi and whilst he couldn't see me I could see him but still couldn't connect.

I've gone over every thread I can find here related to C2 and MP and I've tried opening the ports suggested (2300-2400 and the other one) but nothing works. We've checked every network and firewall setting we can think of and every variation of him serving, me serving, Hamachi's IPs or our main IPs. We've tried different compatibility modes but that just seemed to make the game more unstable. Nothing works and we constantly get a connection error. I even checked to see if we could play the first training level again but no joy. We can see each other but we just can't connect.

This is driving me insane, especially since we've already managed to play a successful game.

If there's any secret technique, voodoo ritual or Internet magic trick out there that makes the game work then please let us know. I really hope this is just some stupid oversight on our part and I'll be happy to call myself an idiot if this is the case. I just want to play the game again!

Thanks for any and all help,