PDA

View Full Version : Realtek Audio Support



wekwek
19th Sep 2009, 10:23
I have a realtek sound card and I am experiencing random crashes with both physx on and off. I therefore think that my soundcard is causing the very random crashes. Hope eidos can release a fix for this ASAP. Thanks.

capable heart
19th Sep 2009, 10:33
I have a realtek sound card and I am experiencing random crashes with both physx on and off. I therefore think that my soundcard is causing the very random crashes. Hope eidos can release a fix for this ASAP. Thanks.

What evidence makes you think the sound card is the cause of the crashes?

wekwek
19th Sep 2009, 10:39
whenever i disable my audio driver, the game does not crash. i hope that is enough.

bbb
19th Sep 2009, 10:52
There is a memory corruption bug in the realtek drivers so it's quite likely that they're the cause.

If you use Windows XP, try turning down the hardware acceleration (there are more details in the readme). This should fix it for XP but Vista doesn't have that option.

Other than that, try out the latest realtek drivers. They released some new ones recently which seem to have improved the situation for some people.

wekwek
19th Sep 2009, 11:25
too bad i'm using vista. tnx for the tip regarding the latest realtek drivers. will try that one out and let you know if it works. thanks!

Rockatansky
19th Sep 2009, 11:44
too bad i'm using vista. tnx for the tip regarding the latest realtek drivers. will try that one out and let you know if it works. thanks!

Have you tried updating your drivers?
RealTek released some new drivers on 14/9/09

wekwek
19th Sep 2009, 12:06
i've just updated my realtek drivers as adviced by bbb and looks like the updated drivers are ok! thanks again bbb. finally i can play with no crashes.

Mythdracon
19th Oct 2009, 02:18
Where can I download RealTek audio driver updates? The official site is confusing, and I can't be sure if the updates apply to my sound card.

I've been having crash issues as well, it randomly happens after a few minutes, sometimes shortly after starting, sometimes when I'm near the end of a challenge. It's very irritating. One solution people posted was to disable sound, but I'd rather not play the game mute. SO there has to be some way to fix the issue.

Also, how do I turn hardware acceleration down? I'm rather horrible with computer tech so I have no idea how to do such things. :nut:

drache
5th Nov 2009, 21:42
I'm having crash issues also. i run a Radeon 4800, with AMD athalon 6000+ and have 4GB of memory, with a realtek HD audio device on vista (32 bit) my Game crashes randomly,

used to be able to play for 10 minutes on highest graphics b4 it crashed.
or play for 40 minutes on lowest settings b4 crash.

i updated my drivers for my graphics card.

now i can only play for 10 minutes on lowest or highest graphics b4 crash.

i clicked (update drivers) on my sound card. and it said i have the most recent version (but vista told me that, so i dont trust it). (I'll try the link above for sound drivers when i get home, I'm at work right now)
i reinstalled the game, and i still get crashes after ten minutes (or less).

IM SO FRUSTRATED!!!! i love this game, and i NEED a fix for this issue!

oilsfan
1st Jun 2010, 10:55
I also am experiencing the same problem. As soon as the start screen appears the audio stutters, pops, crackles and is choppy. I have a realtek sound card so I know that is the problem but the updated drivers were no help for me. I also updated my graphic card drivers and still the problem remains. Any help would be great as I am about to return this game, which looks like such a loss for me.

fenrirswrath
20th Jul 2010, 05:34
So there is still no solution to this problem?

fenrirswrath
24th Jul 2010, 01:12
Dear Customer, Regarding your request for console support. Please find your answer below.
We appreciate you bringing this to our attention. While we cannot immediately offer a resolution, it will be forwarded to the appropriate party. Unfortunately we do not have further suggestions for you at this time, you may want to look into trying a different sound card if other players are running into similar issues with that card.

robertadeniro
1st Aug 2010, 07:16
I have realtek audio on my evga 780iFTW MB but no problems yet..
I hope you find a solution..good luck