PDA

View Full Version : Left stick controlls STILL inverted, option doesnt work!



brodbeck
18th Sep 2009, 12:14
The controlls are still inverted, the new "Invert backward/forward" option doesnt work!

Another thing is that I'm pretty sure that it was promissed that ALL buttons would be assignable in the final version, this is not the case as far as I can tell!

Please patch this!

Rockatansky
18th Sep 2009, 12:26
That's strange because I downloaded from STEAM this morning, received V1.1 and when I launch the game I get the option to go into Settings and I've been able to change the Invert Forward/Backward from Normal to Inverted. It did change the functionality of my controller but I must admit it was a 360 controller I had plugged in.

bbb
18th Sep 2009, 13:27
Did you download the game and patch from Direct2Drive? There seem to be some issues with it not applying the patch correctly which could explain this issue.

brodbeck
18th Sep 2009, 13:33
I bought it on amazon, received it today, installed the game from dvd, installed patch via GFWL, checked before and after the patch....its not working!

I have a Logitech Dual Shock pad! I wont start playing like this, I dont want to ruin the game for myself!

Rockatansky
18th Sep 2009, 13:42
Do you mean Logitech Dual Action Gamepad (http://www.logitech.com/index.cfm/441/288&cl=gb,en&hub=1?selectedcrid=441&selectedcid=288)?

GhostMatter
18th Sep 2009, 13:50
Use this (http://www.tocaedit.com/IB/index.php?automodule=downloads&showfile=4) and be sure to copy dinput8.dll(to prevent detection of the pad as 3rd party) in the Binaries folder along with the two other files mentioned in the readme(xinput1_3.dll, xbox360cemu.ini).

If you want to put the controls like the SNES(x,y,a,b placed differently) ones, just edit xbox360cemu.ini and switch the numbers between the two buttons you want inverted.

brodbeck
18th Sep 2009, 13:56
@Rockatansky:
Yes, thats the one I have!

@GhostMatter:
Thanks, I'll try it, already tried the logitech profiler, that didn't work either!

This should simply work from the getgo!

GhostMatter
18th Sep 2009, 14:03
Worked great for me and less setup than editing the ini from the game. I had been using it for Braid fine. I have the Dual Action too. Didn't work at first because it conflicted with my normal controller so I added dinput8.dll to hide the Dual Action.

Only thing is the Xbox button placement is confusing after years of SNES so I had to move 4 numbers around. Really easy.

brodbeck
18th Sep 2009, 14:18
So now I've copied dinput8.dll and xinput1_3.dll to the "Binaries" folder, the XInputTest runs perfect, buttons are placed exactly where they should be, I run Arkham Asylum and...


no controlls at all! I'm stuck at the "press start" screen! Tried to rename the xinput, but only 1_3 works!

brodbeck
18th Sep 2009, 14:21
Wait, forgot to copy the xbox360cemu.ini, now it works!


YOU'VE SINGLE HANDLY SAVED MY DAY MAN!!!! 100000xTIMES THANK YOU!!!!!!

GhostMatter
18th Sep 2009, 14:31
Great, happy it works!

Just a note for those still trying: if you activated the inverted control stick option and it doesn't work, the option may be conflicting with the 360 controller.