View Full Version : XBOX 360 wireless controller problem

18th Sep 2009, 03:55
Hi Everyone,

I installed this game on Tuesday night and played it for 3 hours with my xbox 360 wireless controller (gamepad for short). I have an XBOX 360 wireless gaming receiver for windows --> that's how I get the controller to work.

On Wednesday I tried to play the game again -- but I couldn't get my gamepad to work! If I press the center button then the Windows Live Bar comes up and i can move around from left to right just fine using the gamepad. But when I make the Windows Live Bar go away and get back to the game, my gamepad does not work. Press the start button - nothing. Try to move around the cursor and it just sits there mocking me until I use the mouse.

I tried switching USB ports -- that didn't work.
I tried rebooting -- that didn't work.

Here are two kickers:
1) Sometimes when I have the Windows Live Bar up I can see two icons on the upper left side of it. One is the left arrow and the other is a House (home). Sometimes those icons will change into B and Y and then quickly change back to the arrow and house.

2) Sometimes, by some weird fluke I can actually start the game and on the title screen I can press the Start button and the gamepad appears to work: icons come up for the B and A keys allowing me to go back and forth through menu options and when I press those buttons they work. BUT when that happens windows live won't let me sign in and the game tells me that if I continue to play then I can't save any games.

I know my gamepad works (I checked it through the control panel),
I know it isn't out of batteries.

If anyone has a solution then please help me out. I don't want to keyboard + mouse this game because there seem to be lots of controls (it's years ahead of GTA).

I can use the Pinnacle Game Profiler and the game will work fine, but I'd rather not do that because the on screen prompts will always be misleading (press the E key for this, wait, what did I map that to again?).

OS: Windows Vista 64-bit
I think that's all I need to post. If anyone needs more info then just ask me.


18th Sep 2009, 16:54
I have the exact same problem, i installed the demo a couple of days ago and used the 360 controller.
now i have bought the game, the controller doesn't work except for the center 'live' button - i know the controller works fine, as it responds in the live menu, and in my other games... if anyone has a fix it would be much appreciated.

18th Sep 2009, 20:36
http://www.microsoft.com/hardware/download/download.aspx?category=Gaming&type=Gaming&sku=JR9-00001 go here and download the drivers and install them. try that. It worked for me. hope that helps

18th Sep 2009, 22:23
cheers for the tip inzane, unfortunately it didn't work for me

19th Sep 2009, 02:02
It didn't work for me either. Thanks anyway.

22nd Sep 2009, 14:37
suma - instead of turning the controller on before you start the game, turn the controller on at the 'click to start' screen, this actually worked for me just now - hope this works for you too

26th Sep 2009, 09:25
Has anyone solved this problem yet? I've contacted Eidos Support about it but I'm not getting a reply. They must be busy and this issue probably isn't a priority.

I'm running a wireless XBOX 360 controller for Windows on Windows XP. All drivers are up to date and I've tried absolutely everything suggested on these forums. The controller works fine in all other games.

Anybody got any ideas?

28th Sep 2009, 08:12
I've solved this problem now. I've got an XBOX 360 controller and a Logitech cordless rumblepad connected to my system. I deactivated the Logitech controller in the Device Manager, and now the game recognises the XBOX 360 controller.