View Full Version : Can't even start the game.

16th Sep 2009, 20:09
Whenever I try to start the game I get this error from .NET Framework.

Could not load file or assembly 'Microsoft.DirectX.Direct3D,
Version=1.0.2902.0, Culture=neutral,
PublicKeyTowken-31bf3856ad364e35' or one of its dependencies. The
system cannot find the file specified.

Does anyone know what is going on here? I have uninstalled and redownloaded both .NET Framework and Directx 9.0c (I am using XP for now). Nothing is getting rid of this error message.

Please help

P.S. I have also made certain that DirectX and Direct3D are working. I checked my Dxdiag to make sure Direct3D was enabled and used the test option there too.

16th Sep 2009, 21:23
Check the readme file and the Support folder on the DVD for a workaround for this issue.

Alternatively you can download the Title Update (links have been posted on this forum or search for it on google) which I believe fixes this issue.

16th Sep 2009, 23:08
Did not work. :(

I have the game through Steam from the NVIDIA free give away if you purchased a video card recently.

17th Sep 2009, 03:37
I really need help with this issue. I've tried reinstalling the game and all the programs associated with this error message. Nothing is working.

17th Sep 2009, 09:47
Do you have the Support folder if you have it from Steam? If not, have you seen the thread about copying in the ini files to fix a similar issue? This is a crash in the Launcher config program, not the game.

You could also try running Binaries\BmStartApp.exe as I don't think Steam provides a link directly to the game.

17th Sep 2009, 09:58
Steam dont seem to supply that support folder.. There is a thread on here that explains how to get it to get into the game. Note if first time running the game will always try and launch the launcher to configure settings for first play.

19th Sep 2009, 05:54
I have the same problem as the OP, so any help would be appreciated.

I also downloaded the game from STEAM and tried changing the configuration files.

19th Sep 2009, 06:05
triatom, i eventually figured it out on my own after Eidos support sent me to Steam, who sent me back to Eidos.... I said screw that... I'll figure it out on my own.

Basically there is an issue where the correct version of DirectX needed for the game is downloaded, but not installed. You have to go and find this file. I have Windows XP and this was the path


In the DirectX folder is a burried file called DXSetup. Click on it and follow the instructions.

If you put your Steam folder somewhere other than Program Files you are going to have to find it. Also, the path to the folder/file may be a little different for Vista.

19th Sep 2009, 07:20
Awesome! Thanks a lot oseven :) that fixed it

19th Sep 2009, 07:51
Also for any directx problems, you can go to the microsoft site and download the latest directx it's called the directx end user runtimes web installer.

Never had a problem myself as games should install the components of directx that they need.

19th Sep 2009, 23:38
Awesome! Thanks a lot oseven :) that fixed it

Enjoy the game :D!