View Full Version : Problem with Keyboard Controls

16th Sep 2009, 17:01
I am enjoying the game a lot! However, I notice that when I crouch with left ctrl and then move around a bit, especially run or use the space bar in any way, the game will not let me move after coming up from a crouch. Also the game makes a repetitive beeping noise when this happens.

I have also been unable to open vents that are located on the floor. I can crouch, but when I hit space nothing happens.

If you could please look into this I would be very grateful.

16th Sep 2009, 17:21
You have to continually tap the space bar until Batman rips the vent off.

16th Sep 2009, 17:27
Most keyboards have got certain combinations of keys that can't be held at the same time, and the combinations are different for different keyboards. It's possible that your keyboard doesn't support (say) left ctrl + A + W + space, and the keydown/keyup messages aren't behaving as they should.

Try remapping some of the keys?

Another possibility is that windows is treating the held keys as something special - for instance holding shift in some circumstances will turn on stickykeys. Depending on what exactly is happening, that could cause the beeping as well. Again, remapping *might* help...

16th Sep 2009, 18:06
Yeah - I tried tapping it, but it was sort of a no go.

How do you remap keys in Arkham Asylum? Thanks!

16th Sep 2009, 18:32
Run the Launcher. For the retail box, either:
XP - click through the start menu and click Launcher
Vista - click to the Games menu, right click the Batman icon and select Launcher

For the D2D and Steam versions, I'm not completely sure how to start the Launcher. You might have to explore to the binaries folder and run it directly/

16th Sep 2009, 18:34
Nice fixed the problem! Thanks guys!

18th Sep 2009, 13:54
At me here what question
During game sometimes capture appears in structures and if to press capture "F" that batman departs for structures and to something clings and if to jump off that flies infinitely. Prompt please that to me to do and as it can be corrected. At me PC. For earlier thanks! Game simply class

21st Sep 2009, 12:08
ответтье пожалуйста на мой вопрос

1st Dec 2012, 12:59
I have a different problem.

I've played the game all the way up to the point where Batman gets the Freeze Gun Disruptor and you see that screen where it's introduced & he's holding it.

You have to press 'Enter' to continue.

Now, I noticed this earlier in the game - some of my keyboard keys don't function with this game. I can get into the map interface by hitting 'Tab', for instance, but to get out and back to the game, hitting 'ESC' does nothing. I have been manually clicking the words with the mouse pointer. So because the ESC and ENTER keys don't work, I've been getting by manually clicking the button symbols or the words with the mouse pointer.

And it's worked so far. Until now.

For some reason this new screen is different. It doesn't let you click the 'enter' symbol or the word 'ENTER' with the mouse pointer to continue.

I made sure my keyboard drive was updated, but that didn't fix it. I'm currently re-installing the game - after I put the save data in a separate folder and kept it.

I tried the Controls menu in the BM game launcher, but that doesn't have anything to do with the ESC or ENTER commands.

If this doesn't fix the problem, does any one have any ideas?