PDA

View Full Version : Controls not inverting (steam)



Mitsukayoi
15th Sep 2009, 22:13
Using the steam version and toggling the inverted controls switch before play. The problem is that the controls are still inverted, on either of the settings. Using a usb gamepad, vista 32, steam version, game version is 1.1

edited the BaseInput from what seemed to work for some other people on the steam forums and no dice. hate m/keyobard for this game, any info?

edited another section of BaseInput changing the left stick definitions for up and down under [Engine, UIInputConfiguration] and swapping the 0 and 1 values. This made the thumbstick work in the menu screen, but in game it still is not inverted for play.

This was a known issue for a long time and it's a bit frustrating when a controller is just so much better suited for this game. And please, I already paid out the money for a logitech and a usb adapter to use my PS2 pads, and they work fine with every other game I've thrown at them, including UE3 games, so please don't say 'just buy an xbox360 controller' as I find them the most uncomfortable controllers out there.

Mitsukayoi
16th Sep 2009, 00:15
Responding to my own message, but here's what I altered to manually invert the up/down problem with ps2 controllers. Not sure if this only pertains to the steam version but here we go.

If using steam, go to steam apps, common, batman for your folder. Otherwise find the folder for your batman directory.

go into BmGame --> Config (NOT Engine --> Config)

change this line
.Bindings=(Name="XboxTypeS_LeftY" ,Command="Axis aBaseY Speed=0.0 DeadZone=0.3 ....... (the dots are just in place of the rest of the line, don't add those)

to this line

.Bindings=(Name="XboxTypeS_LeftY" ,Command="Axis aBaseY Speed=-0.0 DeadZone=0.3 .......

Basically making the Speed=0.0 to Speed=-0.0 for the LeftY
Edit: change both cases of Speed=0.0 in this line for LeftY to Speed=-0.0, that will make sure movent and fighting and jumping/dodging are also inverted.

Hope this helps someone, because I've been fiddling with configs for a couple hours starting and restarting the program.

EDIT: Ok, not a perfect solution because aiming while fighting and jumping/dodging throws you in the opposite direction still. So this is only a temporary solution.

EDITx2: Ok, changed both cases of Speed=0.0 to Speed=-0.0 for the LeftY axis in the config file, and now fighting and jumping/dodging work without being inverted. And again, I am using the steam version, so I cannot say if the inversion toggle in the settings menu works on the other versions.

Cruis.In
16th Sep 2009, 03:34
thanks for this, i confirmed this bug on the demo, and it probably wont be fixed. i was using a logitech rumblepad 2 wireless or something i found it way easier than keyboard mouse.

Rockatansky
16th Sep 2009, 11:14
Thanks to the way Steam is handling the game, people don't know how to access the BmLauncher.exe to change the settings.
The BmLauncher.exe for the Demo could be found here:
C:\Program Files (x86)\Steam\SteamApps\common\batman arkham asylum - demo\Binaries
There should be a similar path for the full game.
With V1.1 there is an option to invert the stick.

Cruis.In
16th Sep 2009, 11:22
there was always an option to invert. it just never worked.

JayDeath
16th Sep 2009, 13:12
Yeah, Microsoft being greedy and wanting you to run out and get a 360 controller. Screw that! I have the logitech rumblepad too and after this fix everything is cool.

Mitsukayoi
16th Sep 2009, 13:28
Glad I could help, nothing like using the PS2 pads or the logitech pad.

KCQuetzal
18th Sep 2009, 02:26
What *.ini file does this edit occur in? I apologize if I missed it somewhere in the post. Kinda tired and have a headache! =)


Responding to my own message, but here's what I altered to manually invert the up/down problem with ps2 controllers. Not sure if this only pertains to the steam version but here we go.

If using steam, go to steam apps, common, batman for your folder. Otherwise find the folder for your batman directory.

go into BmGame --> Config (NOT Engine --> Config)

change this line
.Bindings=(Name="XboxTypeS_LeftY" ,Command="Axis aBaseY Speed=0.0 DeadZone=0.3 ....... (the dots are just in place of the rest of the line, don't add those)

to this line

.Bindings=(Name="XboxTypeS_LeftY" ,Command="Axis aBaseY Speed=-0.0 DeadZone=0.3 .......

Basically making the Speed=0.0 to Speed=-0.0 for the LeftY
Edit: change both cases of Speed=0.0 in this line for LeftY to Speed=-0.0, that will make sure movent and fighting and jumping/dodging are also inverted.

Hope this helps someone, because I've been fiddling with configs for a couple hours starting and restarting the program.

EDIT: Ok, not a perfect solution because aiming while fighting and jumping/dodging throws you in the opposite direction still. So this is only a temporary solution.

EDITx2: Ok, changed both cases of Speed=0.0 to Speed=-0.0 for the LeftY axis in the config file, and now fighting and jumping/dodging work without being inverted. And again, I am using the steam version, so I cannot say if the inversion toggle in the settings menu works on the other versions.

GhostMatter
18th Sep 2009, 02:51
Use this (http://www.tocaedit.com/IB/index.php?automodule=downloads&showfile=4) and be sure to copy dinput8.dll along with the two other files.

KCQuetzal
18th Sep 2009, 03:00
Found what I needed in BmInput.ini. Thanks for the suggestion it seems to work just fine now.


What *.ini file does this edit occur in? I apologize if I missed it somewhere in the post. Kinda tired and have a headache! =)

rigor
11th Oct 2009, 03:08
Thanks. This corrected my invert issue with my Logitech Rumblepad 2 and the Steam full v1.1 of Batman AA.

I edited the line mentioned above in the following path.

<drive letter>:\Steam\steamapps\common\batman arkham asylum\BmGame\Config\DefaultEngine.ini