PDA

View Full Version : PC USB Mini Lag Fix!!



IonAphis
14th Sep 2009, 22:09
I posted this on the threads, but I wish some mod make this sticky, because it could make life a lot easier to a lot of people, so I'm posting this here again. Notice this will not work for everyone (hopefully yes?), but if the fix doesn't work, try disabling unused devices (such as web-cams, joysticks, game-pads) that you're not going to be using. If all else fails, physically unplug these from your computer while you play.
Original post below:

Great news, I got it fixed. While looking around the internet alot of people stated that you could just disable the devices that were giving conflict and all would be gone. Well, I use a wireless desktop system (mouse and keyboard) and that wasn't an option. But i found something kind of interesting. When turning off HID Non-User Input Data Filter (KB 911895), the problem disappeared. I did not have to turn off any other HID devices or disconnect anything. Just go to Device Manager -> Human Interface Devices and turn off the data filters.
Apparently, this fix is intended to fix issues of multimedia keyboards and devices to keep the connection to the OS. It sort of keeps on establishing a connection in order to give full support for the keys in your keyboard and mouse. Mind you, turning these off means you'll not be able to actually use the "special" keys on your keyboard and specially assigned functions to either mouse and keyboard (assuming they are USB connected). Once you're done playing, just go back to the Device Manager and turn them back on. I realize this is not a solution, but until Eidos does something about it, it should work (and without having to go behind your PC and physically unplugging things).
Not sure it will work for everyone, but I think this is the most probable culprit.
Happy gaming,
Aphis

zelgadisgray
15th Sep 2009, 01:07
I just got the game and I'm using a Saitek Eclipse II keyboard so I'm screwed...
Not sure if I understand your fix correctly, don't it work on XP or only on Vista because I can't find the "data filters" in the device manager and does I'll be able to play with my keyboard or I'll have to play with a controller?

thx

JimProfit
15th Sep 2009, 01:19
I don't have this KB911895. are you running xp, IonAphis?

zelgadisgray, it's something you have to update to. it's probably a windows update download for xp as it doesn't exist as this kind of update for windows7 or probably not vista either so it can't be shut off. there's probably a different process, that does the same thing, you can turn off, or it's incorporated under something else. but I'm not going to screw around looking for it.

keep trucking ionaphis, eidos or io aren't going to be helping anyone it seems.

IonAphis
15th Sep 2009, 02:29
Running Windows 7, but this fix should be standard. It may have some other release code, but look for these in your Device Manager screen. If you can't find the data filters, try disabling some other HID input devices. Do one at a time, because if you do it all at once, you might disable your keyboard and mouse and you'll be stuck. Try one, if your mouse stops working, use the keyboard to turn it on, and vice-versa with your keyboard. You might have to disable cameras, input devices and etc. This "fix" isn't really a solution, so when running the game you might have to disable all your extra devices, but it sure beats disconnecting them.

By the way, about the controller thing: This is still an issue, because with this "fix" you'll be disabling everything, including controllers. If you leave the controller enabled, it might still lag; and if you want to play with the controller, you'd have to disable mouse and keyboard... I don't see how you could even start the game like that....
So this quick solution is only really valid if you want to play with the keyboard.

zelgadisgray
15th Sep 2009, 04:28
Tried to disable/enable all the items one by one the game still lagged...
I'll have to wait for a patch, I hate lazy port so much...

zelgadisgray
18th Sep 2009, 04:01
OK fixed my problem, I disabled HID-compliant consumer control device and all the other HID-compliant device. I lost my play/pause buttons and sound control on my keyboard but I don't use them anyway.

I can now play the game without lag :D