PDA

View Full Version : PC USB Problem



JimProfit
11th Sep 2009, 12:08
Ok, this stuttering problem caused by USB keyboards. Why does it still exist? It was exactly the same in Kane & Lynch. How hasn't it been destroyed by now? Are IOI not allowed to work on stuff like this by Eidos? I can understand not being able to patch Kane & Lynch to fix things like this, because I know what Eidos are like with patches after games are released. But for ****s sake, this issue should have been known LONG BEFORE THIS GAME WAS CLOSE TO BEING FINISHED. :mad2: :mad2: :mad2:

Yeah, I'm making a bigger deal of this than it actually is, because Mini Ninjas is completely fine to play on a controller. While K&L was a bit more awkward for me, and it was a bigger issue there. But really, having to unplug the keyboard each time I want to play this game is quite annoying.

Fix this.

Or at least ******* fix this for the next Hitman, if somehow this bug is in there aswell I will boat down to Denmark and punch you all in the soul.

Good day.

Falkenwut
11th Sep 2009, 12:17
I recommend you trying to install an old Graphics card driver. It helped me with Kane and lynch, coz SOME people didn't have the USB issue.

I think it's the Engine which is causing this issue. They may have modded the gameplay but it's not following for newer PC Hardware.

JimProfit
11th Sep 2009, 12:23
There's no way I'm going to do that, and also my videocard is newer than that, so the oldest possible driver for it wouldn't make the difference. This is clearly a problem with their engine/game and they should fix it. Isn't Hitman Blood Money supposed to be running the same engine, although obviously an older version? That game is fine and doesn't have this issue at all.

Falkenwut
11th Sep 2009, 12:47
There's no way I'm going to do that, and also my videocard is newer than that, so the oldest possible driver for it wouldn't make the difference. This is clearly a problem with their engine/game and they should fix it. Isn't Hitman Blood Money supposed to be running the same engine, although obviously an older version? That game is fine and doesn't have this issue at all.

That's because the Engine during the development of Hitman 4 , the engine had less features. Clearly by the time the creation of kane and lynch there was this 1 Feature which collided with some PC hardware.

Even if you hardware is brand new, I still recommend trying to find older software for it.

It may set you back but if you REALLY wish to finish mini ninjas, I recommend you try it.

JimProfit
11th Sep 2009, 13:28
You clearly don't understand. I'm running a GTX295 under Windows7 x64. There's no help in going back to the first driver for it.

And yeah, that's what I'm saying they BROKE something in the software and somehow haven't been able through fix it through a whole cycle there. It's ridiculous.

Barkhing
13th Sep 2009, 08:11
I agree, the fact they haven't fixed such a persistent issue over two games is pretty sad.

Mini ninjas still rocks though.

IonAphis
13th Sep 2009, 15:40
I noticed in the options menu, where it says "Use Controller", it's says On (or Yes, I don't remember now), but it's greyed out and I can't turn controller Off. Someone on another post said they thought the game studdered because it was looking for connected controllers and couldn't find any and as a result it would do that lag thing. If I could turn the "Use Controller" Off, that might help? But it's greyed out so... I'm kind of lost now... Eidos, please solve this...
Aphis

IonAphis
14th Sep 2009, 22:08
Great news, I got it fixed. While looking around the internet alot of people stated that you could just disable the devices that were giving conflict and all would be gone. Well, I use a wireless desktop system (mouse and keyboard) and that wasn't an option. But i found something kind of interesting. When turning off HID Non-User Input Data Filter (KB 911895), the problem disappeared. I did not have to turn off any other HID devices or disconnect anything. Just go to Device Manager -> Human Interface Devices and turn off the data filters.
Apparently, this fix is intended to fix issues of multimedia keyboards and devices to keep the connection to the OS. It sort of keeps on establishing a connection in order to give full support for the keys in your keyboard and mouse. Mind you, turning these off means you'll not be able to actually use the "special" keys on your keyboard and specially assigned functions to either mouse and keyboard (assuming they are USB connected). Once you're done playing, just go back to the Device Manager and turn them back on. I realize this is not a solution, but until Eidos does something about it, it should work (and without having to go behind your PC and physically unplugging things).
Not sure it will work for everyone, but I think this is the most probable culprit.
Happy gaming,
Aphis