PDA

View Full Version : Customize Physx features?



Claptovaughn
10th Sep 2009, 20:12
Would it be possible to mod it so we can choose which Physx features to have on or off?

In the demo, my framerates dropped like crazy during the tile scene with Zsasz yet it handled the heavily steamed/smoked areas just fine. I would gladly turn off the environment destruction (which, in the demo, is pretty rare and useless anyways) but would like to keep the steam as I feel it adds a great deal of atmosphere.

I can do without the flapping paper sheets too, since that's got to affect performance a bit as well.

Nemesis296
10th Sep 2009, 20:27
Would it be possible to mod it so we can choose which Physx features to have on or off?

In the demo, my framerates dropped like crazy during the tile scene with Zsasz yet it handled the heavily steamed/smoked areas just fine. I would gladly turn off the environment destruction (which, in the demo, is pretty rare and useless anyways) but would like to keep the steam as I feel it adds a great deal of atmosphere.

I can do without the flapping paper sheets too, since that's got to affect performance a bit as well.

It's interesting that I experience the same spike only at this one part. Mods, what's happening?

Claptovaughn
10th Sep 2009, 20:37
I don't have the pc with Batman installed with me right now, but I remember finding some settings in the config files that appear to control environment damage. Changing it, however, did nothing.

There's got to be a way to do it. Turn the shotgun Physx setting on, and then turn specific features off.

sertz
11th Sep 2009, 02:40
i'm having the same issues with severe slowdown in areas when physx are enabled. my rig really shouldnt slow down at all either... i have a core i7 920 overclocked to 3.35GHz, an eVGA geforce gtx 275 896mb video card, 3GB corsair xms3 ddr3-1600 ram...

funny thing is, when physx are disabled everything is silky smooth no matter how many things are going on, but as soon as i turn physx on it plays great right up until you walk through the smoke in the first hallway, or smash zsasz into the ground. hopefully will be fixed upon release or through a patch!

Nemesis296
11th Sep 2009, 04:12
It's possible that this will be resolved with the new PhysX release on the 15th...the day the game comes out. We don't know the exact reason for why the PC version was delayed, but this could be it :)